aboutsummaryrefslogtreecommitdiff
path: root/net/ipw-firmware
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-05-16 08:11:31 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-05-16 08:11:31 +0000
commit93b3ce47c7df8fa680714bcefd86ff5e284ece6b (patch)
tree2c6dcbcd603f9b064c2b86080311a212bb281136 /net/ipw-firmware
parentda8124267bcfb529216a025a9a5ec7fa0484a9bb (diff)
downloadports-93b3ce47c7df8fa680714bcefd86ff5e284ece6b.tar.gz
ports-93b3ce47c7df8fa680714bcefd86ff5e284ece6b.zip
Notes
Diffstat (limited to 'net/ipw-firmware')
-rw-r--r--net/ipw-firmware/Makefile50
-rw-r--r--net/ipw-firmware/distinfo4
-rw-r--r--net/ipw-firmware/files/ipw.sh.in66
-rw-r--r--net/ipw-firmware/files/pkg-message.in38
-rw-r--r--net/ipw-firmware/pkg-descr9
-rw-r--r--net/ipw-firmware/pkg-plist6
-rw-r--r--net/ipw-firmware/pkg-req222
7 files changed, 395 insertions, 0 deletions
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
new file mode 100644
index 000000000000..f0c9dac8ef11
--- /dev/null
+++ b/net/ipw-firmware/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ipw-firmware
+# Date created: May 11 2005
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipw-firmware
+PORTVERSION= 1.3
+CATEGORIES= net sysutils
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= flz/ipw
+DISTFILES= ipw2100-fw-${PORTVERSION}.tgz
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Intel PRO/Wireless 2100 Driver Firmware
+
+IPW_VERSION= 1.6.4
+DISTFILES+= ipw-freebsd-${IPW_VERSION}.tgz
+
+WRKSRC= ${WRKDIR}
+SUB_FILES= pkg-message
+SUB_LIST= PORTVERSION="${PORTVERSION}"
+MAKE_ENV= BINDIR="${PREFIX}/sbin" MANDIR="${PREFIX}/man/man"
+USE_RC_SUBR= ipw.sh
+
+MAN8= ipwcontrol.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ cd ${WRKSRC}/ipw-freebsd-${IPW_VERSION}/src/usr.sbin/ipwcontrol/; make all
+
+do-install:
+.if !defined(PACKAGE_BUILDING)
+# Let pointyhat build the package, anyway the user will have to agree with license
+# terms to install the port/package.
+ ${SH} ${PKGREQ} ${PORTNAME} INSTALL
+.endif
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/ipw-freebsd-${IPW_VERSION}/src/usr.sbin/ipwcontrol/; make install ${MAKE_ENV}
+.for i in LICENSE ipw2100-1.3-i.fw ipw2100-1.3-p.fw ipw2100-1.3.fw
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DATADIR}/
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/ipw-firmware/distinfo b/net/ipw-firmware/distinfo
new file mode 100644
index 000000000000..2ed34c538801
--- /dev/null
+++ b/net/ipw-firmware/distinfo
@@ -0,0 +1,4 @@
+MD5 (ipw2100-fw-1.3.tgz) = 46aa75bcda1a00efa841f9707bbbd113
+SIZE (ipw2100-fw-1.3.tgz) = 248471
+MD5 (ipw-freebsd-1.6.4.tgz) = 4af640b3fe9035884dd03cbd2e8b1c27
+SIZE (ipw-freebsd-1.6.4.tgz) = 23051
diff --git a/net/ipw-firmware/files/ipw.sh.in b/net/ipw-firmware/files/ipw.sh.in
new file mode 100644
index 000000000000..c208e6477688
--- /dev/null
+++ b/net/ipw-firmware/files/ipw.sh.in
@@ -0,0 +1,66 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ipw
+# REQUIRE: LOGIN abi
+# BEFORE: securelevel
+# KEYWORD: FreeBSD shutdown
+
+# Add the following line to /etc/rc.conf to enable `ipw':
+#
+# ipw_enable="YES"
+#
+
+. "%%RC_SUBR%%"
+
+name="ipw"
+rcvar=`set_rcvar`
+
+start_cmd="ipw_start_cmd"
+stop_cmd="ipw_stop_cmd"
+
+load_rc_config "$name"
+: ${ipw_enable="NO"}
+: ${ipw_interfaces="ipw0"}
+
+command="/usr/sbin/ipwcontrol"
+
+ipw_start_cmd()
+{
+ echo -n "Starting ipw"
+ for i in ${ipw_interfaces}; do
+ eval _mode=\$ipw_mode_${i}
+ case ${_mode} in
+ ""|bss)
+ eval _ipw_file_${i}="ipw2100-%%PORTVERSION%%.fw"
+ ;;
+ ibss)
+ eval _ipw_file_${i}="ipw2100-%%PORTVERSION%%-i.fw"
+ ;;
+ monitor)
+ eval _ipw_file_${i}="ipw2100-%%PORTVERSION%%-p.fw"
+ ;;
+ *)
+ echo "${_mode} - Possible values for ipw_mode_${i} are bss|ibss|monitor."
+ exit 1
+ ;;
+ esac
+
+ eval _file=\$_ipw_file_${i}
+ echo -n " [${i}:${_mode:=bss}]"
+ ${command} -i ${i} -f %%DATADIR%%/${_file}
+ done
+ echo "."
+}
+
+ipw_stop_cmd()
+{
+ echo "Stopping ipw."
+ for i in ${ipw_interfaces}; do
+ ${command} -i ${i} -k
+ done
+}
+
+run_rc_command "$1"
diff --git a/net/ipw-firmware/files/pkg-message.in b/net/ipw-firmware/files/pkg-message.in
new file mode 100644
index 000000000000..1fd56452065f
--- /dev/null
+++ b/net/ipw-firmware/files/pkg-message.in
@@ -0,0 +1,38 @@
+------------------------------------------------------------------
+This port has installed following files in %%DATADIR%%:
+
+ - LICENSE : License terms,
+ - ipw2100-1.3-i.fw : IBSS mode (aka ad-hoc mode) firmware,
+ - ipw2100-1.3-p.fw : Monitor mode firmware,
+ - ipw2100-1.3.fw : BSS mode (aka infrastructure mode) firmware.
+
+Ensure you've read license terms carefully before you use this
+firmware.
+
+You must choose the correct image depending on how you want to
+use your adapter.
+
+For instance, to download firmware for BSS mode:
+
+ # ipwcontrol -i ipw0 \
+ -f %%DATADIR%%/ipw2100-1.3.fw
+
+The port has installed a startup script (ipw.sh). Add these lines
+to /etc/rc.conf to use it :
+
+ - ipw_enable (bool) : defaults to "NO", set it to "YES" to
+ use the startup script.
+ - ipw_interfaces (str) : defaults to "ipw0", override it to
+ change to interface names list (optional).
+ - ipw_mode_<iface> (str) : defaults to "bss", possible values
+ are bss, ibss and monitor (optional).
+
+Note:
+
+This port requires ipw(4) driver which has not been MFC'ed to
+RELENG_5 yet. Point your web browser at [1] and install it by hand
+if not already done.
+
+[1] http://damien.bergamini.free.fr/ipw/
+
+------------------------------------------------------------------
diff --git a/net/ipw-firmware/pkg-descr b/net/ipw-firmware/pkg-descr
new file mode 100644
index 000000000000..da0531a28fa7
--- /dev/null
+++ b/net/ipw-firmware/pkg-descr
@@ -0,0 +1,9 @@
+This project was created by Intel to enable support for the Intel
+PRO/Wireless 2100 Network Connection mini PCI adapter. This project
+(IPW2100) is intended to be a community effort as much as is possible
+given some working constraints (mainly, no HW documentation is available).
+
+WWW: http://ipw2100.sourceforge.net/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/net/ipw-firmware/pkg-plist b/net/ipw-firmware/pkg-plist
new file mode 100644
index 000000000000..0a6f68ea8133
--- /dev/null
+++ b/net/ipw-firmware/pkg-plist
@@ -0,0 +1,6 @@
+sbin/ipwcontrol
+%%DATADIR%%/LICENSE
+%%DATADIR%%/ipw2100-1.3-i.fw
+%%DATADIR%%/ipw2100-1.3-p.fw
+%%DATADIR%%/ipw2100-1.3.fw
+@dirrm %%DATADIR%%
diff --git a/net/ipw-firmware/pkg-req b/net/ipw-firmware/pkg-req
new file mode 100644
index 000000000000..e3696b37222f
--- /dev/null
+++ b/net/ipw-firmware/pkg-req
@@ -0,0 +1,222 @@
+#! /bin/sh
+
+case "$2" in
+INSTALL)
+ cat << EOF | more
+ TERMS AND CONDITIONS
+ IMPORTANT - PLEASE READ BEFORE INSTALLING OR USING THIS INTEL(C) SOFTWARE
+
+Do not use or load this firmware (the "Software") until you have carefully read
+the following terms and conditions. By loading or using the Software, you agree
+to the terms of this Agreement. If you do not wish to so agree, do not install
+or use the Software.
+
+LICENSEES:
+
+Please note:
+
+* If you are an End-User, only Exhibit A, the SOFTWARE LICENSE AGREEMENT,
+ applies.
+* If you are an Original Equipment Manufacturer (OEM), Independent Hardware
+ Vendor (IHV), or Independent Software Vendor (ISV), this complete Agreement
+ applies
+
+--------------------------------------------------------------------------------
+
+For OEMs, IHVs, and ISVs:
+
+LICENSE. This Software is licensed for use only in conjunction with Intel
+component products. Use of the Software in conjunction with non-Intel component
+products is not licensed hereunder. Subject to the terms of this Agreement,
+Intel grants to you a nonexclusive, nontransferable, worldwide, fully paid-up
+license under Intel's copyrights to: (i) copy the Software internally for your
+own development and maintenance purposes; (ii) copy and distribute the Software
+to your end-users, but only under a license agreement with terms at least as
+restrictive as those contained in Intel's Final, Single User License Agreement,
+attached as Exhibit A; and (iii) modify, copy and distribute the end-user
+documentation which may accompany the Software, but only in association with
+the Software.
+
+If you are not the final manufacturer or vendor of a computer system or software
+program incorporating the Software, then you may transfer a copy of the
+Software, including any related documentation (modified or unmodified) to your
+recipient for use in accordance with the terms of this Agreement, provided such
+recipient agrees to be fully bound by the terms hereof. You shall not otherwise
+assign, sublicense, lease, or in any other way transfer or disclose Software to
+any third party. You may not, nor may you assist any other person or entity to
+modify, translate, convert to another programming language, decompile, reverse
+engineer, or disassemble any portion of the Software or otherwise attempt to
+derive source code from any object code modules of the Software or any internal
+data files generated by the Software. Your rights to redistribute the Software
+shall be contingent upon your installation of this Agreement in its entirety in
+the same directory as the Software.
+
+CONFIDENTIALITY. If you wish to have a third party consultant or subcontractor
+("Contractor") perform work on your behalf which involves access to or use of
+Software, you shall obtain a written confidentiality agreement from the
+Contractor which contains provisions with respect to access to or use of the
+Software no less restrictive than those set forth in this Agreement and
+excluding any distribution rights, and use for any other purpose. Except as
+expressly provided herein, you shall not disclose the terms or existence of
+this Agreement or use Intel's name in any publications, advertisements, or
+other announcements without Intel's prior written consent. You do not have any
+rights to use any Intel trademarks or logos.
+
+OWNERSHIP OF SOFTWARE AND COPYRIGHTS. Software and accompanying materials, if
+any, are owned by Intel or its suppliers and licensors and may be protected by
+copyright, trademark, patent and trade secret law and international treaties.
+Any rights, express or implied, in the intellectual property embodied in the
+foregoing, other than those specified in this Agreement, are reserved by Intel
+and its suppliers and licensors or otherwise as set forth in any applicable
+open source license agreement. You will keep the Software free of liens,
+attachments, and other encumbrances. You agree not to remove any proprietary
+notices and/or any labels from the Software and accompanying materials without
+prior written approval by Intel
+
+LIMITATION OF LIABILITY. IN NO EVENT SHALL INTEL OR ITS SUPPLIERS AND LICENSORS
+BE LIABLE FOR ANY DAMAGES WHATSOEVER FROM ANY CAUSE OF ACTION OF ANY KIND
+(INCLUDING, WITHOUT LIMITATION, LOST PROFITS, BUSINESS INTERRUPTION, OR LOST
+INFORMATION) ARISING OUT OF THE USE, MODIFICATION, OR INABILITY TO USE THE
+INTEL SOFTWARE, OR OTHERWISE, NOR FOR PUNITIVE, INCIDENTAL, CONSEQUENTIAL, OR
+SPECIAL DAMAGES OF ANY KIND, EVEN IF INTEL OR ITS SUPPLIERS AND LICENSORS HAS
+BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME JURISDICTIONS PROHIBIT
+EXCLUSION OR LIMITATION OF LIABILITY FOR IMPLIED WARRANTIES, CONSEQUENTIAL OR
+INCIDENTAL DAMAGES, SO CERTAIN LIMITATIONS MAY NOT APPLY. YOU MAY ALSO HAVE
+OTHER LEGAL RIGHTS THAT VARY BETWEEN JURISDICTIONS.
+
+EXCLUSION OF WARRANTIES. THE SOFTWARE IS PROVIDED "AS IS" AND POSSIBLY WITH
+FAULTS. UNLESS EXPRESSLY AGREED OTHERWISE, INTEL AND ITS SUPPLIERS AND
+LICENSORS DISCLAIM ANY AND ALL WARRANTIES AND GUARANTEES, EXPRESS, IMPLIED OR
+OTHERWISE, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+NONINFRINGEMENT, OR FITNESS FOR A PARTICULAR PURPOSE. Intel does not warrant
+or assume responsibility for the accuracy or completeness of any information,
+text, graphics, links or other items contained within the Software. You assume
+all liability, financial or otherwise, associated with Your use or disposition
+of the Software.
+
+APPLICABLE LAW. Claims arising under this Agreement shall be governed by the
+laws of State of California], excluding its principles of conflict of laws and
+the United Nations Convention on Contracts for the Sale of Goods.
+
+WAIVER AND AMENDMENT. No modification, amendment or waiver of any provision of
+this Agreement shall be effective unless in writing and signed by an officer of
+Intel. No failure or delay in exercising any right, power, or remedy under
+this Agreement shall operate as a waiver of any such right, power or remedy.
+Without limiting the foregoing, terms and conditions on any purchase orders or
+similar materials submitted by you to Intel, and any terms contained in Intel’s
+standard acknowledgment form that are in conflict with these terms, shall be of
+no force or effect.
+
+SEVERABILITY. If any provision of this Agreement is held by a court of
+competent jurisdiction to be contrary to law, such provision shall be changed
+and interpreted so as to best accomplish the objectives of the original
+provision to the fullest extent allowed by law and the remaining provisions of
+this Agreement shall remain in full force and effect.
+
+EXPORT RESTRICTIONS. Each party acknowledges that the Software is subject to
+applicable import and export regulations of the United States and of the
+countries in which each party transacts business, specifically including U.S.
+Export Administration Act and Export Administration Regulations. Each party
+shall comply with such laws and regulations, as well as all other laws and
+regulations applicable to the Software. Without limiting the generality of the
+foregoing, each party agrees that it will not export, re-export, transfer or
+divert any of the Software or the direct programs thereof to any restricted
+place or party in accordance with U.S. export regulations. Note that Software
+containing encryption may be subject to additional restrictions.
+
+GOVERNMENT RESTRICTED RIGHTS. The Software is provided with "RESTRICTED RIGHTS."
+Use, duplication, or disclosure by the Government is subject to restrictions as
+set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or their successors. Use
+of the Software by the Government constitutes acknowledgment of Intel's
+proprietary rights therein. Contractor or Manufacturer is Intel Corporation,
+2200 Mission College Blvd., Santa Clara, CA 95052.
+
+TERMINATION OF THE AGREEMENT. Intel may terminate this Agreement if you violate
+its terms. Upon termination, you will immediately destroy the Software or
+return all copies of the Software to Intel.
+
+--------------------------------------------------------------------------------
+
+EXHIBIT "A"
+
+SOFTWARE LICENSE AGREEMENT (Final, Single User)
+
+IMPORTANT - READ BEFORE COPYING, INSTALLING OR USING.
+
+Do not use or load this firmware image (the "Software") until you have carefully
+read the following terms and conditions. By loading or using the Software, you
+agree to the terms of this Agreement. If you do not wish to so agree, do not
+install or use the Software.
+
+LICENSE. You may copy and use the Software, subject to these conditions:
+1. This Software is licensed for use only in conjunction with Intel component
+ products. Use of the Software in conjunction with non-Intel component
+ products is not licensed hereunder.
+2. You may not copy, modify, rent, sell, distribute or transfer any part of the
+ Software except as provided in this Agreement, and you agree to prevent
+ unauthorized copying of the Software.
+3. You may not reverse engineer, decompile, or disassemble the Software.
+4. You may not sublicense the Software.
+5. The Software may contain the software or other property of third party
+ suppliers.
+
+OWNERSHIP OF SOFTWARE AND COPYRIGHTS. Title to all copies of the Software
+remains with Intel or its suppliers. The Software is copyrighted and protected
+by the laws of the United States and other countries, and international treaty
+provisions. You may not remove any copyright notices from the Software. Intel
+may make changes to the Software, or items referenced therein, at any time
+without notice, but is not obligated to support or update the Software. Except
+as otherwise expressly provided, Intel grants no express or implied right under
+Intel patents, copyrights, trademarks, or other intellectual property rights.
+You may transfer the Software only if a copy of this license accompanies the
+Software and the recipient agrees to be fully bound by these terms.
+
+EXCLUSION OF OTHER WARRANTIES EXCEPT AS PROVIDED ABOVE, THE SOFTWARE IS PROVIDED
+"AS IS" WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING
+WARRANTIES OF MERCHANTABILITY, NONINFRINGEMENT, OR FITNESS FOR A PARTICULAR
+PURPOSE. Intel does not warrant or assume responsibility for the accuracy or
+completeness of any information, text, graphics, links or other items contained
+within the Software.
+
+LIMITATION OF LIABILITY. IN NO EVENT SHALL INTEL OR ITS SUPPLIERS BE LIABLE FOR
+ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, LOST PROFITS, BUSINESS
+INTERRUPTION, OR LOST INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO
+USE THE SOFTWARE, EVEN IF INTEL HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGES. SOME JURISDICTIONS PROHIBIT EXCLUSION OR LIMITATION OF LIABILITY FOR
+IMPLIED WARRANTIES OR CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE
+LIMITATION MAY NOT APPLY TO YOU. YOU MAY ALSO HAVE OTHER LEGAL RIGHTS THAT VARY
+BETWEEN JURISDICTIONS.
+
+TERMINATION OF THIS AGREEMENT. Intel may terminate this Agreement at any time if
+you violate its terms. Upon termination, you will immediately destroy the
+Software.
+
+APPLICABLE LAWS. Claims arising under this Agreement shall be governed by the
+laws of California, excluding its principles of conflict of laws and the United
+Nations Convention on Contracts for the Sale of Goods. You may not export the
+Software in violation of applicable export laws and regulations. Intel is not
+obligated under any other agreements unless they are in writing and signed by
+an authorized representative
+of Intel.
+
+GOVERNMENT RESTRICTED RIGHTS. The Software is provided with "RESTRICTED RIGHTS."
+Use, duplication, or disclosure by the Government is subject to restrictions as
+set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or their successors. Use
+of the Software by the Government constitutes acknowledgment of Intel's
+proprietary rights therein. Contractor or Manufacturer is Intel Corporation,
+2200 Mission College Blvd., Santa Clara, CA 95052.
+
+EOF
+
+ echo -n "Do you agree with these terms [y/N] ? "
+ read answer
+
+ if [ "${answer}" != "y" -a "${answer}" != "Y" ]; then
+ exit 1
+ else
+ exit 0
+ fi
+ ;;
+*)
+ ;;
+esac