aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp30-server/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-07-25 18:34:18 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-07-25 18:34:18 +0000
commit9b02ae4cc0773430fea2aec6fbae4d609b3cdeaa (patch)
treea6041c4f564d8efe05a44d8d88a7a3d0705e84e3 /net/isc-dhcp30-server/Makefile
parent709005204d867cee2c6b6a71cdb1a1e713820190 (diff)
downloadports-9b02ae4cc0773430fea2aec6fbae4d609b3cdeaa.tar.gz
ports-9b02ae4cc0773430fea2aec6fbae4d609b3cdeaa.zip
Notes
Diffstat (limited to 'net/isc-dhcp30-server/Makefile')
-rw-r--r--net/isc-dhcp30-server/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index c536c48ed1ab..646175fafee8 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= dhcp
-PORTVERSION= 3.0.2
-PORTREVISION= 8
+PORTVERSION= 3.0.3
+PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= dhcp dhcp/dhcp-3.0-history
@@ -31,6 +31,7 @@ OPTIONS= INTERFACE_POLLING "interface polling support" on
.if ${SUBSYS} == server
OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
DHCP_JAIL "add -chroot and -jail options" on \
+ DHCP_SOCKETS "use sockets instead of /dev/bpf (jail-only)" off \
DHCP_LDAP "add experimental LDAP backend support" off \
DHCP_LDAP_SSL "support LDAP connection over SSL/TLS" on \
OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
@@ -42,9 +43,9 @@ OPTIONS= DHCP_PARANOIA "add -user, -group and -chroot options" on \
.if ${SUBSYS} == server && defined(WITH_DHCP_LDAP)
# Based on patch from Brian Masney :
-PATCH_SITES= http://www.newwave.net/~masneyb/ \
- ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
-PATCHFILES= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-ldap-patch
+PATCH_SITES= http://www.newwave.net/~masneyb/:ldap \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/:ldap
+PATCHFILES= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-ldap-patch:ldap
PATCH_DIST_STRIP= -p1
USE_PERL5_RUN= yes
@@ -59,9 +60,9 @@ USE_OPENSSL= yes
.if ${SUBSYS} == server && defined(WITH_DHCP_LQ)
# Based on patch from Dmitry Sukhodoev :
-PATCH_SITES= http://bingo.ru/~raven/FreeBSD/patches/ \
- ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/
-PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch
+PATCH_SITES+= http://bingo.ru/~raven/FreeBSD/patches/:dlq \
+ ftp://ftp.frm2.tum.de/pub/jpulz/FreeBSD/:dlq
+PATCHFILES+= ${PORTNAME}-${RELEASE}${VERSION}${PATCHLEVEL}-dlq-patch:dlq
.endif
# Global variables
@@ -225,6 +226,9 @@ patch-site-conf:
.endif
.if !defined(WITHOUT_DHCP_JAIL)
@${ECHO_CMD} CFLAGS += -DJAIL >> ${WRKSRC}/site.conf
+.if defined(WITH_DHCP_SOCKETS)
+ @${ECHO_CMD} CFLAGS += -DUSE_SOCKETS >> ${WRKSRC}/site.conf
+.endif
.endif
.if defined(WITH_DHCP_LDAP)
@${ECHO_CMD} CFLAGS += -I${LOCALBASE}/include >> ${WRKSRC}/site.conf