aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp30-server
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-03-23 01:33:47 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-03-23 01:33:47 +0000
commit14a6bfe50d6ae2149e4939c44aeb0e4abebfc47a (patch)
tree57700772207c17f0b3f1fdf3c106a89abcd381a8 /net/isc-dhcp30-server
parent80a08c7b73669a37d322c653143b364de2015496 (diff)
downloadports-14a6bfe50d6ae2149e4939c44aeb0e4abebfc47a.tar.gz
ports-14a6bfe50d6ae2149e4939c44aeb0e4abebfc47a.zip
Notes
Diffstat (limited to 'net/isc-dhcp30-server')
-rw-r--r--net/isc-dhcp30-server/Makefile15
-rw-r--r--net/isc-dhcp30-server/distinfo2
-rw-r--r--net/isc-dhcp30-server/files/patch-dhclient.822
-rw-r--r--net/isc-dhcp30-server/files/patch-dhclient.c6
-rw-r--r--net/isc-dhcp30-server/files/patch-freebsd12
5 files changed, 33 insertions, 24 deletions
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
index a5f26e0dda2e..cfb74b959477 100644
--- a/net/isc-dhcp30-server/Makefile
+++ b/net/isc-dhcp30-server/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dhcp
-PORTVERSION= 3.0.b2.18
+PORTVERSION= 3.0.b2.22
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/
PKGNAMEPREFIX= isc-
@@ -32,7 +32,7 @@ MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
# Local variables
#
-PATCH_SUBDIRS= client common dhcpctl dst minires omapip relay server
+PATCH_SUBDIRS= common minires dst omapip server client relay dhcpctl
BIN_FILES= dhclient dhcpd dhcrelay
SAMP_FILES= client/dhclient.conf server/dhcpd.conf
@@ -53,16 +53,19 @@ STRIP?= strip
# Post-patch
#
-post-patch: patch-scripts patch-makefiles
+post-patch: patch-scripts patch-makefile-conf patch-makefiles-dist
patch-scripts:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' \
${WRKSRC}/client/scripts/freebsd
-patch-makefiles:
+patch-makefile-conf:
+ @${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
+ ${WRKSRC}/Makefile.conf
+
+patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e \
- 's|^DEBUG[ ]*=|DEBUG ?=|g;s|^CFLAGS[ ]*=|CFLAGS +=|g' \
+ @${PERL} -pi.fbsd -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor
diff --git a/net/isc-dhcp30-server/distinfo b/net/isc-dhcp30-server/distinfo
index 16de2cef3ac6..384d4e1e0335 100644
--- a/net/isc-dhcp30-server/distinfo
+++ b/net/isc-dhcp30-server/distinfo
@@ -1 +1 @@
-MD5 (dhcp-3.0b2pl18.tar.gz) = 807485e8f6f6ad9028201b9f22354b3e
+MD5 (dhcp-3.0b2pl22.tar.gz) = 9a0155b192a82bd44b38fa6ceae7976e
diff --git a/net/isc-dhcp30-server/files/patch-dhclient.8 b/net/isc-dhcp30-server/files/patch-dhclient.8
index 2ba9899869c3..d92e06169d76 100644
--- a/net/isc-dhcp30-server/files/patch-dhclient.8
+++ b/net/isc-dhcp30-server/files/patch-dhclient.8
@@ -1,15 +1,21 @@
---- client/dhclient.8.orig Mon May 1 19:11:36 2000
-+++ client/dhclient.8 Fri Jan 26 05:12:37 2001
-@@ -34,7 +34,7 @@
+--- client/dhclient.8.orig Thu Mar 1 23:11:12 2001
++++ client/dhclient.8 Thu Mar 22 04:04:29 2001
+@@ -34,12 +34,12 @@
.B -q
]
[
-.B -c
+.B -1
]
++[
+ .B -r
+ ]
[
+-[
.B -lf
-@@ -49,6 +49,10 @@
+ .I lease-file
+ ]
+@@ -52,6 +52,10 @@
.I config-file
]
[
@@ -20,9 +26,9 @@
.B -s
server
]
-@@ -174,17 +178,25 @@
- flag prevents any messages other than errors from being printed to the
- standard error descriptor.
+@@ -184,17 +188,25 @@
+ .B -r
+ flag explicitly releases the current lease.
.PP
+The
+.B -1
@@ -50,7 +56,7 @@
flags, respectively, followed by the name of the file. This can be
particularly useful if, for example,
.B DBDIR
-@@ -206,10 +218,12 @@
+@@ -216,10 +228,12 @@
.SH CONFIGURATION
The syntax of the dhclient.conf(8) file is discussed seperately.
.SH FILES
diff --git a/net/isc-dhcp30-server/files/patch-dhclient.c b/net/isc-dhcp30-server/files/patch-dhclient.c
index 5828f2d2c088..b1f5599304aa 100644
--- a/net/isc-dhcp30-server/files/patch-dhclient.c
+++ b/net/isc-dhcp30-server/files/patch-dhclient.c
@@ -1,5 +1,5 @@
---- client/dhclient.c.orig Thu Feb 15 23:17:05 2001
-+++ client/dhclient.c Fri Mar 2 05:51:43 2001
+--- client/dhclient.c.orig Fri Mar 16 00:12:03 2001
++++ client/dhclient.c Thu Mar 22 02:49:59 2001
@@ -78,6 +78,7 @@
u_int16_t remote_port;
int no_daemon;
@@ -45,7 +45,7 @@
log_info (url);
- log_error ("Usage: dhclient [-d] [-D] [-q] [-p <port>] %s",
-+ log_error ("Usage: dhclient [-1] [-d] [-D] [-q] [-p <port>] %s",
++ log_error ("Usage: dhclient [-1dDqr] [-p <port>] %s",
"[-s server]");
- log_fatal (" [-lf lease-file] [-pf pid-file]%s",
- "[-cf config-file] [interface] [-e VAR=val]");
diff --git a/net/isc-dhcp30-server/files/patch-freebsd b/net/isc-dhcp30-server/files/patch-freebsd
index 2376cbb7ec40..e4da6d9797d8 100644
--- a/net/isc-dhcp30-server/files/patch-freebsd
+++ b/net/isc-dhcp30-server/files/patch-freebsd
@@ -1,5 +1,5 @@
---- client/scripts/freebsd.orig Wed Sep 20 11:38:03 2000
-+++ client/scripts/freebsd Sat Jan 27 02:17:01 2001
+--- client/scripts/freebsd.orig Fri Mar 16 00:16:49 2001
++++ client/scripts/freebsd Thu Mar 22 02:42:13 2001
@@ -1,5 +1,11 @@
#!/bin/sh
@@ -71,8 +71,8 @@
fi
if [ x$old_ip_address = x ] || [ x$old_ip_address != x$new_ip_address ] || \
[ x$reason = xBOUND ] || [ x$reason = xREBOOT ]; then
- ifconfig $interface inet $new_ip_address $new_netmask_arg \
- $new_broadcast_arg $medium
+ eval "ifconfig $interface inet $new_ip_address $new_netmask_arg \
+ $new_broadcast_arg $medium"
+ $LOGGER "New IP Address($interface): $new_ip_address"
+ $LOGGER "New Subnet Mask($interface): $new_subnet_mask"
+ $LOGGER "New Broadcast Address($interface): $new_broadcast_address"
@@ -108,8 +108,8 @@
if [ x$alias_ip_address != x ]; then
@@ -161,9 +174,13 @@
fi
- ifconfig $interface inet $new_ip_address $new_netmask_arg \
- $new_broadcast_arg $medium
+ eval "ifconfig $interface inet $new_ip_address $new_netmask_arg \
+ $new_broadcast_arg $medium"
+ $LOGGER "New IP Address($interface): $new_ip_address"
+ $LOGGER "New Subnet Mask($interface): $new_subnet_mask"
+ $LOGGER "New Broadcast Address($interface): $new_broadcast_address"