aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp40-server/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-03-23 01:33:47 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-03-23 01:33:47 +0000
commit14a6bfe50d6ae2149e4939c44aeb0e4abebfc47a (patch)
tree57700772207c17f0b3f1fdf3c106a89abcd381a8 /net/isc-dhcp40-server/Makefile
parent80a08c7b73669a37d322c653143b364de2015496 (diff)
Notes
Diffstat (limited to 'net/isc-dhcp40-server/Makefile')
-rw-r--r--net/isc-dhcp40-server/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index a5f26e0dda2e..cfb74b959477 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dhcp
-PORTVERSION= 3.0.b2.18
+PORTVERSION= 3.0.b2.22
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/
PKGNAMEPREFIX= isc-
@@ -32,7 +32,7 @@ MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
# Local variables
#
-PATCH_SUBDIRS= client common dhcpctl dst minires omapip relay server
+PATCH_SUBDIRS= common minires dst omapip server client relay dhcpctl
BIN_FILES= dhclient dhcpd dhcrelay
SAMP_FILES= client/dhclient.conf server/dhcpd.conf
@@ -53,16 +53,19 @@ STRIP?= strip
# Post-patch
#
-post-patch: patch-scripts patch-makefiles
+post-patch: patch-scripts patch-makefile-conf patch-makefiles-dist
patch-scripts:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' \
${WRKSRC}/client/scripts/freebsd
-patch-makefiles:
+patch-makefile-conf:
+ @${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
+ ${WRKSRC}/Makefile.conf
+
+patch-makefiles-dist:
.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e \
- 's|^DEBUG[ ]*=|DEBUG ?=|g;s|^CFLAGS[ ]*=|CFLAGS +=|g' \
+ @${PERL} -pi.fbsd -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
${WRKSRC}/${subdir}/Makefile.dist
.endfor