aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-03-16 20:31:15 +0000
commitb77059fee230166d718075c75aefc81e483dfe5b (patch)
treefc6fe8ade1c97ac875e64603da3c6e22730e0d76 /net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h
parenta10e88bb72eaab5fa0cecfd0e2923bde510cdba1 (diff)
Mega-update from maintainer:
isc-dhcp3-client/pkg-message updated isc-dhcp3-devel/pkg-plist updated from PR#61620 isc-dhcp3-relay/pkg-message rewritten to reflect rcNG change isc-dhcp3-relay/pkg-plist etc/rc.isc-dhcrelay.conf deleted etc/rc.d/isc-dhcrelay.sh.sample renamed to etc/rc.d/isc-dhcrelay.sh isc-dhcp3-server/Makefile PORTREVISION bumped USE_RC_SUBR added *_SUB added pre-everything added (WITHOUT_INTERFACE_POLLING cond added) patch-scripts and patch-pkgmessage (! -devel cond) updated patch-site-conf and patch-rc-scripts added install-startup-files now install etc/rc.d/isc-dhcpd.sh instead of etc/rc.d/isc-dhcpd.sh.sample display-message updated (! -devel cond) isc-dhcp3-server/pkg-message rewritten to reflect rcNG change isc-dhcp3-server/pkg-plist etc/rc.isc-dhcpd.conf deleted etc/rc.d/isc-dhcpd.sh.sample renamed to etc/rc.d/isc-dhcpd.sh isc-dhcp3-server/files/isc-dhcpd.sh.sample isc-dhcp3-server/files/isc-dhcrelay.sh.sample both converted to rcNG isc-dhcp3-server/files/patch-freebsd synced w/ -current isc-dhcp3-server/files/patch-site.conf CLIENT_PATH added CFLAGS synced w/ -current isc-dhcp3-server/patch-client::clparse.c isc-dhcp3-server/patch-client::dhclient.8 new files synced w/ -current isc-dhcp3-server/patch-client::dhclient.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/patch-client::dhclient.conf new file isc-dhcp3-server/patch-common::dhcp-options.5 new file synced w/ -current isc-dhcp3-server/patch-common::discover.c new file from PR#61011 isc-dhcp3-server/patch-common::dispatch.c new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/patch-common::parse.c fix time_t issues on little-endian 64-bit platforms isc-dhcp3-server/patch-dst::Makefile.dist new file from PR#61620 isc-dhcp3-server/patch-includes::cf::freebsd.h new file synced w/ -current (-DRESCUE unused right now) isc-dhcp3-server/patch-includes::dhcpd.h new file synced w/ -current (-DENABLE_POLLING_MODE) isc-dhcp3-server/files/rc.isc-dhcpd.conf.sample isc-dhcp3-server/files/rc.isc-dhcrelay.conf.sample deleted files PR: 57943, 61011, 61620 Submitted by: sec@42.org, andy@fud.org.nz, kaa@in-line.ru, des, ru
Notes
Notes: svn path=/head/; revision=104204
Diffstat (limited to 'net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h')
-rw-r--r--net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h53
1 files changed, 53 insertions, 0 deletions
diff --git a/net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h b/net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h
new file mode 100644
index 000000000000..8fe1b6ef93a0
--- /dev/null
+++ b/net/isc-dhcp40-server/files/patch-includes::cf::freebsd.h
@@ -0,0 +1,53 @@
+--- includes/cf/freebsd.h.orig Wed Mar 3 02:32:39 2004
++++ includes/cf/freebsd.h Wed Mar 3 02:31:56 2004
+@@ -101,6 +101,10 @@
+ #define SOCKLEN_T int
+ #endif
+
++#ifdef RESCUE
++#define _PATH_DHCLIENT_SCRIPT "/rescue/dhclient-script"
++#endif
++
+ #if defined (USE_DEFAULT_NETWORK)
+ # define USE_BPF
+ #endif
+@@ -111,6 +115,9 @@
+ #endif /* HAVE_DEV_RANDOM */
+
+ const char *cmds[] = {
++#ifndef RESCUE
++ /* rescue environment can't rely on these ... */
++ /* Actually, /sbin/dhclient shouldn't use these, either. */
+ "/bin/ps -axlw 2>&1",
+ "/usr/sbin/arp -an 2>&1",
+ "/usr/bin/netstat -an 2>&1",
+@@ -121,10 +128,12 @@
+ "/usr/sbin/iostat 2>&1",
+ "/usr/bin/vmstat 2>&1",
+ "/usr/bin/w 2>&1",
++#endif
+ NULL
+ };
+
+ const char *dirs[] = {
++#ifndef RESCUE
+ "/tmp",
+ "/usr/tmp",
+ ".",
+@@ -134,13 +143,16 @@
+ "/var/mail",
+ "/home",
+ "/usr/home",
++#endif
+ NULL
+ };
+
+ const char *files[] = {
++#ifndef RESCUE
+ "/var/log/messages",
+ "/var/log/wtmp",
+ "/var/log/lastlog",
++#endif
+ NULL
+ };
+ #endif /* NEED_PRAND_CONF */