aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp41-server
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-05-29 22:20:30 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-05-29 22:20:30 +0000
commit213a856db39a20fda49286ff79953c9948968895 (patch)
treef82652477c83e00bf505ee38b299fc955839a106 /net/isc-dhcp41-server
parenta189bfef134c643ffb1b5250856ca40b3a3a663d (diff)
Notes
Diffstat (limited to 'net/isc-dhcp41-server')
-rw-r--r--net/isc-dhcp41-server/Makefile3
-rw-r--r--net/isc-dhcp41-server/files/patch-client__Makefile.in18
2 files changed, 18 insertions, 3 deletions
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index d46824204c42..266eef3a5f2b 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT?= The ISC Dynamic Host Configuration Protocol server
PORTREVISION_SERVER= 1
-PORTREVISION_CLIENT= 0
+PORTREVISION_CLIENT= 1
PORTREVISION_RELAY= 0
SUBSYS?= server
@@ -51,6 +51,7 @@ GROUPS= dhcpd
MAN_COMPRESSED= no
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-D_PATH_DHCLIENT_SCRIPT='\"${PREFIX}/sbin/dhclient-script\"' -D_PATH_DHCLIENT_CONF='\"${PREFIX}/etc/dhclient.conf\"'"
SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
.if ${SUBSYS} == client
diff --git a/net/isc-dhcp41-server/files/patch-client__Makefile.in b/net/isc-dhcp41-server/files/patch-client__Makefile.in
index 9c9f72ebe548..cb02e370fe5d 100644
--- a/net/isc-dhcp41-server/files/patch-client__Makefile.in
+++ b/net/isc-dhcp41-server/files/patch-client__Makefile.in
@@ -1,5 +1,5 @@
---- ./client/Makefile.in.orig 2010-01-07 19:47:06.000000000 -0500
-+++ ./client/Makefile.in 2010-05-02 20:38:26.000000000 -0400
+--- client/Makefile.in.orig 2010-01-07 19:47:06.000000000 -0500
++++ client/Makefile.in 2010-05-29 17:24:48.814048529 -0400
@@ -351,8 +351,8 @@
@list='$(dist_sysconf_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
@@ -11,3 +11,17 @@
done
uninstall-dist_sysconfDATA:
+@@ -537,11 +537,11 @@
+
+
+ dhclient.o: dhclient.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=/sbin:/usr/sbin:$(sbindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhclient.c
+
+ dhc6.o: dhc6.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=/sbin:/usr/sbin:$(sbindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.