aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp41-server
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-08-17 13:02:55 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-08-17 13:02:55 +0000
commit2fd8c58b88a3d7dc1e1a388fb59f9485a3d22221 (patch)
tree21b61b5dc0316274f90bb74db2d2c485196b1adb /net/isc-dhcp41-server
parentd5651d2e086031ade34416c459dcf064984be472 (diff)
Notes
Diffstat (limited to 'net/isc-dhcp41-server')
-rw-r--r--net/isc-dhcp41-server/Makefile1
-rw-r--r--net/isc-dhcp41-server/files/extra-patch-dhcp-4.1.1-ldap.patch32
2 files changed, 33 insertions, 0 deletions
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 522f989267ae..ddc5a1ec0231 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -150,6 +150,7 @@ PLIST_SUB+= IPV6="@comment "
pre-patch:
.if ${SUBSYS} == server && defined(WITH_DHCP_LDAP)
+ @${PATCH} ${WRKDIR}/${LDAPPATCHDIST}/${LDAPPATCHFILE} ${FILESDIR}/extra-patch-${LDAPPATCHFILE}
@cd ${WRKSRC} && ${PATCH} -p1 < ${WRKDIR}/${LDAPPATCHDIST}/${LDAPPATCHFILE}
.endif
diff --git a/net/isc-dhcp41-server/files/extra-patch-dhcp-4.1.1-ldap.patch b/net/isc-dhcp41-server/files/extra-patch-dhcp-4.1.1-ldap.patch
new file mode 100644
index 000000000000..3e49daff80f4
--- /dev/null
+++ b/net/isc-dhcp41-server/files/extra-patch-dhcp-4.1.1-ldap.patch
@@ -0,0 +1,32 @@
+--- dhcp-4.1.1-ldap.patch.orig 2010-02-16 09:15:45.000000000 -0800
++++ dhcp-4.1.1-ldap.patch 2011-08-16 21:45:26.000000000 -0700
+@@ -2,10 +2,10 @@
+ --- dhcp-4.1.1/common/conflex.c.ldap 2009-07-23 09:02:09.000000000 -1000
+ +++ dhcp-4.1.1/common/conflex.c 2010-02-16 07:14:11.000000000 -1000
+ @@ -43,6 +43,7 @@ static enum dhcp_token read_string PROTO
+- static enum dhcp_token read_number PROTO ((int, struct parse *));
+- static enum dhcp_token read_num_or_name PROTO ((int, struct parse *));
+- static enum dhcp_token intern PROTO ((char *, enum dhcp_token));
+-+static int read_function PROTO ((struct parse *));
++ static enum dhcp_token read_number (int, struct parse *);
++ static enum dhcp_token read_num_or_name (int, struct parse *);
++ static enum dhcp_token intern (char *, enum dhcp_token);
+++static int read_function (struct parse *);
+
+ isc_result_t new_parse (cfile, file, inbuf, buflen, name, eolp)
+ struct parse **cfile;
+@@ -243,10 +243,10 @@
+ char *quotify_string (const char *, const char *, int);
+ char *quotify_buf (const unsigned char *, unsigned, const char *, int);
+ char *print_base64 (const unsigned char *, unsigned, const char *, int);
+--char *print_hw_addr PROTO ((int, int, unsigned char *));
+-+char *print_hw_addr PROTO ((const int, const int, const unsigned char *));
+- void print_lease PROTO ((struct lease *));
+- void dump_raw PROTO ((const unsigned char *, unsigned));
++-char *print_hw_addr (int, int, unsigned char *);
+++char *print_hw_addr (const int, const int, const unsigned char *);
++ void print_lease (struct lease *);
++ void dump_raw (const unsigned char *, unsigned);
+ void dump_packet_option (struct option_cache *, struct packet *,
+ @@ -3234,6 +3290,20 @@ OMAPI_OBJECT_ALLOC_DECL (dhcp_failover_l
+ \ No newline at end of file