aboutsummaryrefslogtreecommitdiff
path: root/net/istgt/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-02-22 13:26:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-02-22 13:26:57 +0000
commit2abda76bcbd7689bd100a7afab14039d8433189c (patch)
tree61c53977917debd7d4091878fc712e576c50d358 /net/istgt/Makefile
parent4a3139de63c59d2639357645500cd19ad8515a6f (diff)
downloadports-2abda76bcbd7689bd100a7afab14039d8433189c.tar.gz
ports-2abda76bcbd7689bd100a7afab14039d8433189c.zip
Notes
Diffstat (limited to 'net/istgt/Makefile')
-rw-r--r--net/istgt/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/net/istgt/Makefile b/net/istgt/Makefile
index 9875691811c5..3b990fe01bea 100644
--- a/net/istgt/Makefile
+++ b/net/istgt/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= istgt
-PORTVERSION= 20110103
+PORTVERSION= 20110219
CATEGORIES= net
MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
MAINTAINER= aoyama@peach.ne.jp
-COMMENT= An iSCSI target for FreeBSD 7.x
+COMMENT= An iSCSI target for FreeBSD
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -21,20 +21,25 @@ GNU_CONFIGURE= yes
MAN1= istgt.1
MANCOMPRESSED= yes
-PORTDOCS= README ChangeLog.jp QUICKSTART QUICKSTART.jp
+PLIST_FILES= bin/istgt \
+ bin/istgtcontrol \
+ etc/rc.d/istgt \
+ %%ETCDIR%%/auth.conf.sample \
+ %%ETCDIR%%/istgt.conf.sample \
+ %%ETCDIR%%/istgt.large.conf.sample \
+ %%ETCDIR%%/istgtcontrol.conf.sample
+PLIST_DIRS= %%ETCDIR%%
+PORTDOCS= ${DOCS:T}
+
+DOCS= ChangeLog.jp README doc/QUICKSTART doc/QUICKSTART.jp
post-extract:
- @${MV} ${WRKSRC}/doc/Makefile.in ${WRKSRC}/doc/Makefile.tmp
- @${SED} -e '/\/doc\/istgt/d' < ${WRKSRC}/doc/Makefile.tmp \
- > ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '/\/doc\/istgt/d' ${WRKSRC}/doc/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/ChangeLog.jp ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/QUICKSTART ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/QUICKSTART.jp ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${DOCS} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}