aboutsummaryrefslogtreecommitdiff
path: root/net/jags
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-07-08 14:33:48 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-07-08 14:33:48 +0000
commitb1c4722a6de47aa404e86536e4949b5dbf68f7b2 (patch)
tree0d4d35f02fdff1e08dac936a2abdb5b74cf9e54d /net/jags
parentb4e725736274de6f9ce50fbc67190bc7ba605b11 (diff)
downloadports-b1c4722a6de47aa404e86536e4949b5dbf68f7b2.tar.gz
ports-b1c4722a6de47aa404e86536e4949b5dbf68f7b2.zip
Notes
Diffstat (limited to 'net/jags')
-rw-r--r--net/jags/Makefile27
-rw-r--r--net/jags/distinfo1
-rw-r--r--net/jags/pkg-comment1
-rw-r--r--net/jags/pkg-descr11
-rw-r--r--net/jags/pkg-plist67
5 files changed, 107 insertions, 0 deletions
diff --git a/net/jags/Makefile b/net/jags/Makefile
new file mode 100644
index 000000000000..1c7fdaf1ed86
--- /dev/null
+++ b/net/jags/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: jags
+# Date created: Thu Jul 5 17:13:11 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jags
+PORTVERSION= 0.20
+CATEGORIES= net
+MASTER_SITES= http://sumpan.campus.luth.se/software/jags/download/
+
+MAINTAINER= pat@databits.net
+
+USE_GMAKE= yes
+USE_XPM= yes
+USE_GTK= yes
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
+
+patch:
+ @${PERL} -pi.fbsd -e 's@/usr/local/share/jags/@${PREFIX}/share/jags/@g' \
+ ${WRKSRC}/src/jagsconfig.cpp
+ @${PERL} -pi.fbsd -e 's@/usr/local/share/jags/pixmaps/@${PREFIX}/share/jags/pixmaps/@g' \
+ ${WRKSRC}/src/gtk_common.cpp
diff --git a/net/jags/distinfo b/net/jags/distinfo
new file mode 100644
index 000000000000..4a01a0f669fd
--- /dev/null
+++ b/net/jags/distinfo
@@ -0,0 +1 @@
+MD5 (jags-0.20.tar.gz) = b8b5730a0dd4ee576317fa5e3b15480a
diff --git a/net/jags/pkg-comment b/net/jags/pkg-comment
new file mode 100644
index 000000000000..87587e3a83e2
--- /dev/null
+++ b/net/jags/pkg-comment
@@ -0,0 +1 @@
+JAGS - Just Another GTK+ Samba Client
diff --git a/net/jags/pkg-descr b/net/jags/pkg-descr
new file mode 100644
index 000000000000..81277bd2038c
--- /dev/null
+++ b/net/jags/pkg-descr
@@ -0,0 +1,11 @@
+Jags is a Gtk+ based windows network neighbourhood browser. The
+program parses the output from smbclient ( part of the samba-package
+) and use this to display a graphic view of the network. This
+program does the parsing with help from shell- scripts. This means
+that it's easy to change the functionality of the program and you
+can edit this without touching the source-code.
+
+WWW: http://sumpan.campus.luth.se/software/jags/
+Author: Daniel Sundberg <dansun-8@student.luth.se>
+
+- Patrick Li <pat@databits.net>
diff --git a/net/jags/pkg-plist b/net/jags/pkg-plist
new file mode 100644
index 000000000000..bee0ae26609d
--- /dev/null
+++ b/net/jags/pkg-plist
@@ -0,0 +1,67 @@
+bin/fixsmbcop
+bin/jags
+share/jags/jags.conf.sample
+share/jags/pixmaps/Makefile.am
+share/jags/pixmaps/about.xpm
+share/jags/pixmaps/apply.xpm
+share/jags/pixmaps/blank.xpm
+share/jags/pixmaps/browse.xpm
+share/jags/pixmaps/cancel.xpm
+share/jags/pixmaps/computer.xpm
+share/jags/pixmaps/exit.xpm
+share/jags/pixmaps/i-bookmark.xpm
+share/jags/pixmaps/mount.xpm
+share/jags/pixmaps/network.xpm
+share/jags/pixmaps/new_item.xpm
+share/jags/pixmaps/ok.xpm
+share/jags/pixmaps/search.xpm
+share/jags/pixmaps/settings.xpm
+share/jags/pixmaps/unmount.xpm
+share/jags/plugins/freebsd-samba-2.0.7.plugin/fetch_master_browser.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/fetch_master_browser.sh.old
+share/jags/plugins/freebsd-samba-2.0.7.plugin/fetch_master_browser.sh~
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_masterbrowsers.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_servercomments.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_servers.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_servers.sh~
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_shares.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/list_workgroups.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/ls_mnts.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/ls_mnts.sh~
+share/jags/plugins/freebsd-samba-2.0.7.plugin/mount_share.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/mount_share_with.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/mount_share_with.sh~
+share/jags/plugins/freebsd-samba-2.0.7.plugin/search.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/umount.sh
+share/jags/plugins/freebsd-samba-2.0.7.plugin/umount.sh~
+share/jags/plugins/offline.plugin/fetch_master_browser.sh
+share/jags/plugins/offline.plugin/list_masterbrowsers.sh
+share/jags/plugins/offline.plugin/list_servers.sh
+share/jags/plugins/offline.plugin/list_shares.sh
+share/jags/plugins/offline.plugin/list_workgroups.sh
+share/jags/plugins/offline.plugin/mount_share.sh
+share/jags/plugins/offline.plugin/nmblookup_sample
+share/jags/plugins/offline.plugin/sample_smb_output
+share/jags/plugins/samba-2.0.7.plugin/]
+share/jags/plugins/samba-2.0.7.plugin/fetch_master_browser.sh
+share/jags/plugins/samba-2.0.7.plugin/fetch_master_browser.sh.old
+share/jags/plugins/samba-2.0.7.plugin/fetch_master_browser.sh~
+share/jags/plugins/samba-2.0.7.plugin/list_masterbrowsers.sh
+share/jags/plugins/samba-2.0.7.plugin/list_servercomments.sh
+share/jags/plugins/samba-2.0.7.plugin/list_servers.sh
+share/jags/plugins/samba-2.0.7.plugin/list_servers.sh~
+share/jags/plugins/samba-2.0.7.plugin/list_shares.sh
+share/jags/plugins/samba-2.0.7.plugin/list_workgroups.sh
+share/jags/plugins/samba-2.0.7.plugin/ls_mnts.sh
+share/jags/plugins/samba-2.0.7.plugin/mount_share.sh
+share/jags/plugins/samba-2.0.7.plugin/mount_share_with.sh
+share/jags/plugins/samba-2.0.7.plugin/mount_share_with.sh~
+share/jags/plugins/samba-2.0.7.plugin/search.sh
+share/jags/plugins/samba-2.0.7.plugin/umount.sh
+share/jags/plugins/samba-2.0.7.plugin/umount.sh~
+@dirrm share/jags/plugins/samba-2.0.7.plugin
+@dirrm share/jags/plugins/offline.plugin
+@dirrm share/jags/plugins/freebsd-samba-2.0.7.plugin
+@dirrm share/jags/plugins
+@dirrm share/jags/pixmaps
+@dirrm share/jags