aboutsummaryrefslogtreecommitdiff
path: root/net/jgroups
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-03-18 10:17:28 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-03-18 10:17:28 +0000
commit04f5b9ddf06bd44d66998e7d38af0b30d1454284 (patch)
tree32059593c6695688a73b046af394493935ca067f /net/jgroups
parentd7c5457ddfe2556cc9d7becaeb1defa4c37c1931 (diff)
JGroups is a toolkit for reliable multicast communication.
(Note that this doesn't necessarily mean IP Multicast, JGroups can also use transports such as TCP). It can be used to create groups of processes whose members can send messages to each other. The main features include: * Group creation and deletion * Joining and leaving of groups * Membership detection and notification about joined/left/crashed members * Detection and removal of crashed members * Sending and receiving of member-to-group messages (point-to-multipoint) * Sending and receiving of member-to-member messages (point-to-point) WWW: http://www.jgroups.org/
Notes
Notes: svn path=/head/; revision=271245
Diffstat (limited to 'net/jgroups')
-rw-r--r--net/jgroups/Makefile47
-rw-r--r--net/jgroups/distinfo2
-rw-r--r--net/jgroups/files/patch-src_org_jgroups_protocols_MPING.java11
-rw-r--r--net/jgroups/files/patch-src_org_jgroups_protocols_TP.java11
-rw-r--r--net/jgroups/files/patch-src_org_jgroups_protocols_UDP.java20
-rw-r--r--net/jgroups/files/patch-src_org_jgroups_util_Util.java13
-rw-r--r--net/jgroups/pkg-descr17
7 files changed, 121 insertions, 0 deletions
diff --git a/net/jgroups/Makefile b/net/jgroups/Makefile
new file mode 100644
index 000000000000..577f3dcbe258
--- /dev/null
+++ b/net/jgroups/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: jgroups
+# Date created: 18 Mar 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jgroups
+PORTVERSION= 2.12.0
+CATEGORIES= net java
+MASTER_SITES= ${MASTER_SITES_LOCAL}
+MASTER_SITE_SUBDIR= ale
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A Java toolkit for reliable multicast communication
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+USE_ANT= yes
+ALL_TARGET= jar
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+.endif
+
+PORTDATA= *
+PORTDOCS= *
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dist/${DISTNAME}.Final.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+.if !defined(NOPORTDATA)
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-sources.jar \
+ ${DATADIR}/
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/dist/README ${DOCSDIR}/
+ @(cd ${WRKSRC}/dist && ${COPYTREE_SHARE} javadoc ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/jgroups/distinfo b/net/jgroups/distinfo
new file mode 100644
index 000000000000..febd84036cec
--- /dev/null
+++ b/net/jgroups/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jgroups-2.12.0.tar.gz) = 90011c085ea864fd558fa29b4e58591230ca4e0c9e0a1a5a292d4a0b26392598
+SIZE (jgroups-2.12.0.tar.gz) = 8911774
diff --git a/net/jgroups/files/patch-src_org_jgroups_protocols_MPING.java b/net/jgroups/files/patch-src_org_jgroups_protocols_MPING.java
new file mode 100644
index 000000000000..31fadecfba34
--- /dev/null
+++ b/net/jgroups/files/patch-src_org_jgroups_protocols_MPING.java
@@ -0,0 +1,11 @@
+--- src/org/jgroups/protocols/MPING.java.orig 2011-03-18 10:35:23.000000000 +0100
++++ src/org/jgroups/protocols/MPING.java 2011-03-18 10:37:30.000000000 +0100
+@@ -29,7 +29,7 @@
+
+
+ static {
+- can_bind_to_mcast_addr=Util.checkForLinux() || Util.checkForSolaris() || Util.checkForHp();
++ can_bind_to_mcast_addr=Util.checkForFreeBSD() || Util.checkForLinux() || Util.checkForSolaris() || Util.checkForHp();
+ }
+
+
diff --git a/net/jgroups/files/patch-src_org_jgroups_protocols_TP.java b/net/jgroups/files/patch-src_org_jgroups_protocols_TP.java
new file mode 100644
index 000000000000..63b0d9d1778c
--- /dev/null
+++ b/net/jgroups/files/patch-src_org_jgroups_protocols_TP.java
@@ -0,0 +1,11 @@
+--- src/org/jgroups/protocols/TP.java.orig 2011-03-18 10:39:08.000000000 +0100
++++ src/org/jgroups/protocols/TP.java 2011-03-18 10:39:37.000000000 +0100
+@@ -63,7 +63,7 @@
+ protected static NumberFormat f;
+
+ static {
+- can_bind_to_mcast_addr=Util.checkForLinux() || Util.checkForSolaris() || Util.checkForHp();
++ can_bind_to_mcast_addr=Util.checkForFreeBSD() || Util.checkForLinux() || Util.checkForSolaris() || Util.checkForHp();
+ f=NumberFormat.getNumberInstance();
+ f.setGroupingUsed(false);
+ f.setMaximumFractionDigits(2);
diff --git a/net/jgroups/files/patch-src_org_jgroups_protocols_UDP.java b/net/jgroups/files/patch-src_org_jgroups_protocols_UDP.java
new file mode 100644
index 000000000000..08c5b9678e5c
--- /dev/null
+++ b/net/jgroups/files/patch-src_org_jgroups_protocols_UDP.java
@@ -0,0 +1,20 @@
+--- src/org/jgroups/protocols/UDP.java.orig 2011-03-18 10:35:34.000000000 +0100
++++ src/org/jgroups/protocols/UDP.java 2011-03-18 10:39:00.000000000 +0100
+@@ -535,7 +535,7 @@
+ log.warn("send buffer of socket " + sock + " was set to " +
+ Util.printBytes(send_buf_size) + ", but the OS only allocated " +
+ Util.printBytes(actual_size) + ". This might lead to performance problems. Please set your " +
+- "max send buffer in the OS correctly (e.g. net.core.wmem_max on Linux)");
++ "max send buffer in the OS correctly (e.g. net.core.wmem_max on Linux or kern.ipc.maxsockbuf on FreeBSD)");
+ }
+ }
+ catch(Throwable ex) {
+@@ -549,7 +549,7 @@
+ log.warn("receive buffer of socket " + sock + " was set to " +
+ Util.printBytes(recv_buf_size) + ", but the OS only allocated " +
+ Util.printBytes(actual_size) + ". This might lead to performance problems. Please set your " +
+- "max receive buffer in the OS correctly (e.g. net.core.rmem_max on Linux)");
++ "max receive buffer in the OS correctly (e.g. net.core.rmem_max on Linux or kern.ipc.maxsockbuf on FreeBSD)");
+ }
+ }
+ catch(Throwable ex) {
diff --git a/net/jgroups/files/patch-src_org_jgroups_util_Util.java b/net/jgroups/files/patch-src_org_jgroups_util_Util.java
new file mode 100644
index 000000000000..31d53534304c
--- /dev/null
+++ b/net/jgroups/files/patch-src_org_jgroups_util_Util.java
@@ -0,0 +1,13 @@
+--- src/org/jgroups/util/Util.java.orig 2011-03-18 10:35:16.000000000 +0100
++++ src/org/jgroups/util/Util.java 2011-03-18 10:36:44.000000000 +0100
+@@ -3323,6 +3323,10 @@
+ }
+
+
++ public static boolean checkForFreeBSD() {
++ return checkForPresence("os.name", "freebsd");
++ }
++
+ public static boolean checkForLinux() {
+ return checkForPresence("os.name", "linux");
+ }
diff --git a/net/jgroups/pkg-descr b/net/jgroups/pkg-descr
new file mode 100644
index 000000000000..e4fa62169d66
--- /dev/null
+++ b/net/jgroups/pkg-descr
@@ -0,0 +1,17 @@
+JGroups is a toolkit for reliable multicast communication.
+(Note that this doesn't necessarily mean IP Multicast,
+JGroups can also use transports such as TCP).
+It can be used to create groups of processes whose members can
+send messages to each other. The main features include:
+
+* Group creation and deletion
+* Joining and leaving of groups
+* Membership detection and notification about joined/left/crashed members
+* Detection and removal of crashed members
+* Sending and receiving of member-to-group messages (point-to-multipoint)
+* Sending and receiving of member-to-member messages (point-to-point)
+
+WWW: http://www.jgroups.org/
+
+- Alex Dupre
+ale@FreeBSD.org