aboutsummaryrefslogtreecommitdiff
path: root/net/jwhois
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2006-05-18 07:04:17 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2006-05-18 07:04:17 +0000
commita042b03eb548f80c514bbc73a017909dc21a59b4 (patch)
tree2c9a38183b0a32c5ce2f2e6414ff7d30b95a7813 /net/jwhois
parent7f66deb291da072239cce731dc07942b4ce434fd (diff)
downloadports-a042b03eb548f80c514bbc73a017909dc21a59b4.tar.gz
ports-a042b03eb548f80c514bbc73a017909dc21a59b4.zip
Notes
Diffstat (limited to 'net/jwhois')
-rw-r--r--net/jwhois/Makefile2
-rw-r--r--net/jwhois/files/jwhois.conf24
2 files changed, 20 insertions, 6 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index a81b47600324..0557492b9a05 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jwhois
PORTVERSION= 3.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= jwhois
diff --git a/net/jwhois/files/jwhois.conf b/net/jwhois/files/jwhois.conf
index 6601a1befa79..0d5da58cfad7 100644
--- a/net/jwhois/files/jwhois.conf
+++ b/net/jwhois/files/jwhois.conf
@@ -114,6 +114,7 @@ whois-servers {
#
# Pseudo-ccTLDs must be listed above gTLDs
#
+ "\\.ae\\.org$" = "whois.centralnic.net";
"\\.br\\.com$" = "whois.centralnic.net";
"\\.cn\\.com$" = "whois.centralnic.net";
"\\.de\\.com$" = "whois.centralnic.net";
@@ -123,6 +124,7 @@ whois-servers {
"\\.gb\\.net$" = "whois.centralnic.net";
"\\.hu\\.com$" = "whois.centralnic.net";
"\\.jpn\\.com$" = "whois.centralnic.net";
+ "\\.kr\\.com$" = "whois.centralnic.net";
"\\.no\\.com$" = "whois.centralnic.net";
"\\.qc\\.com$" = "whois.centralnic.net";
"\\.ru\\.com$" = "whois.centralnic.net";
@@ -155,7 +157,7 @@ whois-servers {
"\\.az$" = "whois.ripe.net";
"\\.ba$" = "whois.ripe.net";
"\\.be$" = "whois.dns.be";
- "\\.bg$" = "whois.ripe.net";
+ "\\.bg$" = "whois.digsys.bg";
"\\.bi$" = "www.nic.bi";
"\\.biz$" = "whois.neulevel.biz";
"\\.bm$" = "rwhois.ibl.bm 4321";
@@ -164,6 +166,7 @@ whois-servers {
"\\.by$" = "whois.ripe.net";
"\\.bz$" = "whois.belizenic.bz";
"\\.ca$" = "whois.cira.ca";
+ "\\.cat$" = "whois.cat";
"\\.cc$" = "whois.nic.cc";
"\\.cd$" = "whois.nic.cd";
"\\.cg$" = "www.nic.cg";
@@ -173,14 +176,14 @@ whois-servers {
"\\.edu\\.cn$" = "whois.edu.cn";
"\\.cn$" = "whois.cnnic.net.cn";
"\\.com$" {
- whois-server = "whois.internic.net";
+ whois-server = "whois.verisign-grs.com";
query-format = "domain $*";
}
"\\.coop$" = "whois.nic.coop";
"\\.cx$" = "whois.nic.cx";
"\\.cy$" = "whois.ripe.net";
"\\.cz$" = "whois.nic.cz";
- "\\.de$" = "www.denic.de";
+ "\\.de$" = "whois.denic.de";
"\\.dk$" = "whois.dk-hostmaster.dk";
"\\.do$" = "whois.nic.do";
"\\.dz$" = "whois.ripe.net";
@@ -209,7 +212,7 @@ whois-servers {
"\\.id$" = "whois.idnic.net.id";
"\\.ie$" = "whois.domainregistry.ie";
"\\.il$" = "whois.isoc.org.il";
- "\\.in$" = "whois.ncst.ernet.in";
+ "\\.in$" = "whois.inregistry.in";
"\\.info$" = "whois.afilias.info";
"\\.int$" = "whois.iana.org";
"\\.io$" = "www.io.io";
@@ -245,7 +248,7 @@ whois-servers {
"\\.na$" = "whois.na-nic.com.na";
"\\.name$" = "whois.nic.name";
"\\.net$" {
- whois-server = "whois.internic.net";
+ whois-server = "whois.verisign-grs.com";
query-format = "domain $*";
}
"\\.ng$" = "whois.rg.net";
@@ -867,6 +870,10 @@ server-options {
form-element = "domainname";
form-extra = "service=WhoisData&lang=en&submit=Accept";
}
+ "whois\\.denic\\.de" {
+ whois-server = "whois.denic.de";
+ query-format = "-C UTF-8 -T dn,ace $*";
+ }
"whois\\.nic\\.ad\\.jp" {
query-format = "$*/e";
}
@@ -925,3 +932,10 @@ post-as-file = "false";
# browser-postarg = "-post";
# post-as-file = "true";
#
+
+#
+# Set connect-timeout to a positive integer to make the connection to
+# remote hosts timeout after the specified number of seconds, if the
+# remote host doesn't reply. By default, the timeout is 75 seconds.
+#
+#connect-timeout = 3;