aboutsummaryrefslogtreecommitdiff
path: root/net/kafkacat
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-15 17:19:11 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-15 17:19:11 +0000
commit62cf405131dc4546d18e1dde1e649d24e65dd194 (patch)
tree206077fec9fdfd77c058685ba5e41c1b6a405c48 /net/kafkacat
parent762d4558957ff45c6221627e2a945a5bfc7987b2 (diff)
downloadports-62cf405131dc4546d18e1dde1e649d24e65dd194.tar.gz
ports-62cf405131dc4546d18e1dde1e649d24e65dd194.zip
Notes
Diffstat (limited to 'net/kafkacat')
-rw-r--r--net/kafkacat/Makefile27
-rw-r--r--net/kafkacat/distinfo2
-rw-r--r--net/kafkacat/files/patch-configure17
-rw-r--r--net/kafkacat/pkg-descr5
4 files changed, 51 insertions, 0 deletions
diff --git a/net/kafkacat/Makefile b/net/kafkacat/Makefile
new file mode 100644
index 000000000000..8088d0831811
--- /dev/null
+++ b/net/kafkacat/Makefile
@@ -0,0 +1,27 @@
+# Created by: Victor Yagofarov <xnasx@yandex.ru>
+# $FreeBSD$
+
+PORTNAME= kafkacat
+PORTVERSION= 1.2.0
+CATEGORIES= net
+DISTNAME= ${GH_ACCOUNT}-${PORTNAME}-${PORTVERSION}-${GH_TAGNAME}
+
+MAINTAINER= xnasx@yandex.ru
+COMMENT= Generic command line non-JVM Apache Kafka producer and consumer
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ pkg-config:${PORTSDIR}/devel/pkgconf
+LIB_DEPENDS= librdkafka.so:${PORTSDIR}/net/librdkafka
+
+USE_GITHUB= yes
+GH_ACCOUNT= edenhill
+GH_TAGNAME= e2806ae
+
+PLIST_FILES= bin/kafkacat
+
+USES= perl5 gmake
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/kafkacat/distinfo b/net/kafkacat/distinfo
new file mode 100644
index 000000000000..e76d20dcaaa6
--- /dev/null
+++ b/net/kafkacat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (edenhill-kafkacat-1.2.0-e2806ae_GH0.tar.gz) = 6e00be0cdd5d0aa834bba17394ced2e4a5cd3111ea3467a8a1ac1bd756f3e07f
+SIZE (edenhill-kafkacat-1.2.0-e2806ae_GH0.tar.gz) = 34296
diff --git a/net/kafkacat/files/patch-configure b/net/kafkacat/files/patch-configure
new file mode 100644
index 000000000000..171c00bf5fa2
--- /dev/null
+++ b/net/kafkacat/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig 2015-06-18 17:24:07 UTC
++++ configure
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+ #
+
+ MKL_CONFIGURE_ARGS="$0 $*"
+@@ -38,7 +38,7 @@ mkl_require cc
+
+
+ # Load application provided modules (in current directory), if any.
+-for fname in configure.* ; do
++for fname in configure.kafkacat ; do
+ if [[ $fname = 'configure.*' ]]; then
+ continue
+ fi
diff --git a/net/kafkacat/pkg-descr b/net/kafkacat/pkg-descr
new file mode 100644
index 000000000000..6a48c843758b
--- /dev/null
+++ b/net/kafkacat/pkg-descr
@@ -0,0 +1,5 @@
+kafkacat is a generic non-JVM producer and consumer
+for Apache Kafka. Think of it as a netcat for
+Kafka.
+
+WWW: https://github.com/edenhill/kafkacat/