aboutsummaryrefslogtreecommitdiff
path: root/net/kamailio/files
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-05-06 06:57:59 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-05-06 06:57:59 +0000
commit1dcd559cd57ca9e8fe0942dfebb16a5d2acafb75 (patch)
treeaa3c59d33f2b686343022632356bfebba5240c98 /net/kamailio/files
parent6b094d82a8488080ffd0886703ea1b06b724dcbb (diff)
downloadports-1dcd559cd57ca9e8fe0942dfebb16a5d2acafb75.tar.gz
ports-1dcd559cd57ca9e8fe0942dfebb16a5d2acafb75.zip
Notes
Diffstat (limited to 'net/kamailio/files')
-rw-r--r--net/kamailio/files/patch-src_Makefile19
-rw-r--r--net/kamailio/files/patch-src_Makefile.defs8
-rw-r--r--net/kamailio/files/patch-src_core_ip__addr.h10
-rw-r--r--net/kamailio/files/patch-src_main.c2
-rw-r--r--net/kamailio/files/patch-src_modules_ctl_ctl.c4
-rw-r--r--net/kamailio/files/patch-src_modules_ctl_ctl__defaults.h2
-rw-r--r--net/kamailio/files/patch-src_modules_db__berkeley_Makefile2
-rw-r--r--net/kamailio/files/patch-src_modules_db__oracle_Makefile4
-rw-r--r--net/kamailio/files/patch-src_modules_db__sqlite_Makefile2
-rw-r--r--net/kamailio/files/patch-src_modules_tls_Makefile2
-rw-r--r--net/kamailio/files/patch-src_modules_tls_sip-router__cert.sh2
-rw-r--r--net/kamailio/files/patch-src_modules_websocket_ws__frame.c2
-rw-r--r--net/kamailio/files/patch-utils_kamctl_Makefile2
13 files changed, 23 insertions, 38 deletions
diff --git a/net/kamailio/files/patch-src_Makefile b/net/kamailio/files/patch-src_Makefile
index ea050ea4903d..faa1630af042 100644
--- a/net/kamailio/files/patch-src_Makefile
+++ b/net/kamailio/files/patch-src_Makefile
@@ -1,4 +1,4 @@
---- src/Makefile.orig 2017-04-21 12:46:05 UTC
+--- src/Makefile.orig 2018-03-01 16:24:06 UTC
+++ src/Makefile
@@ -34,7 +34,7 @@ err_fail?=1
# whether or not to install $(MAIN_NAME).cfg or just $(MAIN_NAME).cfg.default
@@ -9,7 +9,7 @@
#extra modules to exclude
skip_modules?=
-@@ -649,7 +649,7 @@ sunpkg:
+@@ -651,7 +651,7 @@ sunpkg:
.PHONY: install
install: mk_params="compile_for_install=yes"
install: install-bin install-every-module install-cfg \
@@ -18,18 +18,3 @@
.PHONY: dbinstall
dbinstall:
-@@ -764,10 +764,10 @@ install-cfg: $(cfg_prefix)/$(cfg_dir)
- fi ; \
- fi ; \
- : ; done; true
-- @# radius dictionary
-- @$(INSTALL_TOUCH) $(cfg_prefix)/$(cfg_dir)/dictionary.$(CFG_NAME)
-- @$(INSTALL_CFG) ../etc/dictionary.$(CFG_NAME) $(cfg_prefix)/$(cfg_dir)
-- @echo "config files installed"
-+ # radius dictionary
-+ $(INSTALL_TOUCH) $(cfg_prefix)/$(cfg_dir)/dictionary.$(CFG_NAME).sample
-+ $(INSTALL_CFG) ../etc/dictionary.$(CFG_NAME) $(cfg_prefix)/$(cfg_dir)/dictionary.$(CFG_NAME).sample
-+ echo "config files installed"
-
- install-bin: $(bin_prefix)/$(bin_dir) $(NAME)
- $(INSTALL_TOUCH) $(bin_prefix)/$(bin_dir)/$(NAME)
diff --git a/net/kamailio/files/patch-src_Makefile.defs b/net/kamailio/files/patch-src_Makefile.defs
index ac730a0ad841..2a8b4a506a29 100644
--- a/net/kamailio/files/patch-src_Makefile.defs
+++ b/net/kamailio/files/patch-src_Makefile.defs
@@ -1,4 +1,4 @@
---- src/Makefile.defs.orig 2017-04-21 13:52:06 UTC
+--- src/Makefile.defs.orig 2018-03-01 16:24:11 UTC
+++ src/Makefile.defs
@@ -208,7 +208,7 @@ YACC := $(shell echo "$${YACC}")
@@ -18,7 +18,7 @@
RPAREN=)
CC_VER:=$(word 1,$(CC)) $(shell $(CC) - --version|head -n 1|\
sed -e 's/([^$(RPAREN)]*)//g' \
-@@ -386,7 +386,7 @@ LIBDIR ?=
+@@ -390,7 +390,7 @@ LIBDIR ?=
ifeq ($(LIBDIR),)
ARCHBSZ= $(shell echo $(ARCH) | sed -e 's/.*64.*/64b/')
ifeq ($(ARCHBSZ),64b)
@@ -27,7 +27,7 @@
else
LIBDIR = lib
endif
-@@ -460,7 +460,7 @@ doxygen_dir=doc/doxygen
+@@ -464,7 +464,7 @@ doxygen_dir=doc/doxygen
BASEDIR ?= $(DESTDIR)
basedir = $(BASEDIR)
@@ -36,7 +36,7 @@
runbasedir = $(RUNBASEDIR)
# install location
-@@ -1722,7 +1722,7 @@ ifeq ($(YACC),)
+@@ -1743,7 +1743,7 @@ ifeq ($(YACC),)
endif
YACC_FLAGS=-d -b core/cfg
# on solaris add -lxnet (e.g. LIBS= -lxnet)
diff --git a/net/kamailio/files/patch-src_core_ip__addr.h b/net/kamailio/files/patch-src_core_ip__addr.h
index eb5b5a5b5e75..5116eb1ec2ad 100644
--- a/net/kamailio/files/patch-src_core_ip__addr.h
+++ b/net/kamailio/files/patch-src_core_ip__addr.h
@@ -1,6 +1,6 @@
---- src/core/ip_addr.h.orig 2017-04-21 12:46:05 UTC
+--- src/core/ip_addr.h.orig 2018-03-01 16:24:06 UTC
+++ src/core/ip_addr.h
-@@ -49,6 +49,10 @@ enum sip_protos { PROTO_NONE, PROTO_UDP, PROTO_TCP, PR
+@@ -49,6 +49,10 @@ enum sip_protos { PROTO_NONE, PROTO_UDP,
enum comp_methods { COMP_NONE, COMP_SIGCOMP, COMP_SERGZ };
#endif
@@ -8,6 +8,6 @@
+#define INADDR_LOOPBACK (u_int32_t)0x7f000001
+#endif
+
- struct ip_addr{
- unsigned int af; /* address family: AF_INET6 or AF_INET */
- unsigned int len; /* address len, 16 or 4 */
+ typedef struct ip_addr {
+ unsigned int af; /* address family: AF_INET6 or AF_INET */
+ unsigned int len; /* address len, 16 or 4 */
diff --git a/net/kamailio/files/patch-src_main.c b/net/kamailio/files/patch-src_main.c
index eacdb2737810..61adc641ab15 100644
--- a/net/kamailio/files/patch-src_main.c
+++ b/net/kamailio/files/patch-src_main.c
@@ -1,4 +1,4 @@
---- src/main.c.orig 2017-04-21 12:46:05 UTC
+--- src/main.c.orig 2018-03-01 16:24:07 UTC
+++ src/main.c
@@ -362,7 +362,7 @@ int received_dns = 0;
int sr_auto_aliases=1;
diff --git a/net/kamailio/files/patch-src_modules_ctl_ctl.c b/net/kamailio/files/patch-src_modules_ctl_ctl.c
index 1a2103c7c21f..a0dc3ac9b622 100644
--- a/net/kamailio/files/patch-src_modules_ctl_ctl.c
+++ b/net/kamailio/files/patch-src_modules_ctl_ctl.c
@@ -1,6 +1,6 @@
---- src/modules/ctl/ctl.c.orig 2017-04-21 13:48:39 UTC
+--- src/modules/ctl/ctl.c.orig 2018-03-01 16:24:09 UTC
+++ src/modules/ctl/ctl.c
-@@ -238,8 +238,7 @@ static int mod_init(void)
+@@ -240,8 +240,7 @@ static int mod_init(void)
return -1;
}
strcpy(ctl_socket_path, DEFAULT_CTL_SOCKET_PROTO);
diff --git a/net/kamailio/files/patch-src_modules_ctl_ctl__defaults.h b/net/kamailio/files/patch-src_modules_ctl_ctl__defaults.h
index 4455b720a77f..1a728691494a 100644
--- a/net/kamailio/files/patch-src_modules_ctl_ctl__defaults.h
+++ b/net/kamailio/files/patch-src_modules_ctl_ctl__defaults.h
@@ -1,4 +1,4 @@
---- src/modules/ctl/ctl_defaults.h.orig 2017-04-21 12:46:05 UTC
+--- src/modules/ctl/ctl_defaults.h.orig 2018-03-01 16:24:09 UTC
+++ src/modules/ctl/ctl_defaults.h
@@ -13,7 +13,7 @@
#define DEFAULT_CTL_SOCKET_NAME NAME "_ctl"
diff --git a/net/kamailio/files/patch-src_modules_db__berkeley_Makefile b/net/kamailio/files/patch-src_modules_db__berkeley_Makefile
index 30ad791748ba..30b192316dff 100644
--- a/net/kamailio/files/patch-src_modules_db__berkeley_Makefile
+++ b/net/kamailio/files/patch-src_modules_db__berkeley_Makefile
@@ -1,4 +1,4 @@
---- src/modules/db_berkeley/Makefile.orig 2017-04-21 12:46:05 UTC
+--- src/modules/db_berkeley/Makefile.orig 2018-03-01 16:24:09 UTC
+++ src/modules/db_berkeley/Makefile
@@ -25,7 +25,7 @@ ifeq ($(INSTALL_FLAVOUR),kamailio)
# extra install for kamailio
diff --git a/net/kamailio/files/patch-src_modules_db__oracle_Makefile b/net/kamailio/files/patch-src_modules_db__oracle_Makefile
index a1cdef378659..b52f69b9ab59 100644
--- a/net/kamailio/files/patch-src_modules_db__oracle_Makefile
+++ b/net/kamailio/files/patch-src_modules_db__oracle_Makefile
@@ -1,6 +1,6 @@
---- src/modules/db_oracle/Makefile.orig 2017-04-21 12:46:05 UTC
+--- src/modules/db_oracle/Makefile.orig 2018-03-01 16:24:09 UTC
+++ src/modules/db_oracle/Makefile
-@@ -70,7 +70,7 @@ ifeq ($(INSTALL_FLAVOUR),kamailio)
+@@ -19,7 +19,7 @@ ifeq ($(INSTALL_FLAVOUR),kamailio)
# extra install for kamailio
install-oracle-scripts: $(bin_prefix)/$(bin_dir)
diff --git a/net/kamailio/files/patch-src_modules_db__sqlite_Makefile b/net/kamailio/files/patch-src_modules_db__sqlite_Makefile
index 8aff7d996e54..827b1ff0cb22 100644
--- a/net/kamailio/files/patch-src_modules_db__sqlite_Makefile
+++ b/net/kamailio/files/patch-src_modules_db__sqlite_Makefile
@@ -1,4 +1,4 @@
---- src/modules/db_sqlite/Makefile.orig 2017-04-21 12:46:06 UTC
+--- src/modules/db_sqlite/Makefile.orig 2018-03-01 16:24:09 UTC
+++ src/modules/db_sqlite/Makefile
@@ -22,7 +22,7 @@ ifeq ($(INSTALL_FLAVOUR),kamailio)
# extra install for kamailio
diff --git a/net/kamailio/files/patch-src_modules_tls_Makefile b/net/kamailio/files/patch-src_modules_tls_Makefile
index e86ac2088b84..1adf6d1ad929 100644
--- a/net/kamailio/files/patch-src_modules_tls_Makefile
+++ b/net/kamailio/files/patch-src_modules_tls_Makefile
@@ -1,4 +1,4 @@
---- src/modules/tls/Makefile.orig 2017-04-21 12:46:06 UTC
+--- src/modules/tls/Makefile.orig 2018-03-01 16:24:10 UTC
+++ src/modules/tls/Makefile
@@ -8,6 +8,8 @@ include ../../Makefile.defs
auto_gen=
diff --git a/net/kamailio/files/patch-src_modules_tls_sip-router__cert.sh b/net/kamailio/files/patch-src_modules_tls_sip-router__cert.sh
index 859ac63c52f3..704ee26eeab9 100644
--- a/net/kamailio/files/patch-src_modules_tls_sip-router__cert.sh
+++ b/net/kamailio/files/patch-src_modules_tls_sip-router__cert.sh
@@ -1,4 +1,4 @@
---- src/modules/tls/sip-router_cert.sh.orig 2017-04-21 12:46:06 UTC
+--- src/modules/tls/sip-router_cert.sh.orig 2018-03-01 16:24:10 UTC
+++ src/modules/tls/sip-router_cert.sh
@@ -197,5 +197,6 @@ if [ $? != 0 ] ; then
else
diff --git a/net/kamailio/files/patch-src_modules_websocket_ws__frame.c b/net/kamailio/files/patch-src_modules_websocket_ws__frame.c
index a2ccc98cf958..2d44cf2da71a 100644
--- a/net/kamailio/files/patch-src_modules_websocket_ws__frame.c
+++ b/net/kamailio/files/patch-src_modules_websocket_ws__frame.c
@@ -1,4 +1,4 @@
---- src/modules/websocket/ws_frame.c.orig 2017-04-21 12:46:06 UTC
+--- src/modules/websocket/ws_frame.c.orig 2018-03-01 16:24:10 UTC
+++ src/modules/websocket/ws_frame.c
@@ -29,7 +29,7 @@
#ifdef EMBEDDED_UTF8_DECODE
diff --git a/net/kamailio/files/patch-utils_kamctl_Makefile b/net/kamailio/files/patch-utils_kamctl_Makefile
index 1c660357987e..eaa9c338b431 100644
--- a/net/kamailio/files/patch-utils_kamctl_Makefile
+++ b/net/kamailio/files/patch-utils_kamctl_Makefile
@@ -1,4 +1,4 @@
---- utils/kamctl/Makefile.orig 2017-04-21 12:46:06 UTC
+--- utils/kamctl/Makefile.orig 2018-03-01 16:24:11 UTC
+++ utils/kamctl/Makefile
@@ -8,6 +8,8 @@ else
kamctltmpdir = $(basedir)