aboutsummaryrefslogtreecommitdiff
path: root/net/kamailio
diff options
context:
space:
mode:
authorDmitry Wagin <dmitry.wagin@ya.ru>2024-01-12 08:37:56 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-01-14 16:34:27 +0000
commitcb0e21adcca888445d2cec5a21fce4e130fe8a8a (patch)
treebdf9a229d9f20d84c57a2f848a0b65f21510f6ba /net/kamailio
parentf0f98267f9d29cb87217516a08f9d1fd800f1669 (diff)
downloadports-cb0e21adcca888445d2cec5a21fce4e130fe8a8a.tar.gz
ports-cb0e21adcca888445d2cec5a21fce4e130fe8a8a.zip
Diffstat (limited to 'net/kamailio')
-rw-r--r--net/kamailio/Makefile15
-rw-r--r--net/kamailio/distinfo6
-rw-r--r--net/kamailio/files/patch-src_core_cfg.y43
-rw-r--r--net/kamailio/files/patch-src_core_sr__module.c79
-rw-r--r--net/kamailio/files/patch-src_core_sr__module.h13
-rw-r--r--net/kamailio/files/patch-src_main.c11
-rw-r--r--net/kamailio/pkg-plist4
7 files changed, 16 insertions, 155 deletions
diff --git a/net/kamailio/Makefile b/net/kamailio/Makefile
index e320c28e3704..09e8b425a861 100644
--- a/net/kamailio/Makefile
+++ b/net/kamailio/Makefile
@@ -1,6 +1,5 @@
PORTNAME= kamailio
-PORTVERSION= 5.6.2
-PORTREVISION= 1
+PORTVERSION= 5.7.3
CATEGORIES= net
MASTER_SITES= http://www.kamailio.org/pub/kamailio/${PORTVERSION}/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
@@ -39,10 +38,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USERS= ${KAMAILIO_USER}
GROUPS= ${KAMAILIO_GROUP}
-OPTIONS_DEFINE= DATABASE DIALPLAN DLGS DOCS EVAPI JWT KAFKA \
- LOST LWSC MQTT OUTBOUND PERL PHONENUM POSOPS \
- PRESENCE RADIUS SCTP SECSIPID SIPREPO SLACK \
- SWORKER TLS WEBSOCKET
+OPTIONS_DEFINE= DATABASE DIALPLAN DLGS DOCS EVAPI HTTP_CLIENT \
+ JWT KAFKA LOST LWSC MQTT OUTBOUND PERL \
+ PHONENUM POSOPS PRESENCE RADIUS SCTP SECSIPID \
+ SIPREPO SLACK SWORKER TLS WEBSOCKET
OPTIONS_DEFAULT= MYSQL PRESENCE RADIUS SQLITE TLS
OPTIONS_GROUP= DATABASE_DRIVERS KEMI_LANGS
OPTIONS_GROUP_DATABASE_DRIVERS= MYSQL PGSQL SQLITE UNIXODBC
@@ -54,6 +53,7 @@ DATABASE_DRIVERS_DESC= Database drivers
DIALPLAN_DESC= String translations based on rules
DLGS_DESC= Lightweight, stateless dialog tracking and statistics
EVAPI_DESC= Network event broadcast API
+HTTP_CLIENT_DESC= HTTP-client module
JWT_DESC= JSON Web Token generation and validation
KAFKA_DESC= Produces and sends messages to a Kafka server
KEMI_LANGS_DESC= Kamailio Embedded Interface Interpreters
@@ -83,6 +83,9 @@ DLGS_VARS= EXTRA_MODULES+=dlgs
EVAPI_LIB_DEPENDS= libev.so:devel/libev
EVAPI_VARS= EXTRA_MODULES+=evapi
+HTTP_CLIENT_LIB_DEPENDS= libcurl.so:ftp/curl
+HTTP_CLIENT_VARS= EXTRA_MODULES+=http_client
+
JWT_LIB_DEPENDS= libjwt.so:www/libjwt
JWT_VARS= EXTRA_MODULES+=jwt
diff --git a/net/kamailio/distinfo b/net/kamailio/distinfo
index c8f977c5c09f..382d3440657e 100644
--- a/net/kamailio/distinfo
+++ b/net/kamailio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665134014
-SHA256 (kamailio-5.6.2_src.tar.gz) = ea3cd5d688c34208b92072c3844c8276b693e0ca2c688168ea0357978c76b32d
-SIZE (kamailio-5.6.2_src.tar.gz) = 12921131
+TIMESTAMP = 1702905644
+SHA256 (kamailio-5.7.3_src.tar.gz) = c7a620b03974e4e04d419e086a771fd0b7a8e269f3d69c19a1c66085a498fd8c
+SIZE (kamailio-5.7.3_src.tar.gz) = 13128905
diff --git a/net/kamailio/files/patch-src_core_cfg.y b/net/kamailio/files/patch-src_core_cfg.y
deleted file mode 100644
index c84bab8e0d0c..000000000000
--- a/net/kamailio/files/patch-src_core_cfg.y
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/core/cfg.y.orig (revision 2cebd46f8f2dc3f87c9cfd2054976e347aa75ace)
-+++ src/core/cfg.y
-@@ -2045,14 +2045,38 @@
- module_stm:
- LOADMODULE STRING {
- LM_DBG("loading module %s\n", $2);
-- if (load_module($2)!=0) {
-+ if (ksr_load_module($2, NULL)!=0) {
-+ yyerror("failed to load module");
-+ }
-+ }
-+ | LOADMODULE LPAREN STRING RPAREN {
-+ LM_DBG("loading module %s\n", $3);
-+ if (ksr_load_module($3, NULL)!=0) {
-+ yyerror("failed to load module");
-+ }
-+ }
-+ | LOADMODULE LPAREN STRING COMMA STRING RPAREN {
-+ LM_DBG("loading module %s opts %s\n", $3, $5);
-+ if (ksr_load_module($3, $5)!=0) {
- yyerror("failed to load module");
- }
- }
- | LOADMODULE error { yyerror("string expected"); }
- | LOADMODULEX STRING {
- LM_DBG("loading module %s\n", $2);
-- if (load_modulex($2)!=0) {
-+ if (ksr_load_modulex($2, NULL)!=0) {
-+ yyerror("failed to load module");
-+ }
-+ }
-+ | LOADMODULEX LPAREN STRING RPAREN {
-+ LM_DBG("loading module %s\n", $3);
-+ if (ksr_load_modulex($3, NULL)!=0) {
-+ yyerror("failed to load module");
-+ }
-+ }
-+ | LOADMODULEX LPAREN STRING COMMA STRING RPAREN {
-+ LM_DBG("loading module %s opts %s\n", $3, $5);
-+ if (ksr_load_modulex($3, $5)!=0) {
- yyerror("failed to load module");
- }
- }
diff --git a/net/kamailio/files/patch-src_core_sr__module.c b/net/kamailio/files/patch-src_core_sr__module.c
deleted file mode 100644
index 947d005ed59f..000000000000
--- a/net/kamailio/files/patch-src_core_sr__module.c
+++ /dev/null
@@ -1,79 +0,0 @@
---- src/core/sr_module.c.orig (revision 43f764cae870b15a96b8ca88f1eb195d4ceb8455)
-+++ src/core/sr_module.c
-@@ -525,6 +525,7 @@
- return -1;
- }
-
-+
- /**
- * \brief load a sr module
- *
-@@ -537,9 +538,10 @@
- * absolute path (not starting with '/') then will try:
- * \<MODS_DIR\>/mod_path
- * @param mod_path path or module name
-+ * @param opts options string
- * @return 0 on success , <0 on error
- */
--int load_module(char* mod_path)
-+int ksr_load_module(char* mod_path, char *opts)
- {
- void* handle;
- char* error;
-@@ -553,11 +555,16 @@
- str expref;
- char exbuf[64];
- char* mdir;
-+ char *p;
-
- #ifndef RTLD_NOW
- /* for openbsd */
- #define RTLD_NOW DL_LAZY
- #endif
-+#ifndef RTLD_GLOBAL
-+/* Unsupported! */
-+#define RTLD_GLOBAL 0
-+#endif
-
- if(ksr_locate_module(mod_path, &path)<0) {
- return -1;
-@@ -567,6 +574,17 @@
-
- retries=2;
- dlflags=RTLD_NOW;
-+
-+ if(opts!=NULL) {
-+ for(p=opts; *p!='\0'; p++) {
-+ if(*p=='G' || *p=='g') {
-+ dlflags |= RTLD_GLOBAL;
-+ } else {
-+ LM_INFO("unknown option: %c\n", *p);
-+ }
-+ }
-+ }
-+
- reload:
- handle=dlopen(path, dlflags); /* resolve all symbols now */
- if (handle==0){
-@@ -653,10 +671,11 @@
- return -1;
- }
-
-+
- /**
- *
- */
--int load_modulex(char* mod_path)
-+int ksr_load_modulex(char* mod_path, char *opts)
- {
- str seval;
- str sfmt;
-@@ -679,7 +698,7 @@
- }
- }
-
-- return load_module(emod);
-+ return ksr_load_module(emod, opts);
- }
-
- /**
diff --git a/net/kamailio/files/patch-src_core_sr__module.h b/net/kamailio/files/patch-src_core_sr__module.h
deleted file mode 100644
index af0f3077c090..000000000000
--- a/net/kamailio/files/patch-src_core_sr__module.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/core/sr_module.h.orig (revision 43f764cae870b15a96b8ca88f1eb195d4ceb8455)
-+++ src/core/sr_module.h
-@@ -336,8 +336,8 @@
- extern int mod_response_cbk_no; /**< size of reponse callbacks array */
-
- int register_builtin_modules(void);
--int load_module(char* path);
--int load_modulex(char* path);
-+int ksr_load_module(char* path, char* opts);
-+int ksr_load_modulex(char* path, char* opts);
- ksr_cmd_export_t* find_export_record(char* name, int param_no, int flags);
- cmd_function find_export(char* name, int param_no, int flags);
- cmd_function find_mod_export(char* mod, char* name, int param_no, int flags);
diff --git a/net/kamailio/files/patch-src_main.c b/net/kamailio/files/patch-src_main.c
deleted file mode 100644
index d7c078af955b..000000000000
--- a/net/kamailio/files/patch-src_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main.c.orig (revision 43f764cae870b15a96b8ca88f1eb195d4ceb8455)
-+++ src/main.c
-@@ -2446,7 +2446,7 @@
- fprintf(stderr, "bad load module parameter\n");
- goto error;
- }
-- if (load_module(optarg)!=0) {
-+ if (ksr_load_module(optarg, NULL)!=0) {
- LM_ERR("failed to load the module: %s\n", optarg);
- goto error;
- }
diff --git a/net/kamailio/pkg-plist b/net/kamailio/pkg-plist
index 64c9da1a077c..4bff82bc5bcd 100644
--- a/net/kamailio/pkg-plist
+++ b/net/kamailio/pkg-plist
@@ -148,6 +148,8 @@
%%DLGS%%lib/kamailio/modules/dlgs.so
%%EVAPI%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.evapi
%%EVAPI%%lib/kamailio/modules/evapi.so
+%%HTTP_CLIENT%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.http_connect
+%%HTTP_CLIENT%%lib/kamailio/modules/http_client.so
%%JWT%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.jwt
%%JWT%%lib/kamailio/modules/jwt.so
%%KAFKA%%%%PORTDOCS%%%%DOCSDIR%%/modules/README.kafka
@@ -323,6 +325,7 @@
%%PORTDOCS%%%%DOCSDIR%%/modules/README.log_custom
%%PORTDOCS%%%%DOCSDIR%%/modules/README.lrkproxy
%%PORTDOCS%%%%DOCSDIR%%/modules/README.mangler
+%%PORTDOCS%%%%DOCSDIR%%/modules/README.math
%%PORTDOCS%%%%DOCSDIR%%/modules/README.maxfwd
%%PORTDOCS%%%%DOCSDIR%%/modules/README.mediaproxy
%%PORTDOCS%%%%DOCSDIR%%/modules/README.misctest
@@ -540,6 +543,7 @@ lib/kamailio/modules/kex.so
lib/kamailio/modules/log_custom.so
lib/kamailio/modules/lrkproxy.so
lib/kamailio/modules/mangler.so
+lib/kamailio/modules/math.so
lib/kamailio/modules/maxfwd.so
lib/kamailio/modules/mediaproxy.so
lib/kamailio/modules/misctest.so