aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork3/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-06-09 16:58:30 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-06-09 16:58:30 +0000
commit9774b282738ac937305fa2209b7ad1e372abe715 (patch)
treee5e37e7a03f81167570fc8abd2d5e64828d8163a /net/kdenetwork3/Makefile
parent2c35d214c7188108e6fda3c4580c64ed85511cce (diff)
downloadports-9774b282738ac937305fa2209b7ad1e372abe715.tar.gz
ports-9774b282738ac937305fa2209b7ad1e372abe715.zip
Notes
Diffstat (limited to 'net/kdenetwork3/Makefile')
-rw-r--r--net/kdenetwork3/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index 9392b8add91d..91b938f6c064 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -18,10 +18,13 @@ COMMENT= Network-related programs and modules for KDE
CONFLICTS= kopete-*
+LIB_DEPENDS= slp:${PORTSDIR}/net/openslp
+
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
KDE_BUILD_PLIST=yes
+USE_PERL5= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -33,6 +36,12 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+pre-configure:
+.if ${OSVERSION} < 500028
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|g' \
+ ${WRKSRC}/kopete/protocols/gadu/libgadu/libgadu-config.h.in
+.endif
+
.if !defined(WITHOUT_KTALKD)
UTMP?= /var/run/utmp
.if exists(${UTMP})