aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 20:23:45 +0000
commitef1b3d107105075700da0844ac072acae2de7726 (patch)
tree14d3f35f7d5dc26e8e8feed96c01af49bd9e4d3d /net/kdenetwork4/Makefile
parenta71e0ff08b3f1acf82cd96524c18b3a653ed1954 (diff)
Notes
Diffstat (limited to 'net/kdenetwork4/Makefile')
-rw-r--r--net/kdenetwork4/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 7c826f108aec..39f5f9d60f72 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -8,25 +8,29 @@ PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network applications
-# decibel:${PORTSDIR}/net-im/decibel
-LIB_DEPENDS= slp:${PORTSDIR}/net/openslp \
- idn:${PORTSDIR}/dns/libidn \
+LIB_DEPENDS= slp.1:${PORTSDIR}/net/openslp \
+ idn.16:${PORTSDIR}/dns/libidn \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
qca.2:${PORTSDIR}/devel/qca \
otr.4:${PORTSDIR}/security/libotr \
- vncserver.0:${PORTSDIR}/net/libvncserver
+ vncserver.0:${PORTSDIR}/net/libvncserver \
+ msn.0:${PORTSDIR}/net-im/libmsn \
+ gmp.7:${PORTSDIR}/math/libgmp4 \
+ ortp.5:${PORTSDIR}/net/ortp \
+ decibel.0:${PORTSDIR}/net-im/decibel \
+ meanwhile.1:${PORTSDIR}/net-im/meanwhile
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
LATEST_LINK= ${PORTNAME}4
USE_BZIP2= yes
-USE_KDE4= kdelibs pimlibs workspace kdeprefix kdehier automoc4
+USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
USE_QT_VER= 4
USE_SQLITE= yes
@@ -34,7 +38,18 @@ QT_COMPONENTS= corelib opengl dbus qt3support gui network xml porting_build \
qmake_build moc_build rcc_build uic_build uic3_build
USE_OPENSSL= yes
+OPTIONS= XMMS "Enable XMMS Kopete nowlistening plugin" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XMMS)
+CMAKE_ARGS+= -DWITH_Xmms:BOOL=ON
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+.else
+CMAKE_ARGS+= -DWITH_Xmms:BOOL=OFF
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>