aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-06-26 09:42:53 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-06-26 09:42:53 +0000
commitb3cefb63d88162600387b67b99600c9a80b8b9f3 (patch)
treece4d93bc55848cfbe58e552600685a4b7aa017dc /net/kdenetwork4
parent2fa71e5cce61530e2766d8b3389996a31268b407 (diff)
downloadports-b3cefb63d88162600387b67b99600c9a80b8b9f3.tar.gz
ports-b3cefb63d88162600387b67b99600c9a80b8b9f3.zip
Notes
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/Makefile1
-rw-r--r--net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c19
-rw-r--r--net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c19
3 files changed, 39 insertions, 0 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 91b938f6c064..6926d39a256d 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= net kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c b/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c
new file mode 100644
index 000000000000..9d93cb79db9a
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c
@@ -0,0 +1,19 @@
+--- kopete/protocols/yahoo/libyahoo2/libyahoo2.c 14 Jan 2004 02:07:29 -0000 1.18
++++ kopete/protocols/yahoo/libyahoo2/libyahoo2.c 26 Jun 2004 00:37:08 -0000 1.18.2.3
+@@ -1816,6 +1816,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, pass_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -1905,6 +1907,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, crypt_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
diff --git a/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c b/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c
new file mode 100644
index 000000000000..9d93cb79db9a
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c
@@ -0,0 +1,19 @@
+--- kopete/protocols/yahoo/libyahoo2/libyahoo2.c 14 Jan 2004 02:07:29 -0000 1.18
++++ kopete/protocols/yahoo/libyahoo2/libyahoo2.c 26 Jun 2004 00:37:08 -0000 1.18.2.3
+@@ -1816,6 +1816,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, pass_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -1905,6 +1907,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, crypt_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);