aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-02-09 09:29:31 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-02-09 09:29:31 +0000
commit85c795da4bb3f29490530f9a6c76469d549840a5 (patch)
treeb3472d5d32390a15b4d5fec31e6ca4c231c4d48a /net/kdenetwork4
parentc1f23cd26d8ec0c157abfb1fe1f52b3aaddee6e8 (diff)
downloadports-85c795da4bb3f29490530f9a6c76469d549840a5.tar.gz
ports-85c795da4bb3f29490530f9a6c76469d549840a5.zip
Notes
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt b/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt
new file mode 100644
index 000000000000..49aad1d2a5ce
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kopete__plugins__otr__CMakeLists.txt
@@ -0,0 +1,29 @@
+--- ../kopete/plugins/otr/CMakeLists.txt.orig 2008-10-01 16:20:37.000000000 +0000
++++ ../kopete/plugins/otr/CMakeLists.txt 2009-01-28 23:21:50.000000000 +0000
+@@ -10,7 +10,7 @@
+
+ kde4_add_plugin(kopete_otr ${kopete_otr_PART_SRCS})
+
+-target_link_libraries(kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared otr)
++target_link_libraries(kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared ${LIBOTR_LIBRARY})
+
+ install(TARGETS kopete_otr DESTINATION ${PLUGIN_INSTALL_DIR})
+
+@@ -24,7 +24,7 @@
+
+ kde4_add_plugin(kcm_kopete_otr ${kcm_kopete_otr_PART_SRCS})
+
+-target_link_libraries(kcm_kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared otr)
++target_link_libraries(kcm_kopete_otr ${KDE4_KDEUI_LIBS} kopete kopete_otr_shared ${LIBOTR_LIBRARY})
+
+ install(TARGETS kcm_kopete_otr DESTINATION ${PLUGIN_INSTALL_DIR})
+
+@@ -40,7 +40,7 @@
+
+ kde4_add_library(kopete_otr_shared SHARED ${kopete_otr_shared_LIB_SRCS})
+
+-target_link_libraries(kopete_otr_shared kopete ${KDE4_KIO_LIBS} ${KDE4_KDEUI_LIBS} otr)
++target_link_libraries(kopete_otr_shared kopete ${KDE4_KIO_LIBS} ${KDE4_KDEUI_LIBS} ${LIBOTR_LIBRARY})
+
+ set_target_properties(kopete_otr_shared PROPERTIES VERSION 1.0.0 SOVERSION 1)
+ install(TARGETS kopete_otr_shared ${INSTALL_TARGETS_DEFAULT_ARGS})