aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-04-10 13:28:54 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-04-10 13:28:54 +0000
commiteb8b410983b9bfeae0f6c72e8f944426045b3215 (patch)
treef1df9705c375e367eddf152f8f85054de3e85ee3 /net/kdenetwork4
parent13390bf02869fc2e2050e9ab15ef920b69ccfe2d (diff)
downloadports-eb8b410983b9bfeae0f6c72e8f944426045b3215.tar.gz
ports-eb8b410983b9bfeae0f6c72e8f944426045b3215.zip
Notes
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/Makefile1
-rw-r--r--net/kdenetwork4/files/patch-kget__ui__metalinkcreator__metalinker.cpp17
2 files changed, 18 insertions, 0 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 1a832cfe8e56..9f09ff672fca 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/net/kdenetwork4/files/patch-kget__ui__metalinkcreator__metalinker.cpp b/net/kdenetwork4/files/patch-kget__ui__metalinkcreator__metalinker.cpp
new file mode 100644
index 000000000000..4ab2df4364da
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kget__ui__metalinkcreator__metalinker.cpp
@@ -0,0 +1,17 @@
+--- kget/ui/metalinkcreator/metalinker.cpp 2010/12/22 13:31:19 1208598
++++ kget/ui/metalinkcreator/metalinker.cpp 2011/04/09 09:26:37 1227471
+@@ -583,7 +583,13 @@
+ return false;
+ }
+
+- if (name.contains(QRegExp("$(\\.\\.?)?/")) || name.contains("/../") || name.endsWith("/..")) {
++ if (name.endsWith('/')) {
++ kError(5001) << "Name attribute of Metalink::File does not contain a file name:" << name;
++ return false;
++ }
++
++ const QStringList components = name.split('/');
++ if (name.startsWith('/') || components.contains("..") || components.contains(".")) {
+ kError(5001) << "Name attribute of Metalink::File contains directory traversal directives:" << name;
+ return false;
+ }