aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-06-26 13:13:30 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-06-26 13:13:30 +0000
commite79b635c533b7896f1176ae58e03cfad7f59ed40 (patch)
tree01122364de3557297675e837b0bcabee9b7d5930 /net/kdenetwork4
parent0f48a3a14027f91901aa1e5c9e64234a43a26dcc (diff)
downloadports-e79b635c533b7896f1176ae58e03cfad7f59ed40.tar.gz
ports-e79b635c533b7896f1176ae58e03cfad7f59ed40.zip
Notes
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/Makefile1
-rw-r--r--net/kdenetwork4/files/patch-kmime_util.cpp27
2 files changed, 28 insertions, 0 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 184482f7e3ea..241282d93acc 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= net news kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${KDE_VERSION}/src
diff --git a/net/kdenetwork4/files/patch-kmime_util.cpp b/net/kdenetwork4/files/patch-kmime_util.cpp
new file mode 100644
index 000000000000..30213c8f9eab
--- /dev/null
+++ b/net/kdenetwork4/files/patch-kmime_util.cpp
@@ -0,0 +1,27 @@
+Index: libkdenetwork/kmime_util.cpp
+===================================================================
+RCS file: /home/kde/kdenetwork/libkdenetwork/Attic/kmime_util.cpp,v
+retrieving revision 1.16.2.1
+diff -u -5 -p -d -r1.16.2.1 kmime_util.cpp
+--- libkdenetwork/kmime_util.cpp 13 Dec 2002 09:31:38 -0000 1.16.2.1
++++ libkdenetwork/kmime_util.cpp 25 Jun 2003 19:42:06 -0000
+@@ -646,17 +646,13 @@ DateFormatter::zone(time_t otime) const
+ int secs = abs( local->tm_gmtoff );
+ int neg = (local->tm_gmtoff<0)?1:0; //no, I don't know why it's backwards :o
+ int hours = secs/3600;
+ int mins = (secs - hours*3600)/60;
+
+- if ( local->tm_isdst > 0 ) {
++ if ( local->tm_isdst > 0 )
+ mDaylight = 1;
+- if ( neg )
+- --hours;
+- else
+- ++hours;
+- } else
++ else
+ mDaylight = 0;
+
+ ret.sprintf("%c%.2d%.2d",(neg)?'-':'+', hours, mins);
+
+ #else