aboutsummaryrefslogtreecommitdiff
path: root/net/kea
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-12-30 17:18:39 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-12-30 17:18:39 +0000
commit69deeb18ade35b3f5f39369b537a6eaf9fa205db (patch)
tree9e094f0a997ccdf0188dc8adc8adf6964afad024 /net/kea
parentfc824512c67150eb3a82b89c67567333edf72cc5 (diff)
downloadports-69deeb18ade35b3f5f39369b537a6eaf9fa205db.tar.gz
ports-69deeb18ade35b3f5f39369b537a6eaf9fa205db.zip
Notes
Diffstat (limited to 'net/kea')
-rw-r--r--net/kea/Makefile14
-rw-r--r--net/kea/distinfo6
-rw-r--r--net/kea/files/patch-src-lib-dhcpsrv-daemon.cc11
-rw-r--r--net/kea/files/patch-src-lib-process-Makefile.am9
-rw-r--r--net/kea/files/patch-src_lib_dhcp_libdhcp++.cc81
-rw-r--r--net/kea/pkg-plist121
6 files changed, 105 insertions, 137 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 6d6a8d074794..175d32fb8efb 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= kea
-PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 2
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/-beta/b/:S/a/.a/:S/rc/.rc/}
+PORTREVISION= 0
CATEGORIES= net ipv6
MASTER_SITES= ISC/kea/${ISCVERSION}
DISTNAME= ${PORTNAME}-${ISCVERSION}
@@ -13,13 +13,13 @@ COMMENT= Alternative DHCP implementation by ISC
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: checking for log4cplus library... no
+
LIB_DEPENDS= liblog4cplus.so:devel/log4cplus \
libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to configure: checking for log4cplus library... no
-
# ISC releases things like 1.4.0-P1, which our versioning doesn't like
-ISCVERSION= 1.4.0-P1
+ISCVERSION= 1.5.0
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -45,11 +45,11 @@ PORTDOCS= AUTHORS COPYING ChangeLog README \
examples
OPTIONS_DEFINE= DOCS MYSQL PGSQL
-DOCS_MAKE_ARGS_OFF= \
+DOCS_MAKE_ARGS_OFF= \
INSTALL_STRIP_PROGRAM="${WRKSRC}/install-sh -c -s" \
INSTALL_STRIP_FLAG="-s" \
INSTALL_PROGRAM_ENV="STRIPPROG=${STRIP}"
-DOCS_INSTALL_TARGET_OFF= \
+DOCS_INSTALL_TARGET_OFF= \
install-exec-am \
install-pkgconfigDATA \
install-pkgincludeHEADERS
diff --git a/net/kea/distinfo b/net/kea/distinfo
index da1899133f59..e0136834756c 100644
--- a/net/kea/distinfo
+++ b/net/kea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531421892
-SHA256 (kea-1.4.0-P1.tar.gz) = 46356bd4594a73d269719a724042c43474e592e99476fb63dd8135e78c800411
-SIZE (kea-1.4.0-P1.tar.gz) = 6645111
+TIMESTAMP = 1544845580
+SHA256 (kea-1.5.0.tar.gz) = edce4fab68ca7af607cf7f5bc86596e04fe0ef4b8e88906e339cdefcf21daaec
+SIZE (kea-1.5.0.tar.gz) = 7395257
diff --git a/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc b/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc
deleted file mode 100644
index b06310126ebe..000000000000
--- a/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/dhcpsrv/daemon.cc.orig 2017-10-05 13:00:04 UTC
-+++ src/lib/dhcpsrv/daemon.cc
-@@ -29,7 +29,7 @@ namespace dhcp {
-
- Daemon::Daemon()
- : signal_set_(), signal_handler_(), config_file_(""), proc_name_(""),
-- pid_file_dir_(DHCP_DATA_DIR), pid_file_(), am_file_author_(false) {
-+ pid_file_dir_(KEA_PIDFILE_DIR), pid_file_(), am_file_author_(false) {
-
- // The pid_file_dir can be overridden via environment variable
- // This is primarily intended to simplify testing
diff --git a/net/kea/files/patch-src-lib-process-Makefile.am b/net/kea/files/patch-src-lib-process-Makefile.am
new file mode 100644
index 000000000000..41e87f32e973
--- /dev/null
+++ b/net/kea/files/patch-src-lib-process-Makefile.am
@@ -0,0 +1,9 @@
+--- src/lib/process/Makefile.am.orig 2018-12-30 16:56:27 UTC
++++ src/lib/process/Makefile.am
+@@ -1,5 +1,5 @@
+ SUBDIRS = . testutils tests
+-dhcp_data_dir = @localstatedir@/@PACKAGE@
++dhcp_data_dir = @localstatedir@/run
+ AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib
+ AM_CPPFLAGS += -DDATA_DIR="\"$(dhcp_data_dir)\""
+
diff --git a/net/kea/files/patch-src_lib_dhcp_libdhcp++.cc b/net/kea/files/patch-src_lib_dhcp_libdhcp++.cc
deleted file mode 100644
index c727e18f7b8c..000000000000
--- a/net/kea/files/patch-src_lib_dhcp_libdhcp++.cc
+++ /dev/null
@@ -1,81 +0,0 @@
-After https://github.com/boostorg/range/commit/69409ed63a9e1 build fails:
-
-libdhcp++.cc:420:24: error: call to 'distance' is ambiguous
- num_defs = distance(range.first, range.second);
- ^~~~~~~~
-libdhcp++.cc:428:24: error: call to 'distance' is ambiguous
- num_defs = distance(range.first, range.second);
- ^~~~~~~~
-libdhcp++.cc:537:24: error: call to 'distance' is ambiguous
- num_defs = distance(range.first, range.second);
- ^~~~~~~~
-libdhcp++.cc:545:24: error: call to 'distance' is ambiguous
- num_defs = distance(range.first, range.second);
- ^~~~~~~~
-libdhcp++.cc:637:31: error: call to 'distance' is ambiguous
- size_t num_defs = distance(range.first, range.second);
- ^~~~~~~~
-libdhcp++.cc:743:35: error: call to 'distance' is ambiguous
- size_t num_defs = distance(range.first, range.second);
- ^~~~~~~~
-/usr/include/c++/v1/iterator:511:1: note: candidate function [with _InputIter = boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<boost::multi_index::detail::hashed_index_node<boost::multi_index::detail::index_node_base<boost::shared_ptr<isc::dhcp::OptionDefinition>, std::__1::allocator<boost::shared_ptr<isc::dhcp::OptionDefinition> > >, boost::multi_index::detail::hashed_non_unique_tag>, boost::multi_index::detail::hashed_non_unique_tag>, boost::multi_index::detail::bucket_array<std::__1::allocator<boost::shared_ptr<isc::dhcp::OptionDefinition> > >, boost::multi_index::detail::hashed_index_global_iterator_tag>]
-distance(_InputIter __first, _InputIter __last)
-^
-/usr/local/include/boost/iterator/distance.hpp:49:9: note: candidate function [with SinglePassIterator = boost::multi_index::detail::hashed_index_iterator<boost::multi_index::detail::hashed_index_node<boost::multi_index::detail::hashed_index_node<boost::multi_index::detail::index_node_base<boost::shared_ptr<isc::dhcp::OptionDefinition>, std::__1::allocator<boost::shared_ptr<isc::dhcp::OptionDefinition> > >, boost::multi_index::detail::hashed_non_unique_tag>, boost::multi_index::detail::hashed_non_unique_tag>, boost::multi_index::detail::bucket_array<std::__1::allocator<boost::shared_ptr<isc::dhcp::OptionDefinition> > >, boost::multi_index::detail::hashed_index_global_iterator_tag>]
- distance(SinglePassIterator first, SinglePassIterator last)
- ^
-
---- src/lib/dhcp/libdhcp++.cc.orig 2018-08-15 13:54:01.170731000 -0500
-+++ src/lib/dhcp/libdhcp++.cc
-@@ -419,14 +419,14 @@
- // We previously did the lookup only for dhcp6 option space, but with the
- // addition of S46 options, we now do it for every space.
- range = idx.equal_range(opt_type);
-- num_defs = distance(range.first, range.second);
-+ num_defs = std::distance(range.first, range.second);
-
- // Standard option definitions do not include the definition for
- // our option or we're searching for non-standard option. Try to
- // find the definition among runtime option definitions.
- if (num_defs == 0) {
- range = runtime_idx.equal_range(opt_type);
-- num_defs = distance(range.first, range.second);
-+ num_defs = std::distance(range.first, range.second);
- }
-
- OptionPtr opt;
-@@ -538,14 +538,14 @@
- // may be standard options in other spaces (e.g. radius). So we now do
- // the lookup for every space.
- range = idx.equal_range(opt_type);
-- num_defs = distance(range.first, range.second);
-+ num_defs = std::distance(range.first, range.second);
-
- // Standard option definitions do not include the definition for
- // our option or we're searching for non-standard option. Try to
- // find the definition among runtime option definitions.
- if (num_defs == 0) {
- range = runtime_idx.equal_range(opt_type);
-- num_defs = distance(range.first, range.second);
-+ num_defs = std::distance(range.first, range.second);
- }
-
- // Check if option unpacking must be deferred
-@@ -638,7 +638,7 @@
- idx->equal_range(opt_type);
- // Get the number of returned option definitions for the
- // option code.
-- size_t num_defs = distance(range.first, range.second);
-+ size_t num_defs = std::distance(range.first, range.second);
-
- if (num_defs > 1) {
- // Multiple options of the same code are not supported
-@@ -746,7 +746,7 @@
- idx->equal_range(opt_type);
- // Get the number of returned option definitions for
- // the option code.
-- size_t num_defs = distance(range.first, range.second);
-+ size_t num_defs = std::distance(range.first, range.second);
-
- if (num_defs > 1) {
- // Multiple options of the same code are not
diff --git a/net/kea/pkg-plist b/net/kea/pkg-plist
index ee8beb2d7585..5908294277fa 100644
--- a/net/kea/pkg-plist
+++ b/net/kea/pkg-plist
@@ -1,6 +1,7 @@
bin/kea-msg-compiler
include/kea/asiodns/io_fetch.h
include/kea/asiodns/logger.h
+include/kea/asiolink/addr_utilities.h
include/kea/asiolink/asio_wrapper.h
include/kea/asiolink/asiolink.h
include/kea/asiolink/dummy_io_cb.h
@@ -26,6 +27,8 @@ include/kea/cc/data.h
include/kea/cc/dhcp_config_error.h
include/kea/cc/json_feed.h
include/kea/cc/simple_parser.h
+include/kea/cc/stamped_element.h
+include/kea/cc/stamped_value.h
include/kea/cc/user_context.h
include/kea/cfgrpt/config_report.h
include/kea/config.h
@@ -36,11 +39,22 @@ include/kea/config/command_mgr.h
include/kea/config/config_log.h
include/kea/config/hooked_command_mgr.h
include/kea/config/timeouts.h
+include/kea/config_backend/base_config_backend.h
+include/kea/config_backend/base_config_backend_mgr.h
+include/kea/config_backend/base_config_backend_pool.h
+include/kea/config_backend/constants.h
include/kea/cryptolink/crypto_hash.h
include/kea/cryptolink/crypto_hmac.h
+include/kea/cryptolink/crypto_rng.h
include/kea/cryptolink/cryptolink.h
include/kea/cryptolink/openssl_common.h
include/kea/cryptolink/openssl_compat.h
+include/kea/database/backend_selector.h
+include/kea/database/database_connection.h
+include/kea/database/db_exceptions.h
+include/kea/database/db_log.h
+include/kea/database/dbaccess_parser.h
+include/kea/database/server_selector.h
include/kea/dhcp/classify.h
include/kea/dhcp/dhcp4.h
include/kea/dhcp/dhcp6.h
@@ -56,6 +70,7 @@ include/kea/dhcp/option.h
include/kea/dhcp/option4_addrlst.h
include/kea/dhcp/option4_client_fqdn.h
include/kea/dhcp/option6_addrlst.h
+include/kea/dhcp/option6_auth.h
include/kea/dhcp/option6_client_fqdn.h
include/kea/dhcp/option6_ia.h
include/kea/dhcp/option6_iaaddr.h
@@ -73,6 +88,11 @@ include/kea/dhcp/option_space_container.h
include/kea/dhcp/option_string.h
include/kea/dhcp/option_vendor.h
include/kea/dhcp/option_vendor_class.h
+include/kea/dhcp/packet_queue.h
+include/kea/dhcp/packet_queue_mgr.h
+include/kea/dhcp/packet_queue_mgr4.h
+include/kea/dhcp/packet_queue_mgr6.h
+include/kea/dhcp/packet_queue_ring.h
include/kea/dhcp/pkt.h
include/kea/dhcp/pkt4.h
include/kea/dhcp/pkt4o6.h
@@ -83,12 +103,12 @@ include/kea/dhcp/pkt_filter_bpf.h
include/kea/dhcp/pkt_filter_inet.h
include/kea/dhcp/pkt_filter_inet6.h
include/kea/dhcp/protocol_util.h
+include/kea/dhcp/socket_info.h
include/kea/dhcp/std_option_defs.h
include/kea/dhcp_ddns/dhcp_ddns_log.h
include/kea/dhcp_ddns/ncr_io.h
include/kea/dhcp_ddns/ncr_msg.h
include/kea/dhcp_ddns/ncr_udp.h
-include/kea/dhcpsrv/addr_utilities.h
include/kea/dhcpsrv/alloc_engine.h
include/kea/dhcpsrv/alloc_engine_log.h
include/kea/dhcpsrv/assignable_network.h
@@ -96,6 +116,7 @@ include/kea/dhcpsrv/base_host_data_source.h
include/kea/dhcpsrv/cache_host_data_source.h
include/kea/dhcpsrv/callout_handle_store.h
include/kea/dhcpsrv/cfg_4o6.h
+include/kea/dhcpsrv/cfg_consistency.h
include/kea/dhcpsrv/cfg_db_access.h
include/kea/dhcpsrv/cfg_duid.h
include/kea/dhcpsrv/cfg_expiration.h
@@ -112,17 +133,16 @@ include/kea/dhcpsrv/cfg_subnets4.h
include/kea/dhcpsrv/cfg_subnets6.h
include/kea/dhcpsrv/cfgmgr.h
include/kea/dhcpsrv/client_class_def.h
+include/kea/dhcpsrv/config_backend_dhcp4.h
+include/kea/dhcpsrv/config_backend_dhcp4_mgr.h
+include/kea/dhcpsrv/config_backend_pool_dhcp4.h
include/kea/dhcpsrv/csv_lease_file4.h
include/kea/dhcpsrv/csv_lease_file6.h
include/kea/dhcpsrv/d2_client_cfg.h
include/kea/dhcpsrv/d2_client_mgr.h
-include/kea/dhcpsrv/daemon.h
-include/kea/dhcpsrv/database_connection.h
-include/kea/dhcpsrv/db_exceptions.h
-include/kea/dhcpsrv/db_log.h
include/kea/dhcpsrv/db_type.h
include/kea/dhcpsrv/dhcp4o6_ipc.h
-include/kea/dhcpsrv/dhcpsrv_db_log.h
+include/kea/dhcpsrv/dhcpsrv_exceptions.h
include/kea/dhcpsrv/dhcpsrv_log.h
include/kea/dhcpsrv/host.h
include/kea/dhcpsrv/host_container.h
@@ -135,29 +155,28 @@ include/kea/dhcpsrv/lease_file_loader.h
include/kea/dhcpsrv/lease_file_stats.h
include/kea/dhcpsrv/lease_mgr.h
include/kea/dhcpsrv/lease_mgr_factory.h
-include/kea/dhcpsrv/logging.h
-include/kea/dhcpsrv/logging_info.h
include/kea/dhcpsrv/memfile_lease_mgr.h
include/kea/dhcpsrv/memfile_lease_storage.h
include/kea/dhcpsrv/ncr_generator.h
include/kea/dhcpsrv/network.h
include/kea/dhcpsrv/network_state.h
include/kea/dhcpsrv/parsers/client_class_def_parser.h
-include/kea/dhcpsrv/parsers/dbaccess_parser.h
include/kea/dhcpsrv/parsers/dhcp_parsers.h
+include/kea/dhcpsrv/parsers/dhcp_queue_control_parser.h
include/kea/dhcpsrv/parsers/duid_config_parser.h
include/kea/dhcpsrv/parsers/expiration_config_parser.h
include/kea/dhcpsrv/parsers/host_reservation_parser.h
include/kea/dhcpsrv/parsers/host_reservations_list_parser.h
include/kea/dhcpsrv/parsers/ifaces_config_parser.h
include/kea/dhcpsrv/parsers/option_data_parser.h
+include/kea/dhcpsrv/parsers/sanity_checks_parser.h
include/kea/dhcpsrv/parsers/shared_network_parser.h
include/kea/dhcpsrv/parsers/shared_networks_list_parser.h
include/kea/dhcpsrv/parsers/simple_parser4.h
include/kea/dhcpsrv/parsers/simple_parser6.h
include/kea/dhcpsrv/pool.h
+include/kea/dhcpsrv/sanity_checker.h
include/kea/dhcpsrv/shared_network.h
-include/kea/dhcpsrv/sql_common.h
include/kea/dhcpsrv/srv_config.h
include/kea/dhcpsrv/subnet.h
include/kea/dhcpsrv/subnet_id.h
@@ -201,6 +220,7 @@ include/kea/dns/tsigerror.h
include/kea/dns/tsigkey.h
include/kea/dns/tsigrecord.h
include/kea/dns/zone_checker.h
+include/kea/eval/dependency.h
include/kea/eval/eval_context.h
include/kea/eval/eval_context_decl.h
include/kea/eval/eval_log.h
@@ -247,6 +267,7 @@ include/kea/http/response_creator_factory.h
include/kea/http/response_json.h
include/kea/http/response_parser.h
include/kea/http/url.h
+include/kea/kea_version.h
include/kea/log/buffer_appender_impl.h
include/kea/log/interprocess/interprocess_sync.h
include/kea/log/interprocess/interprocess_sync_file.h
@@ -272,11 +293,17 @@ include/kea/log/message_initializer.h
include/kea/log/message_reader.h
include/kea/log/message_types.h
include/kea/log/output_option.h
+include/kea/process/config_base.h
+include/kea/process/config_ctl_info.h
+include/kea/process/config_ctl_parser.h
include/kea/process/d_cfg_mgr.h
include/kea/process/d_controller.h
include/kea/process/d_log.h
include/kea/process/d_process.h
+include/kea/process/daemon.h
include/kea/process/io_service_signal.h
+include/kea/process/log_parser.h
+include/kea/process/logging_info.h
include/kea/stats/context.h
include/kea/stats/observation.h
include/kea/stats/stats_mgr.h
@@ -316,6 +343,7 @@ include/kea/util/stopwatch_impl.h
include/kea/util/strutil.h
include/kea/util/threads/sync.h
include/kea/util/threads/thread.h
+include/kea/util/threads/watched_thread.h
include/kea/util/time_utilities.h
include/kea/util/versioned_csv_file.h
include/kea/util/watch_socket.h
@@ -331,40 +359,44 @@ lib/libkea-asiodns.so.0
lib/libkea-asiodns.so.0.0.2
lib/libkea-asiolink.a
lib/libkea-asiolink.so
-lib/libkea-asiolink.so.6
-lib/libkea-asiolink.so.6.0.1
+lib/libkea-asiolink.so.7
+lib/libkea-asiolink.so.7.0.0
lib/libkea-cc.a
lib/libkea-cc.so
-lib/libkea-cc.so.5
-lib/libkea-cc.so.5.0.0
+lib/libkea-cc.so.7
+lib/libkea-cc.so.7.0.0
lib/libkea-cfgclient.a
lib/libkea-cfgclient.so
-lib/libkea-cfgclient.so.5
-lib/libkea-cfgclient.so.5.0.1
+lib/libkea-cfgclient.so.6
+lib/libkea-cfgclient.so.6.0.0
lib/libkea-cryptolink.a
lib/libkea-cryptolink.so
-lib/libkea-cryptolink.so.3
-lib/libkea-cryptolink.so.3.0.0
+lib/libkea-cryptolink.so.4
+lib/libkea-cryptolink.so.4.0.0
+lib/libkea-database.a
+lib/libkea-database.so
+lib/libkea-database.so.1
+lib/libkea-database.so.1.0.0
lib/libkea-dhcp++.a
lib/libkea-dhcp++.so
-lib/libkea-dhcp++.so.8
-lib/libkea-dhcp++.so.8.0.0
+lib/libkea-dhcp++.so.11
+lib/libkea-dhcp++.so.11.0.0
lib/libkea-dhcp_ddns.a
lib/libkea-dhcp_ddns.so
lib/libkea-dhcp_ddns.so.1
lib/libkea-dhcp_ddns.so.1.0.3
lib/libkea-dhcpsrv.a
lib/libkea-dhcpsrv.so
-lib/libkea-dhcpsrv.so.11
-lib/libkea-dhcpsrv.so.11.0.0
+lib/libkea-dhcpsrv.so.14
+lib/libkea-dhcpsrv.so.14.0.0
lib/libkea-dns++.a
lib/libkea-dns++.so
-lib/libkea-dns++.so.2
-lib/libkea-dns++.so.2.0.1
+lib/libkea-dns++.so.3
+lib/libkea-dns++.so.3.0.0
lib/libkea-eval.a
lib/libkea-eval.so
-lib/libkea-eval.so.7
-lib/libkea-eval.so.7.0.1
+lib/libkea-eval.so.10
+lib/libkea-eval.so.10.0.0
lib/libkea-exceptions.a
lib/libkea-exceptions.so
lib/libkea-exceptions.so.0
@@ -372,35 +404,35 @@ lib/libkea-exceptions.so.0.0.1
lib/libkea-hooks.a
lib/libkea-hooks.so
lib/libkea-hooks.so.7
-lib/libkea-hooks.so.7.0.0
+lib/libkea-hooks.so.7.0.2
lib/libkea-http.a
lib/libkea-http.so
-lib/libkea-http.so.2
-lib/libkea-http.so.2.0.0
+lib/libkea-http.so.4
+lib/libkea-http.so.4.0.0
lib/libkea-log.a
lib/libkea-log.so
lib/libkea-log.so.3
lib/libkea-log.so.3.0.1
lib/libkea-process.a
lib/libkea-process.so
-lib/libkea-process.so.2
-lib/libkea-process.so.2.0.1
+lib/libkea-process.so.3
+lib/libkea-process.so.3.0.0
lib/libkea-stats.a
lib/libkea-stats.so
lib/libkea-stats.so.2
lib/libkea-stats.so.2.0.2
lib/libkea-threads.a
lib/libkea-threads.so
-lib/libkea-threads.so.1
-lib/libkea-threads.so.1.0.0
+lib/libkea-threads.so.2
+lib/libkea-threads.so.2.0.0
lib/libkea-util-io.a
lib/libkea-util-io.so
lib/libkea-util-io.so.0
lib/libkea-util-io.so.0.0.1
lib/libkea-util.a
lib/libkea-util.so
-lib/libkea-util.so.3
-lib/libkea-util.so.3.0.1
+lib/libkea-util.so.5
+lib/libkea-util.so.5.0.0
libdata/pkgconfig/dns++.pc
man/man8/kea-admin.8.gz
man/man8/kea-ctrl-agent.8.gz
@@ -423,6 +455,7 @@ sbin/perfdhcp
%%DATADIR%%/scripts/cql/dhcpdb_drop.cql
%%DATADIR%%/scripts/cql/soft_wipe.cql
%%DATADIR%%/scripts/cql/upgrade_1.0_to_2.0.sh
+%%DATADIR%%/scripts/cql/upgrade_2.0_to_3.0.sh
%%DATADIR%%/scripts/mysql/dhcpdb_create.mysql
%%DATADIR%%/scripts/mysql/dhcpdb_drop.mysql
%%DATADIR%%/scripts/mysql/upgrade_1.0_to_2.0.sh
@@ -433,6 +466,7 @@ sbin/perfdhcp
%%DATADIR%%/scripts/mysql/upgrade_5.0_to_5.1.sh
%%DATADIR%%/scripts/mysql/upgrade_5.1_to_5.2.sh
%%DATADIR%%/scripts/mysql/upgrade_5.2_to_6.0.sh
+%%DATADIR%%/scripts/mysql/upgrade_6.0_to_7.0.sh
%%DATADIR%%/scripts/pgsql/dhcpdb_create.pgsql
%%DATADIR%%/scripts/pgsql/dhcpdb_drop.pgsql
%%DATADIR%%/scripts/pgsql/upgrade_1.0_to_2.0.sh
@@ -441,9 +475,26 @@ sbin/perfdhcp
%%DATADIR%%/scripts/pgsql/upgrade_3.1_to_3.2.sh
%%DATADIR%%/scripts/pgsql/upgrade_3.2_to_3.3.sh
%%DATADIR%%/scripts/pgsql/upgrade_3.3_to_4.0.sh
+%%DATADIR%%/scripts/pgsql/upgrade_4.0_to_5.0.sh
+%%DATADIR%%/yang/modules/ietf-dhcpv6-client@2018-09-04.yang
+%%DATADIR%%/yang/modules/ietf-dhcpv6-options@2018-09-04.yang
+%%DATADIR%%/yang/modules/ietf-dhcpv6-relay@2018-09-04.yang
+%%DATADIR%%/yang/modules/ietf-dhcpv6-server@2018-09-04.yang
+%%DATADIR%%/yang/modules/ietf-dhcpv6-types@2018-09-04.yang
+%%DATADIR%%/yang/modules/ietf-inet-types@2013-07-15.yang
+%%DATADIR%%/yang/modules/ietf-interfaces@2014-05-08.yang
+%%DATADIR%%/yang/modules/ietf-yang-types@2013-07-15.yang
+%%DATADIR%%/yang/modules/kea-ctrl-agent@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-dhcp-ddns@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-dhcp-types@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-dhcp4-server@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-dhcp6-server@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-logging@2018-11-20.yang
+%%DATADIR%%/yang/modules/kea-types@2018-11-20.yang
@sample %%ETCDIR%%/kea-ctrl-agent.conf.sample
@sample %%ETCDIR%%/kea-dhcp-ddns.conf.sample
@sample %%ETCDIR%%/kea-dhcp4.conf.sample
@sample %%ETCDIR%%/kea-dhcp6.conf.sample
+@sample %%ETCDIR%%/kea-netconf.conf.sample
@sample %%ETCDIR%%/keactrl.conf.sample
@dir /var/db/kea