aboutsummaryrefslogtreecommitdiff
path: root/net/kea
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-12-31 16:36:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-12-31 16:36:04 +0000
commita7a8d8bb1915f7cf1e804468ddbb856cd7f7b85e (patch)
tree164a8d9b2cee38d2294122369b8d14d49f274c97 /net/kea
parenteab3d4dc21f923b2e6e748ba4cfccde8aca84ed1 (diff)
downloadports-a7a8d8bb1915f7cf1e804468ddbb856cd7f7b85e.tar.gz
ports-a7a8d8bb1915f7cf1e804468ddbb856cd7f7b85e.zip
Notes
Diffstat (limited to 'net/kea')
-rw-r--r--net/kea/Makefile3
-rw-r--r--net/kea/pkg-plist17
2 files changed, 19 insertions, 1 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 175d32fb8efb..e797e90d465f 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -27,7 +27,7 @@ CPE_VERSION= ${ISCVERSION:C/-.*//}
CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
.endif
-USES= autoreconf compiler:c++11-lang libtool pathfix ssl cpe
+USES= autoreconf compiler:c++11-lang iconv libtool pathfix ssl cpe
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
@@ -45,6 +45,7 @@ PORTDOCS= AUTHORS COPYING ChangeLog README \
examples
OPTIONS_DEFINE= DOCS MYSQL PGSQL
+OPTIONS_SUB= yes
DOCS_MAKE_ARGS_OFF= \
INSTALL_STRIP_PROGRAM="${WRKSRC}/install-sh -c -s" \
INSTALL_STRIP_FLAG="-s" \
diff --git a/net/kea/pkg-plist b/net/kea/pkg-plist
index 5908294277fa..0350fd778700 100644
--- a/net/kea/pkg-plist
+++ b/net/kea/pkg-plist
@@ -157,6 +157,8 @@ include/kea/dhcpsrv/lease_mgr.h
include/kea/dhcpsrv/lease_mgr_factory.h
include/kea/dhcpsrv/memfile_lease_mgr.h
include/kea/dhcpsrv/memfile_lease_storage.h
+%%MYSQL%%include/kea/dhcpsrv/mysql_host_data_source.h
+%%MYSQL%%include/kea/dhcpsrv/mysql_lease_mgr.h
include/kea/dhcpsrv/ncr_generator.h
include/kea/dhcpsrv/network.h
include/kea/dhcpsrv/network_state.h
@@ -175,6 +177,8 @@ include/kea/dhcpsrv/parsers/shared_networks_list_parser.h
include/kea/dhcpsrv/parsers/simple_parser4.h
include/kea/dhcpsrv/parsers/simple_parser6.h
include/kea/dhcpsrv/pool.h
+%%PGSQL%%include/kea/dhcpsrv/pgsql_host_data_source.h
+%%PGSQL%%include/kea/dhcpsrv/pgsql_lease_mgr.h
include/kea/dhcpsrv/sanity_checker.h
include/kea/dhcpsrv/shared_network.h
include/kea/dhcpsrv/srv_config.h
@@ -293,6 +297,11 @@ include/kea/log/message_initializer.h
include/kea/log/message_reader.h
include/kea/log/message_types.h
include/kea/log/output_option.h
+%%MYSQL%%include/kea/mysql/mysql_binding.h
+%%MYSQL%%include/kea/mysql/mysql_connection.h
+%%MYSQL%%include/kea/mysql/mysql_constants.h
+%%PGSQL%%include/kea/pgsql/pgsql_connection.h
+%%PGSQL%%include/kea/pgsql/pgsql_exchange.h
include/kea/process/config_base.h
include/kea/process/config_ctl_info.h
include/kea/process/config_ctl_parser.h
@@ -413,6 +422,14 @@ lib/libkea-log.a
lib/libkea-log.so
lib/libkea-log.so.3
lib/libkea-log.so.3.0.1
+%%MYSQL%%lib/libkea-mysql.a
+%%MYSQL%%lib/libkea-mysql.so
+%%MYSQL%%lib/libkea-mysql.so.0
+%%MYSQL%%lib/libkea-mysql.so.0.0.1
+%%PGSQL%%lib/libkea-pgsql.a
+%%PGSQL%%lib/libkea-pgsql.so
+%%PGSQL%%lib/libkea-pgsql.so.0
+%%PGSQL%%lib/libkea-pgsql.so.0.0.0
lib/libkea-process.a
lib/libkea-process.so
lib/libkea-process.so.3