aboutsummaryrefslogtreecommitdiff
path: root/net/kf5-kcontacts
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-10-17 18:06:42 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-10-17 18:06:42 +0000
commita9479c561cd6a289e584168f8d5ae3ac381d3006 (patch)
tree3377a5ed6fa362ac166fa085ac3646213434ec70 /net/kf5-kcontacts
parente89764772a78a07fa9ff91dc221edbf7ecee7e3c (diff)
downloadports-a9479c561cd6a289e584168f8d5ae3ac381d3006.tar.gz
ports-a9479c561cd6a289e584168f8d5ae3ac381d3006.zip
Notes
Diffstat (limited to 'net/kf5-kcontacts')
-rw-r--r--net/kf5-kcontacts/Makefile28
-rw-r--r--net/kf5-kcontacts/distinfo3
-rw-r--r--net/kf5-kcontacts/pkg-plist129
3 files changed, 160 insertions, 0 deletions
diff --git a/net/kf5-kcontacts/Makefile b/net/kf5-kcontacts/Makefile
new file mode 100644
index 000000000000..1792c0a4ee4b
--- /dev/null
+++ b/net/kf5-kcontacts/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= kcontacts
+DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTEPOCH= 1
+CATEGORIES= net kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE api to manage contact information
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= iso-codes>=0:misc/iso-codes
+RUN_DEPENDS= iso-codes>=0:misc/iso-codes
+
+USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz
+USE_KDE= ecm codecs config coreaddons i18n
+USE_QT= core dbus gui \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+OPTIONS_DEFINE= DOCS
+
+CONFLICTS_INSTALL= kcontacts-1*
+
+.include <bsd.port.mk>
diff --git a/net/kf5-kcontacts/distinfo b/net/kf5-kcontacts/distinfo
new file mode 100644
index 000000000000..9525dde4db20
--- /dev/null
+++ b/net/kf5-kcontacts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1571172276
+SHA256 (KDE/frameworks/5.63.0/kcontacts-5.63.0.tar.xz) = 10f0bb2cbcab33332830763a0f9313c0c5919c0d5dc974908965b24d68614577
+SIZE (KDE/frameworks/5.63.0/kcontacts-5.63.0.tar.xz) = 540728
diff --git a/net/kf5-kcontacts/pkg-plist b/net/kf5-kcontacts/pkg-plist
new file mode 100644
index 000000000000..d7f6ccf7ea8f
--- /dev/null
+++ b/net/kf5-kcontacts/pkg-plist
@@ -0,0 +1,129 @@
+include/KF5/KContacts/KContacts/Address
+include/KF5/KContacts/KContacts/Addressee
+include/KF5/KContacts/KContacts/AddresseeList
+include/KF5/KContacts/KContacts/CalendarUrl
+include/KF5/KContacts/KContacts/ClientPidMap
+include/KF5/KContacts/KContacts/ContactGroup
+include/KF5/KContacts/KContacts/ContactGroupTool
+include/KF5/KContacts/KContacts/Email
+include/KF5/KContacts/KContacts/Field
+include/KF5/KContacts/KContacts/FieldGroup
+include/KF5/KContacts/KContacts/Gender
+include/KF5/KContacts/KContacts/Geo
+include/KF5/KContacts/KContacts/Impp
+include/KF5/KContacts/KContacts/Key
+include/KF5/KContacts/KContacts/LDIFConverter
+include/KF5/KContacts/KContacts/Lang
+include/KF5/KContacts/KContacts/NickName
+include/KF5/KContacts/KContacts/Note
+include/KF5/KContacts/KContacts/Org
+include/KF5/KContacts/KContacts/PhoneNumber
+include/KF5/KContacts/KContacts/Picture
+include/KF5/KContacts/KContacts/Related
+include/KF5/KContacts/KContacts/ResourceLocatorUrl
+include/KF5/KContacts/KContacts/Role
+include/KF5/KContacts/KContacts/Secrecy
+include/KF5/KContacts/KContacts/Sound
+include/KF5/KContacts/KContacts/TimeZone
+include/KF5/KContacts/KContacts/Title
+include/KF5/KContacts/KContacts/VCardConverter
+include/KF5/KContacts/KContacts/VCardDrag
+include/KF5/KContacts/kcontacts/address.h
+include/KF5/KContacts/kcontacts/addressee.h
+include/KF5/KContacts/kcontacts/addresseelist.h
+include/KF5/KContacts/kcontacts/calendarurl.h
+include/KF5/KContacts/kcontacts/clientpidmap.h
+include/KF5/KContacts/kcontacts/contactgroup.h
+include/KF5/KContacts/kcontacts/contactgrouptool.h
+include/KF5/KContacts/kcontacts/email.h
+include/KF5/KContacts/kcontacts/field.h
+include/KF5/KContacts/kcontacts/fieldgroup.h
+include/KF5/KContacts/kcontacts/gender.h
+include/KF5/KContacts/kcontacts/geo.h
+include/KF5/KContacts/kcontacts/impp.h
+include/KF5/KContacts/kcontacts/kcontacts_export.h
+include/KF5/KContacts/kcontacts/key.h
+include/KF5/KContacts/kcontacts/lang.h
+include/KF5/KContacts/kcontacts/ldifconverter.h
+include/KF5/KContacts/kcontacts/nickname.h
+include/KF5/KContacts/kcontacts/note.h
+include/KF5/KContacts/kcontacts/org.h
+include/KF5/KContacts/kcontacts/phonenumber.h
+include/KF5/KContacts/kcontacts/picture.h
+include/KF5/KContacts/kcontacts/related.h
+include/KF5/KContacts/kcontacts/resourcelocatorurl.h
+include/KF5/KContacts/kcontacts/role.h
+include/KF5/KContacts/kcontacts/secrecy.h
+include/KF5/KContacts/kcontacts/sound.h
+include/KF5/KContacts/kcontacts/timezone.h
+include/KF5/KContacts/kcontacts/title.h
+include/KF5/KContacts/kcontacts/vcardconverter.h
+include/KF5/KContacts/kcontacts/vcarddrag.h
+include/KF5/kcontacts_version.h
+lib/cmake/KF5Contacts/KF5ContactsConfig.cmake
+lib/cmake/KF5Contacts/KF5ContactsConfigVersion.cmake
+lib/cmake/KF5Contacts/KF5ContactsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5Contacts/KF5ContactsTargets.cmake
+lib/libKF5Contacts.so
+lib/libKF5Contacts.so.5
+lib/libKF5Contacts.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KContacts.pri
+share/locale/ar/LC_MESSAGES/kcontacts5.mo
+share/locale/ast/LC_MESSAGES/kcontacts5.mo
+share/locale/be/LC_MESSAGES/kcontacts5.mo
+share/locale/bs/LC_MESSAGES/kcontacts5.mo
+share/locale/ca/LC_MESSAGES/kcontacts5.mo
+share/locale/ca@valencia/LC_MESSAGES/kcontacts5.mo
+share/locale/cs/LC_MESSAGES/kcontacts5.mo
+share/locale/da/LC_MESSAGES/kcontacts5.mo
+share/locale/de/LC_MESSAGES/kcontacts5.mo
+share/locale/el/LC_MESSAGES/kcontacts5.mo
+share/locale/en_GB/LC_MESSAGES/kcontacts5.mo
+share/locale/eo/LC_MESSAGES/kcontacts5.mo
+share/locale/es/LC_MESSAGES/kcontacts5.mo
+share/locale/et/LC_MESSAGES/kcontacts5.mo
+share/locale/fi/LC_MESSAGES/kcontacts5.mo
+share/locale/fr/LC_MESSAGES/kcontacts5.mo
+share/locale/ga/LC_MESSAGES/kcontacts5.mo
+share/locale/gl/LC_MESSAGES/kcontacts5.mo
+share/locale/hi/LC_MESSAGES/kcontacts5.mo
+share/locale/hne/LC_MESSAGES/kcontacts5.mo
+share/locale/hu/LC_MESSAGES/kcontacts5.mo
+share/locale/ia/LC_MESSAGES/kcontacts5.mo
+share/locale/it/LC_MESSAGES/kcontacts5.mo
+share/locale/ja/LC_MESSAGES/kcontacts5.mo
+share/locale/kk/LC_MESSAGES/kcontacts5.mo
+share/locale/km/LC_MESSAGES/kcontacts5.mo
+share/locale/ko/LC_MESSAGES/kcontacts5.mo
+share/locale/lt/LC_MESSAGES/kcontacts5.mo
+share/locale/lv/LC_MESSAGES/kcontacts5.mo
+share/locale/mai/LC_MESSAGES/kcontacts5.mo
+share/locale/mr/LC_MESSAGES/kcontacts5.mo
+share/locale/nb/LC_MESSAGES/kcontacts5.mo
+share/locale/nds/LC_MESSAGES/kcontacts5.mo
+share/locale/nl/LC_MESSAGES/kcontacts5.mo
+share/locale/nn/LC_MESSAGES/kcontacts5.mo
+share/locale/pa/LC_MESSAGES/kcontacts5.mo
+share/locale/pl/LC_MESSAGES/kcontacts5.mo
+share/locale/pt/LC_MESSAGES/kcontacts5.mo
+share/locale/pt_BR/LC_MESSAGES/kcontacts5.mo
+share/locale/ro/LC_MESSAGES/kcontacts5.mo
+share/locale/ru/LC_MESSAGES/kcontacts5.mo
+share/locale/se/LC_MESSAGES/kcontacts5.mo
+share/locale/sk/LC_MESSAGES/kcontacts5.mo
+share/locale/sl/LC_MESSAGES/kcontacts5.mo
+share/locale/sq/LC_MESSAGES/kcontacts5.mo
+share/locale/sr/LC_MESSAGES/kcontacts5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/kcontacts5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/kcontacts5.mo
+share/locale/sr@latin/LC_MESSAGES/kcontacts5.mo
+share/locale/sv/LC_MESSAGES/kcontacts5.mo
+share/locale/tg/LC_MESSAGES/kcontacts5.mo
+share/locale/th/LC_MESSAGES/kcontacts5.mo
+share/locale/tr/LC_MESSAGES/kcontacts5.mo
+share/locale/ug/LC_MESSAGES/kcontacts5.mo
+share/locale/uk/LC_MESSAGES/kcontacts5.mo
+share/locale/zh_CN/LC_MESSAGES/kcontacts5.mo
+share/locale/zh_TW/LC_MESSAGES/kcontacts5.mo
+share/qlogging-categories5/kcontacts.categories
+share/qlogging-categories5/kcontacts.renamecategories