aboutsummaryrefslogtreecommitdiff
path: root/net/kf5-kxmlrpcclient
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-11-14 16:12:56 +0000
commit30a183cdd9faf4c65a08818c285c8d9351e43ad3 (patch)
treedbe08499461c3eea79dce8b1eca87e2699ef0d1c /net/kf5-kxmlrpcclient
parent1ff45cdd0ae918b61cf33786436856d37aa2dcfb (diff)
downloadports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.tar.gz
ports-30a183cdd9faf4c65a08818c285c8d9351e43ad3.zip
Notes
Diffstat (limited to 'net/kf5-kxmlrpcclient')
-rw-r--r--net/kf5-kxmlrpcclient/Makefile15
-rw-r--r--net/kf5-kxmlrpcclient/distinfo3
-rw-r--r--net/kf5-kxmlrpcclient/pkg-descr3
-rw-r--r--net/kf5-kxmlrpcclient/pkg-plist69
4 files changed, 90 insertions, 0 deletions
diff --git a/net/kf5-kxmlrpcclient/Makefile b/net/kf5-kxmlrpcclient/Makefile
new file mode 100644
index 000000000000..e3dae356a242
--- /dev/null
+++ b/net/kf5-kxmlrpcclient/Makefile
@@ -0,0 +1,15 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kxmlrpcclient
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= net kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 interaction with XMLRPC services
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= config coreaddons ecm doctools i18n kio service
+USE_QT5= buildtools_build core gui qmake_build xml
+
+.include <bsd.port.mk>
diff --git a/net/kf5-kxmlrpcclient/distinfo b/net/kf5-kxmlrpcclient/distinfo
new file mode 100644
index 000000000000..9fbc8259947c
--- /dev/null
+++ b/net/kf5-kxmlrpcclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475424081
+SHA256 (KDE/frameworks/5.27.0/kxmlrpcclient-5.27.0.tar.xz) = 61abedec062b2c71593c0f26632f9659217ac306e2957e0c9b21138951dd6a9d
+SIZE (KDE/frameworks/5.27.0/kxmlrpcclient-5.27.0.tar.xz) = 28436
diff --git a/net/kf5-kxmlrpcclient/pkg-descr b/net/kf5-kxmlrpcclient/pkg-descr
new file mode 100644
index 000000000000..98f0615da7a1
--- /dev/null
+++ b/net/kf5-kxmlrpcclient/pkg-descr
@@ -0,0 +1,3 @@
+kxmlrpclient provides client-side support for the XML-RPC protocol.
+
+WWW: http://api.kde.org/frameworks-api/frameworks5-apidocs/kxmlrpcclient/html/index.html
diff --git a/net/kf5-kxmlrpcclient/pkg-plist b/net/kf5-kxmlrpcclient/pkg-plist
new file mode 100644
index 000000000000..b9cc89373a1c
--- /dev/null
+++ b/net/kf5-kxmlrpcclient/pkg-plist
@@ -0,0 +1,69 @@
+include/KF5/KXmlRpcClient/KXmlRpcClient/Client
+include/KF5/KXmlRpcClient/kxmlrpcclient/client.h
+include/KF5/KXmlRpcClient/kxmlrpcclient/kxmlrpcclient_export.h
+include/KF5/kxmlrpcclient_version.h
+lib/cmake/KF5XmlRpcClient/KF5XmlRpcClientConfig.cmake
+lib/cmake/KF5XmlRpcClient/KF5XmlRpcClientConfigVersion.cmake
+lib/cmake/KF5XmlRpcClient/KF5XmlRpcClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5XmlRpcClient/KF5XmlRpcClientTargets.cmake
+lib/libKF5XmlRpcClient.so
+lib/libKF5XmlRpcClient.so.5
+lib/libKF5XmlRpcClient.so.%%KDE_FRAMEWORKS_VERSION%%
+%%QT_MKSPECDIR%%/modules/qt_KXmlRpcClient.pri
+share/locale/ar/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ast/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/be/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/bg/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/bs/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ca/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ca@valencia/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/cs/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/da/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/de/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/el/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/en_GB/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/eo/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/es/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/et/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/fi/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/fr/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ga/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/gd/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/gl/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/he/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/hi/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/hne/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/hu/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ia/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/it/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ja/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/kk/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/km/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ko/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/lt/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/lv/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/mr/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/nb/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/nds/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/nl/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/nn/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/pa/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/pl/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/pt/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/pt_BR/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ro/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ru/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/se/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sk/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sl/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sq/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sr/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sr@latin/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/sv/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/tr/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/ug/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/uk/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/zh_CN/LC_MESSAGES/libkxmlrpcclient5.mo
+share/locale/zh_TW/LC_MESSAGES/libkxmlrpcclient5.mo