aboutsummaryrefslogtreecommitdiff
path: root/net/kojoney
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-05 20:08:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-05 20:08:46 +0000
commitbc6842e502bf445dbda8104b1a1ce6c998665f12 (patch)
tree82b5cac92e709ce21b5f49670cb8c9620d32f2e6 /net/kojoney
parentb1a741e2b719b9eedbd1e163c2d3bc9d8b0eeb4f (diff)
downloadports-bc6842e502bf445dbda8104b1a1ce6c998665f12.tar.gz
ports-bc6842e502bf445dbda8104b1a1ce6c998665f12.zip
Notes
Diffstat (limited to 'net/kojoney')
-rw-r--r--net/kojoney/Makefile28
-rw-r--r--net/kojoney/distinfo3
-rw-r--r--net/kojoney/files/patch-Makefile19
-rw-r--r--net/kojoney/pkg-descr4
-rw-r--r--net/kojoney/pkg-plist17
5 files changed, 71 insertions, 0 deletions
diff --git a/net/kojoney/Makefile b/net/kojoney/Makefile
new file mode 100644
index 000000000000..ffd9f02eb7e2
--- /dev/null
+++ b/net/kojoney/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: kojoney
+# Date created: 5 December 2006
+# Whom: mj <systemoperator@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kojoney
+PORTVERSION= 0.0.4.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=kojoney
+
+MAINTAINER= systemoperator@gmail.com
+COMMENT= A low level interaction honeypot that emulates an SSH server
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/zope/interface/interface.py:${PORTSDIR}/devel/py-zopeInterface \
+ ${PYTHONPREFIX_SITELIBDIR}/Crypto:${PORTSDIR}/security/py-pycrypto \
+ ${SITE_PERL}/IP/Country.pm:${PORTSDIR}/net/p5-IP-Country
+
+WRKSRC= ${WRKDIR}/kojoney
+
+USE_PYTHON= 2.4+
+USE_TWISTED= conch
+USE_OPENSSL= yes
+USE_PERL5_RUN= yes
+
+.include <bsd.port.mk>
diff --git a/net/kojoney/distinfo b/net/kojoney/distinfo
new file mode 100644
index 000000000000..8b70e4bc0f34
--- /dev/null
+++ b/net/kojoney/distinfo
@@ -0,0 +1,3 @@
+MD5 (kojoney-0.0.4.1.tar.gz) = 85c588498051bdfc6c69b7827cfebbfa
+SHA256 (kojoney-0.0.4.1.tar.gz) = a2f8bf201cd5914ecdb5375586b61e4d7c00f0cd6886e2fa86a50062692cde94
+SIZE (kojoney-0.0.4.1.tar.gz) = 3201022
diff --git a/net/kojoney/files/patch-Makefile b/net/kojoney/files/patch-Makefile
new file mode 100644
index 000000000000..56aa7e360cb1
--- /dev/null
+++ b/net/kojoney/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.old Tue Dec 5 15:12:55 2006
++++ Makefile Tue Dec 5 15:11:49 2006
+@@ -0,0 +1,16 @@
++all:
++ @echo ""
++ @echo ""
++ @echo "There's nothing to do. Just use 'make install'."
++ @echo ""
++install:
++ @mkdir -p ${PREFIX}/kojoney/reports
++ @mv coret_config.py coret_config.py.dist
++ @cp -pf coret_config.py.dist ${PREFIX}/kojoney
++ @cp -pf *.py ${PREFIX}/kojoney
++ @cp -pf KoJoney.e3p ${PREFIX}/kojoney
++ @mv fake_users fake_users.dist
++ @cp -pf fake_users.dist ${PREFIX}/kojoney
++ @cp -pf reports/k* ${PREFIX}/kojoney/reports
++ @mv coret_config.py.dist coret_config.py
++ @mv fake_users.dist fake_users
diff --git a/net/kojoney/pkg-descr b/net/kojoney/pkg-descr
new file mode 100644
index 000000000000..6276cae07912
--- /dev/null
+++ b/net/kojoney/pkg-descr
@@ -0,0 +1,4 @@
+Kojoney is a low level interaction honeypot that emulates an SSH server.
+The daemon is written in Python using the Twisted Conch libraries.
+
+WWW: http://kojoney.sourceforge.net/
diff --git a/net/kojoney/pkg-plist b/net/kojoney/pkg-plist
new file mode 100644
index 000000000000..dad866712d3e
--- /dev/null
+++ b/net/kojoney/pkg-plist
@@ -0,0 +1,17 @@
+kojoney/KoJoney.e3p
+kojoney/coret_command.py
+kojoney/coret_config.py.dist
+kojoney/coret_fake.py
+kojoney/coret_honey.py
+kojoney/coret_log.py
+kojoney/coret_std_unix.py
+kojoney/coret_users.py
+kojoney/fake_users.dist
+kojoney/kojoney.py
+kojoney/reports/kojhumans
+kojoney/reports/kojreport-filter
+kojoney/reports/kip2country
+kojoney/reports/kojreport
+kojoney/reports/kojsession
+@dirrmtry kojoney/reports
+@dirrmtry kojoney