aboutsummaryrefslogtreecommitdiff
path: root/net/krdc/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /net/krdc/Makefile
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
KDE/FreeBSD team presents KDE SC 4.9.5 ports!
- kdebindings ports have been renamed to match upstream. - kdemultimedia and kdenetwork have been split. - New port games/pairs added. - Trim Makefile header - Convert to new option framework - New USE_KDE4 components: libkcddb, libkcompactdisc - Update: databases/akonadi to 1.9.0 devel/grantlee to 0.3.0 textproc/rasqal to 0.9.30 textproc/redland-bindings to 1.0.16.1 textproc/soprano to 2.9.0 x11-toolkits/attica to 0.4.1 The area51 repository features commits by Schaich Alonso, avilla, dbn, jhale, makc and rakuco. Contributors: - Oleg Sidorkin - Tobias Berner - Kurt Jaeger
Notes
Notes: svn path=/head/; revision=311483
Diffstat (limited to 'net/krdc/Makefile')
-rw-r--r--net/krdc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/krdc/Makefile b/net/krdc/Makefile
new file mode 100644
index 000000000000..d5fb0916e662
--- /dev/null
+++ b/net/krdc/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= krdc
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DISTNAME= kdenetwork-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= RDP and VNC client for KDE
+
+LIB_DEPENDS= vncserver.0:${PORTSDIR}/net/libvncserver \
+ telepathy-qt4.2:${PORTSDIR}/net-im/telepathy-qt4
+
+DISTINFO_FILE= ${.CURDIR}/../../net/kdenetwork4/distinfo
+
+CONFLICTS_INSTALL= kdenetwork-4.[1-8].*
+
+USE_CMAKE= yes
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CMAKE_OUTSOURCE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
+
+.include <bsd.port.mk>