aboutsummaryrefslogtreecommitdiff
path: root/net/krfb
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:10:37 +0000
commitcb8b1428c6bb9ed135f61a9cecbe8397defbf329 (patch)
tree0a68a09c88303888985b47f7045bed36788aefc2 /net/krfb
parent563bcaab10c891e4bee07c4ec1fbf46515c5a0b4 (diff)
downloadports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.tar.gz
ports-cb8b1428c6bb9ed135f61a9cecbe8397defbf329.zip
Notes
Diffstat (limited to 'net/krfb')
-rw-r--r--net/krfb/Makefile30
-rw-r--r--net/krfb/pkg-descr6
-rw-r--r--net/krfb/pkg-plist14
3 files changed, 50 insertions, 0 deletions
diff --git a/net/krfb/Makefile b/net/krfb/Makefile
new file mode 100644
index 000000000000..0867774031f0
--- /dev/null
+++ b/net/krfb/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= krfb
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DISTNAME= kdenetwork-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= VNC server for KDE
+
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+ telepathy-qt4.2:${PORTSDIR}/net-im/telepathy-qt4
+
+DISTINFO_FILE= ${.CURDIR}/../../net/kdenetwork4/distinfo
+
+CONFLICTS_INSTALL= kdenetwork-4.[1-8].*
+
+USE_CMAKE= yes
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+CMAKE_OUTSOURCE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/krfb/pkg-descr b/net/krfb/pkg-descr
new file mode 100644
index 000000000000..0f87a31efe3a
--- /dev/null
+++ b/net/krfb/pkg-descr
@@ -0,0 +1,6 @@
+KDE Desktop Sharing (krfb) is a small server for the RFB protocol,
+better known as VNC. Unlike most other Unix/Linux RFB servers, KRfb
+allows you to share your X11 session instead of creating a new X11
+session.
+
+WWW: www.kde.org
diff --git a/net/krfb/pkg-plist b/net/krfb/pkg-plist
new file mode 100644
index 000000000000..cb9043f082ca
--- /dev/null
+++ b/net/krfb/pkg-plist
@@ -0,0 +1,14 @@
+bin/krfb
+lib/kde4/krfb_framebuffer_qt.so
+lib/kde4/krfb_framebuffer_x11.so
+lib/libkrfbprivate.so.5.0.1
+share/applications/kde4/krfb.desktop
+share/apps/krfb/krfb.notifyrc
+share/dbus-1/services/org.freedesktop.Telepathy.Client.krfb_rfb_handler.service
+share/kde4/services/krfb_framebuffer_qt.desktop
+share/kde4/services/krfb_framebuffer_x11.desktop
+share/kde4/servicetypes/krfb-framebuffer.desktop
+share/telepathy/clients/krfb_rfb_handler.client
+@dirrmtry share/telepathy/clients
+@dirrmtry share/telepathy
+@dirrm share/apps/krfb