aboutsummaryrefslogtreecommitdiff
path: root/net/l4ip
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-02-17 18:44:32 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-02-17 18:44:32 +0000
commit08e492016fb71d84c431750564039c310aecc805 (patch)
tree6725b91acf37bd6a071bd764b517face231f5900 /net/l4ip
parentc9c4bbaef78ba1511563447a06794aa5d97e94de (diff)
- add l4ip-v1.0.b294, the L4 health check daemon for IPFILTER.
The idea is that IPFilter in its current state can already do a simple L4 round-robin in its NAT rules. However, it does not detect or sense when a service and/or host is down. It will continue to send requests to a downed service/host. However, IPFilter lets us add and remove rules on-the-fly so it should be possible to build a daemon that lets you specify "clusters". In each cluster you would specify its members/hosts and services. As well as a health-check for the service to determine its current state. Once a service was deemed "up" we would add a Round-Robin rule to the NAT table, and naturally, the reverse once we detect a service as being "down". In addition to this, this program can optionally add ipf rules to log for RST (reset) packets coming from the members of your clusters. In the situations where the software/port goes down, but the host itself is still working, we would detect failure instantly. (Since the forwarded connections to the service would trigger a RST packet back). If this option is enabled, l4ip spawns the "ipmon" command to monitor for the "log" entries given when such a packet is detected. l4ip will then mark the service down. This is an add-on feature and is strictly not necessary for functional usage. It is currently only supported for TCP. WWW: http://www.lundman.net/unix/l4ip.php
Notes
Notes: svn path=/head/; revision=156224
Diffstat (limited to 'net/l4ip')
-rw-r--r--net/l4ip/Makefile31
-rw-r--r--net/l4ip/distinfo3
-rw-r--r--net/l4ip/pkg-descr24
-rw-r--r--net/l4ip/pkg-plist12
4 files changed, 70 insertions, 0 deletions
diff --git a/net/l4ip/Makefile b/net/l4ip/Makefile
new file mode 100644
index 000000000000..594daf563378
--- /dev/null
+++ b/net/l4ip/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: l4ip
+# Date created: 17 February 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l4ip
+PORTVERSION= 1.0.294
+CATEGORIES= net
+MASTER_SITES= http://www.lundman.net/ftp/l4ip/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/([0-9]*)\.([0-9]*)\.([0-9]*)/v\1.\2.b\3/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= L4 and Health-Check project for IPFilter
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,service_type_t,script_type_t,g' ${WRKSRC}/service.c
+ ${REINPLACE_CMD} -e 's,/usr/sbin,/sbin,g' ${WRKSRC}/l4ip.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/l4ip ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/l4ip.conf ${PREFIX}/etc
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} ${WRKSRC}/../samples/*.conf ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net/l4ip/distinfo b/net/l4ip/distinfo
new file mode 100644
index 000000000000..d292f89268e2
--- /dev/null
+++ b/net/l4ip/distinfo
@@ -0,0 +1,3 @@
+MD5 (l4ip-v1.0.b294.tgz) = b5c56255e411cc41966e5af31b132506
+SHA256 (l4ip-v1.0.b294.tgz) = 5d2a0793cc75b0219f409a95a0448be08ef0a27881dc75e86917aaafe055baf5
+SIZE (l4ip-v1.0.b294.tgz) = 222162
diff --git a/net/l4ip/pkg-descr b/net/l4ip/pkg-descr
new file mode 100644
index 000000000000..5763656b6a0a
--- /dev/null
+++ b/net/l4ip/pkg-descr
@@ -0,0 +1,24 @@
+The idea is that IPFilter in its current state can already do a simple L4
+round-robin in its NAT rules. However, it does not detect or sense when a
+service and/or host is down. It will continue to send requests to a downed
+service/host.
+
+However, IPFilter lets us add and remove rules on-the-fly so it should be
+possible to build a daemon that lets you specify "clusters". In each cluster
+you would specify its members/hosts and services. As well as a health-check
+for the service to determine its current state.
+
+Once a service was deemed "up" we would add a Round-Robin rule to the NAT
+table, and naturally, the reverse once we detect a service as being "down".
+
+In addition to this, this program can optionally add ipf rules to log for RST
+(reset) packets coming from the members of your clusters. In the situations
+where the software/port goes down, but the host itself is still working, we
+would detect failure instantly. (Since the forwarded connections to the service
+would trigger a RST packet back). If this option is enabled, l4ip spawns the
+"ipmon" command to monitor for the "log" entries given when such a packet is
+detected. l4ip will then mark the service down. This is an add-on feature and
+is strictly not necessary for functional usage. It is currently only supported
+for TCP.
+
+WWW: http://www.lundman.net/unix/l4ip.php
diff --git a/net/l4ip/pkg-plist b/net/l4ip/pkg-plist
new file mode 100644
index 000000000000..4c140014c3b6
--- /dev/null
+++ b/net/l4ip/pkg-plist
@@ -0,0 +1,12 @@
+sbin/l4ip
+etc/l4ip.conf
+%%EXAMPLESDIR%%/apache1.conf
+%%EXAMPLESDIR%%/apache2.conf
+%%EXAMPLESDIR%%/dns1.conf
+%%EXAMPLESDIR%%/dns2.conf
+%%EXAMPLESDIR%%/ftp1.conf
+%%EXAMPLESDIR%%/ftp2.conf
+%%EXAMPLESDIR%%/ldap.conf
+%%EXAMPLESDIR%%/ldap1.conf
+%%EXAMPLESDIR%%/ldap2.conf
+@dirrm %%EXAMPLESDIR%%