aboutsummaryrefslogtreecommitdiff
path: root/net/ladvd/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-31 17:15:49 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-31 17:15:49 +0000
commit905117981ad2b3201881da4a0295f07026850d05 (patch)
treeb2fd37393ae4021da7b721d6e14da6180b2e63d2 /net/ladvd/Makefile
parent10f09c6138184be9d3ac0cffa10b65d571ac2295 (diff)
downloadports-905117981ad2b3201881da4a0295f07026850d05.tar.gz
ports-905117981ad2b3201881da4a0295f07026850d05.zip
Notes
Diffstat (limited to 'net/ladvd/Makefile')
-rw-r--r--net/ladvd/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/ladvd/Makefile b/net/ladvd/Makefile
index fd6adf5c1072..73a55684a82f 100644
--- a/net/ladvd/Makefile
+++ b/net/ladvd/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= ladvd
-PORTVERSION= 0.9.2
+PORTVERSION= 1.0.1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+MASTER_SITES= GOOGLE_CODE \
http://blinkenlights.nl/software/ladvd/
MAINTAINER= sten@blinkenlights.nl
COMMENT= A minimal LLDP/CDP daemon
+LICENSE= BSD
+
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
-LICENSE= BSD
+USERS= ladvd
+GROUPS= ${USERS}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-chroot-dir=/var/empty
@@ -24,7 +27,10 @@ CONFIGURE_ARGS= --with-chroot-dir=/var/empty
PORTDOCS= *
MAN8= ladvd.8 ladvdc.8
USE_RC_SUBR+= ladvd
-SUB_FILES= pkg-message pkg-install
+SUB_FILES= pkg-message
+
+PLIST_FILES= sbin/ladvd \
+ sbin/ladvdc
post-patch:
.if defined(NOPORTDOCS)
@@ -33,8 +39,6 @@ post-patch:
.endif
post-install:
- @${ECHO} "==> Creating custom user to run ladvd..."
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>