aboutsummaryrefslogtreecommitdiff
path: root/net/lam
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-08-21 20:50:50 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-08-21 20:50:50 +0000
commitd8b30d9b95d18dcf25baa9f0ef9e13dd8c40aee8 (patch)
treea87c9fbdf906eedd0e08050c9a00665b0c4052f1 /net/lam
parent2625c1ff197c2ef601e8bb44b47ec76c5b6830cd (diff)
downloadports-d8b30d9b95d18dcf25baa9f0ef9e13dd8c40aee8.tar.gz
ports-d8b30d9b95d18dcf25baa9f0ef9e13dd8c40aee8.zip
Notes
Diffstat (limited to 'net/lam')
-rw-r--r--net/lam/Makefile393
-rw-r--r--net/lam/distinfo6
-rw-r--r--net/lam/files/manpages339
-rw-r--r--net/lam/files/patch-man-mans-Makefile.in12
-rw-r--r--net/lam/files/patch-otb+lamcheckpoint+lamcheckpoint.c38
-rw-r--r--net/lam/files/patch-share+args+all_opt.c (renamed from net/lam/files/patch-share-args-all_opt.c)30
-rw-r--r--net/lam/pkg-descr6
-rw-r--r--net/lam/pkg-plist141
8 files changed, 541 insertions, 424 deletions
diff --git a/net/lam/Makefile b/net/lam/Makefile
index e33f48ee3531..407c44867873 100644
--- a/net/lam/Makefile
+++ b/net/lam/Makefile
@@ -6,22 +6,399 @@
#
PORTNAME= lam
-PORTVERSION= 6.5.9
+PORTVERSION= 7.1.2
CATEGORIES= net parallel
-MASTER_SITES= http://www.lam-mpi.org/download/files/
+MASTER_SITES= http://www.lam-mpi.org/download/files/ \
+ http://www.thinkingnerds.com/lam/download/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Local Area Multicomputer MPI implementation
USE_BZIP2= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-rsh=ssh
+CONFIGURE_ARGS= --with-rsh=ssh
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LDCONFIG= yes
-CONFLICTS= lam-7.*
+MAN1= hboot.1 \
+ hcc.1 \
+ hcp.1 \
+ hf77.1 \
+ introu.1 \
+ lamboot.1 \
+ lamcheckpoint.1 \
+ lamclean.1 \
+ lamd.1 \
+ lamexec.1 \
+ lamgrow.1 \
+ lamhalt.1 \
+ laminfo.1 \
+ lamnodes.1 \
+ lamrestart.1 \
+ lamshrink.1 \
+ lamtrace.1 \
+ lamwipe.1 \
+ mpiCC.1 \
+ mpic++.1 \
+ mpicc.1 \
+ mpiexec.1 \
+ mpif77.1 \
+ mpimsg.1 \
+ mpirun.1 \
+ mpitask.1 \
+ recon.1 \
+ tkill.1 \
+ tping.1 \
+ wipe.1
+MAN3= MPIL_Comm_gps.3 \
+ MPIL_Comm_id.3 \
+ MPIL_Request_get_name.3 \
+ MPIL_Request_set_name.3 \
+ MPIL_Signal.3 \
+ MPIL_Trace_off.3 \
+ MPIL_Trace_on.3 \
+ MPIL_Type_id.3 \
+ MPIO_Request_c2f.3 \
+ MPIO_Request_f2c.3 \
+ MPIO_Test.3 \
+ MPIO_Wait.3 \
+ MPI_Abort.3 \
+ MPI_Accumulate.3 \
+ MPI_Address.3 \
+ MPI_Allgather.3 \
+ MPI_Allgatherv.3 \
+ MPI_Alloc_mem.3 \
+ MPI_Allreduce.3 \
+ MPI_Alltoall.3 \
+ MPI_Alltoallv.3 \
+ MPI_Alltoallw.3 \
+ MPI_Attr_delete.3 \
+ MPI_Attr_get.3 \
+ MPI_Attr_put.3 \
+ MPI_Barrier.3 \
+ MPI_Bcast.3 \
+ MPI_Bsend.3 \
+ MPI_Bsend_init.3 \
+ MPI_Buffer_attach.3 \
+ MPI_Buffer_detach.3 \
+ MPI_COMM_DUP_FN.3 \
+ MPI_Cancel.3 \
+ MPI_Cart_coords.3 \
+ MPI_Cart_create.3 \
+ MPI_Cart_get.3 \
+ MPI_Cart_map.3 \
+ MPI_Cart_rank.3 \
+ MPI_Cart_shift.3 \
+ MPI_Cart_sub.3 \
+ MPI_Cartdim_get.3 \
+ MPI_Close_port.3 \
+ MPI_Comm_accept.3 \
+ MPI_Comm_c2f.3 \
+ MPI_Comm_compare.3 \
+ MPI_Comm_connect.3 \
+ MPI_Comm_create.3 \
+ MPI_Comm_create_errhandler.3 \
+ MPI_Comm_create_keyval.3 \
+ MPI_Comm_delete_attr.3 \
+ MPI_Comm_disconnect.3 \
+ MPI_Comm_dup.3 \
+ MPI_Comm_f2c.3 \
+ MPI_Comm_free.3 \
+ MPI_Comm_free_keyval.3 \
+ MPI_Comm_get_attr.3 \
+ MPI_Comm_get_errhandler.3 \
+ MPI_Comm_get_name.3 \
+ MPI_Comm_get_parent.3 \
+ MPI_Comm_group.3 \
+ MPI_Comm_join.3 \
+ MPI_Comm_rank.3 \
+ MPI_Comm_remote_group.3 \
+ MPI_Comm_remote_size.3 \
+ MPI_Comm_ser_errhandler.3 \
+ MPI_Comm_set_attr.3 \
+ MPI_Comm_set_name.3 \
+ MPI_Comm_size.3 \
+ MPI_Comm_spawn.3 \
+ MPI_Comm_spawn_multiple.3 \
+ MPI_Comm_split.3 \
+ MPI_Comm_test_inter.3 \
+ MPI_DUP_FN.3 \
+ MPI_Dims_create.3 \
+ MPI_Errhandler_c2f.3 \
+ MPI_Errhandler_create.3 \
+ MPI_Errhandler_f2c.3 \
+ MPI_Errhandler_free.3 \
+ MPI_Errhandler_get.3 \
+ MPI_Errhandler_set.3 \
+ MPI_Error_class.3 \
+ MPI_Error_string.3 \
+ MPI_Exscan.3 \
+ MPI_File_c2f.3 \
+ MPI_File_close.3 \
+ MPI_File_delete.3 \
+ MPI_File_f2c.3 \
+ MPI_File_get_amode.3 \
+ MPI_File_get_atomicity.3 \
+ MPI_File_get_byte_offset.3 \
+ MPI_File_get_errhandler.3 \
+ MPI_File_get_group.3 \
+ MPI_File_get_info.3 \
+ MPI_File_get_position.3 \
+ MPI_File_get_position_shared.3 \
+ MPI_File_get_size.3 \
+ MPI_File_get_type_extent.3 \
+ MPI_File_get_view.3 \
+ MPI_File_iread.3 \
+ MPI_File_iread_at.3 \
+ MPI_File_iread_shared.3 \
+ MPI_File_iwrite.3 \
+ MPI_File_iwrite_at.3 \
+ MPI_File_iwrite_shared.3 \
+ MPI_File_open.3 \
+ MPI_File_preallocate.3 \
+ MPI_File_read.3 \
+ MPI_File_read_all.3 \
+ MPI_File_read_all_begin.3 \
+ MPI_File_read_all_end.3 \
+ MPI_File_read_at.3 \
+ MPI_File_read_at_all.3 \
+ MPI_File_read_at_all_begin.3 \
+ MPI_File_read_at_all_end.3 \
+ MPI_File_read_ordered.3 \
+ MPI_File_read_ordered_begin.3 \
+ MPI_File_read_ordered_end.3 \
+ MPI_File_read_shared.3 \
+ MPI_File_seek.3 \
+ MPI_File_seek_shared.3 \
+ MPI_File_set_atomicity.3 \
+ MPI_File_set_errhandler.3 \
+ MPI_File_set_info.3 \
+ MPI_File_set_size.3 \
+ MPI_File_set_view.3 \
+ MPI_File_sync.3 \
+ MPI_File_write.3 \
+ MPI_File_write_all.3 \
+ MPI_File_write_all_begin.3 \
+ MPI_File_write_all_end.3 \
+ MPI_File_write_at.3 \
+ MPI_File_write_at_all.3 \
+ MPI_File_write_at_all_begin.3 \
+ MPI_File_write_at_all_end.3 \
+ MPI_File_write_ordered.3 \
+ MPI_File_write_ordered_begin.3 \
+ MPI_File_write_ordered_end.3 \
+ MPI_File_write_shared.3 \
+ MPI_Finalize.3 \
+ MPI_Finalized.3 \
+ MPI_Free_mem.3 \
+ MPI_Gather.3 \
+ MPI_Gatherv.3 \
+ MPI_Get.3 \
+ MPI_Get_address.3 \
+ MPI_Get_count.3 \
+ MPI_Get_elements.3 \
+ MPI_Get_processor_name.3 \
+ MPI_Get_version.3 \
+ MPI_Graph_create.3 \
+ MPI_Graph_get.3 \
+ MPI_Graph_map.3 \
+ MPI_Graph_neighbors.3 \
+ MPI_Graph_neighbors_count.3 \
+ MPI_Graphdims_get.3 \
+ MPI_Group_c2f.3 \
+ MPI_Group_compare.3 \
+ MPI_Group_difference.3 \
+ MPI_Group_excl.3 \
+ MPI_Group_f2c.3 \
+ MPI_Group_free.3 \
+ MPI_Group_incl.3 \
+ MPI_Group_intersection.3 \
+ MPI_Group_range_excl.3 \
+ MPI_Group_range_incl.3 \
+ MPI_Group_rank.3 \
+ MPI_Group_size.3 \
+ MPI_Group_translate_ranks.3 \
+ MPI_Group_union.3 \
+ MPI_Ibsend.3 \
+ MPI_Info_c2f.3 \
+ MPI_Info_create.3 \
+ MPI_Info_delete.3 \
+ MPI_Info_dup.3 \
+ MPI_Info_f2c.3 \
+ MPI_Info_free.3 \
+ MPI_Info_get.3 \
+ MPI_Info_get_nkeys.3 \
+ MPI_Info_get_nthkey.3 \
+ MPI_Info_get_valuelen.3 \
+ MPI_Info_set.3 \
+ MPI_Init.3 \
+ MPI_Init_thread.3 \
+ MPI_Initialized.3 \
+ MPI_Intercomm_create.3 \
+ MPI_Intercomm_merge.3 \
+ MPI_Iprobe.3 \
+ MPI_Irecv.3 \
+ MPI_Irsend.3 \
+ MPI_Is_thread_main.3 \
+ MPI_Isend.3 \
+ MPI_Issend.3 \
+ MPI_Keyval_create.3 \
+ MPI_Keyval_free.3 \
+ MPI_Lookup_name.3 \
+ MPI_Op_c2f.3 \
+ MPI_Op_create.3 \
+ MPI_Op_f2c.3 \
+ MPI_Op_free.3 \
+ MPI_Open_port.3 \
+ MPI_Pack.3 \
+ MPI_Pack_size.3 \
+ MPI_Pcontrol.3 \
+ MPI_Probe.3 \
+ MPI_Publish_name.3 \
+ MPI_Put.3 \
+ MPI_Query_thread.3 \
+ MPI_Recv.3 \
+ MPI_Recv_init.3 \
+ MPI_Reduce.3 \
+ MPI_Reduce_scatter.3 \
+ MPI_Request_c2f.3 \
+ MPI_Request_f2c.3 \
+ MPI_Request_free.3 \
+ MPI_Rsend.3 \
+ MPI_Rsend_init.3 \
+ MPI_Scan.3 \
+ MPI_Scatter.3 \
+ MPI_Scatterv.3 \
+ MPI_Send.3 \
+ MPI_Send_init.3 \
+ MPI_Sendrecv.3 \
+ MPI_Sendrecv_replace.3 \
+ MPI_Ssend.3 \
+ MPI_Ssend_init.3 \
+ MPI_Start.3 \
+ MPI_Startall.3 \
+ MPI_Status_c2f.3 \
+ MPI_Status_f2c.3 \
+ MPI_TYPE_DUP_FN.3 \
+ MPI_Test.3 \
+ MPI_Test_cancelled.3 \
+ MPI_Testall.3 \
+ MPI_Testany.3 \
+ MPI_Testsome.3 \
+ MPI_Topo_test.3 \
+ MPI_Type_c2f.3 \
+ MPI_Type_commit.3 \
+ MPI_Type_contiguous.3 \
+ MPI_Type_create_darray.3 \
+ MPI_Type_create_extent.3 \
+ MPI_Type_create_hindexed.3 \
+ MPI_Type_create_hvector.3 \
+ MPI_Type_create_keyval.3 \
+ MPI_Type_create_struct.3 \
+ MPI_Type_create_subarray.3 \
+ MPI_Type_delete_attr.3 \
+ MPI_Type_dup.3 \
+ MPI_Type_extent.3 \
+ MPI_Type_f2c.3 \
+ MPI_Type_free.3 \
+ MPI_Type_free_keyval.3 \
+ MPI_Type_get_attr.3 \
+ MPI_Type_get_contents.3 \
+ MPI_Type_get_envelope.3 \
+ MPI_Type_get_extent.3 \
+ MPI_Type_get_name.3 \
+ MPI_Type_get_true_extent.3 \
+ MPI_Type_hindexed.3 \
+ MPI_Type_hvector.3 \
+ MPI_Type_indexed.3 \
+ MPI_Type_lb.3 \
+ MPI_Type_set_attr.3 \
+ MPI_Type_set_name.3 \
+ MPI_Type_size.3 \
+ MPI_Type_struct.3 \
+ MPI_Type_ub.3 \
+ MPI_Type_vector.3 \
+ MPI_Unpack.3 \
+ MPI_WIN_DUP_FN.3 \
+ MPI_Wait.3 \
+ MPI_Waitall.3 \
+ MPI_Waitany.3 \
+ MPI_Waitsome.3 \
+ MPI_Win_Lock.3 \
+ MPI_Win_Test.3 \
+ MPI_Win_c2f.3 \
+ MPI_Win_call_errhandler.3 \
+ MPI_Win_complete.3 \
+ MPI_Win_create.3 \
+ MPI_Win_create_errhandler.3 \
+ MPI_Win_create_keyval.3 \
+ MPI_Win_delete_attr.3 \
+ MPI_Win_f2c.3 \
+ MPI_Win_fence.3 \
+ MPI_Win_free.3 \
+ MPI_Win_free_keyval.3 \
+ MPI_Win_get_attr.3 \
+ MPI_Win_get_errhandler.3 \
+ MPI_Win_get_group.3 \
+ MPI_Win_get_name.3 \
+ MPI_Win_post.3 \
+ MPI_Win_set_attr.3 \
+ MPI_Win_set_errhandler.3 \
+ MPI_Win_set_name.3 \
+ MPI_Win_start.3 \
+ MPI_Win_unlock.3 \
+ MPI_Win_wait.3 \
+ MPI_Wtick.3 \
+ MPI_Wtime.3 \
+ XMPI_Buoy.3 \
+ XMPI_Coloroff.3 \
+ XMPI_Coloron.3
+MAN5= CONSTANTS.5 \
+ appschema.5 \
+ bhost.5 \
+ conf.5 \
+ lam-helpfile.5 \
+ procschema.5
+MAN7= LAM.7 \
+ MPI.7 \
+ lam.7 \
+ lamssi.7 \
+ lamssi_boot.7 \
+ lamssi_coll.7 \
+ lamssi_cr.7 \
+ lamssi_rpi.7 \
+ libmpi.7 \
+ mpi.7
-DEPRECATED= to be replaced by net/lam7, please use this port instead
-EXPIRATION_DATE=2006-08-18
+.include <bsd.port.pre.mk>
-.include "files/manpages"
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
-.include <bsd.port.mk>
+.if ${ARCH} == "i386"
+PLIST_SUB= I386=""
+.else
+# Note: to enable TotalView on 64 bits platforms,
+# --enable-tv-dll-force should be added to CONFIGURE_ARGS
+PLIST_SUB= I386="@comment "
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -E -e 's|/usr/bin/env perl|${PERL} -w| ; \
+ s|use warnings;||' ${WRKSRC}/tools/mpiexec/mpiexec
+
+post-install:
+.if ${ARCH} != "i386"
+ ${RMDIR} ${PREFIX}/lib/lam
+.endif
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ (cd ${BUILD_WRKSRC}/examples; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/lam/distinfo b/net/lam/distinfo
index c73366429504..f852041f2133 100644
--- a/net/lam/distinfo
+++ b/net/lam/distinfo
@@ -1,3 +1,3 @@
-MD5 (lam-6.5.9.tar.bz2) = 8a4e98da5e1ba41e68c9422635b42364
-SHA256 (lam-6.5.9.tar.bz2) = 988f62d4af572e6f52042dad46e17da35b01814f9dd23d17b39dd4b2b58336f5
-SIZE (lam-6.5.9.tar.bz2) = 1642559
+MD5 (lam-7.1.2.tar.bz2) = 07c59cf03c773a67199e066e500e499b
+SHA256 (lam-7.1.2.tar.bz2) = b3826e79f1a674ed275d2a0e32895aefe63d4278126bd5fa01dbe43cc1c1960b
+SIZE (lam-7.1.2.tar.bz2) = 7851483
diff --git a/net/lam/files/manpages b/net/lam/files/manpages
deleted file mode 100644
index d15c9ae26cb6..000000000000
--- a/net/lam/files/manpages
+++ /dev/null
@@ -1,339 +0,0 @@
-MAN1= \
-hboot.1 \
-hcc.1 \
-hcp.1 \
-hf77.1 \
-introu.1 \
-lamboot.1 \
-lamclean.1 \
-lamd.1 \
-lamexec.1 \
-lamgrow.1 \
-lamshrink.1 \
-lamtrace.1 \
-mpiCC.1 \
-mpic++.1 \
-mpicc.1 \
-mpif77.1 \
-mpimsg.1 \
-mpirun.1 \
-mpitask.1 \
-recon.1 \
-tkill.1 \
-tping.1 \
-wipe.1
-
-MAN3= \
-MPIL_Comm_gps.3 \
-MPIL_Comm_id.3 \
-MPIL_Comm_parent.3 \
-MPIL_Signal.3 \
-MPIL_Spawn.3 \
-MPIL_Trace_off.3 \
-MPIL_Trace_on.3 \
-MPIL_Type_id.3 \
-MPIL_Universe_size.3 \
-MPIO_Request_c2f.3 \
-MPIO_Request_f2c.3 \
-MPIO_Test.3 \
-MPIO_Wait.3 \
-MPI_Abort.3 \
-MPI_Accumulate.3 \
-MPI_Address.3 \
-MPI_Allgather.3 \
-MPI_Allgatherv.3 \
-MPI_Alloc_mem.3 \
-MPI_Allreduce.3 \
-MPI_Alltoall.3 \
-MPI_Alltoallv.3 \
-MPI_Attr_delete.3 \
-MPI_Attr_get.3 \
-MPI_Attr_put.3 \
-MPI_Barrier.3 \
-MPI_Bcast.3 \
-MPI_Bsend.3 \
-MPI_Bsend_init.3 \
-MPI_Buffer_attach.3 \
-MPI_Buffer_detach.3 \
-MPI_COMM_DUP_FN.3 \
-MPI_Cancel.3 \
-MPI_Cart_coords.3 \
-MPI_Cart_create.3 \
-MPI_Cart_get.3 \
-MPI_Cart_map.3 \
-MPI_Cart_rank.3 \
-MPI_Cart_shift.3 \
-MPI_Cart_sub.3 \
-MPI_Cartdim_get.3 \
-MPI_Close_port.3 \
-MPI_Comm_accept.3 \
-MPI_Comm_c2f.3 \
-MPI_Comm_compare.3 \
-MPI_Comm_connect.3 \
-MPI_Comm_create.3 \
-MPI_Comm_create_errhandler.3 \
-MPI_Comm_create_keyval.3 \
-MPI_Comm_delete_attr.3 \
-MPI_Comm_disconnect.3 \
-MPI_Comm_dup.3 \
-MPI_Comm_f2c.3 \
-MPI_Comm_free.3 \
-MPI_Comm_free_keyval.3 \
-MPI_Comm_get_attr.3 \
-MPI_Comm_get_errhandler.3 \
-MPI_Comm_get_name.3 \
-MPI_Comm_get_parent.3 \
-MPI_Comm_group.3 \
-MPI_Comm_join.3 \
-MPI_Comm_rank.3 \
-MPI_Comm_remote_group.3 \
-MPI_Comm_remote_size.3 \
-MPI_Comm_ser_errhandler.3 \
-MPI_Comm_set_attr.3 \
-MPI_Comm_set_name.3 \
-MPI_Comm_size.3 \
-MPI_Comm_spawn.3 \
-MPI_Comm_spawn_multiple.3 \
-MPI_Comm_split.3 \
-MPI_Comm_test_inter.3 \
-MPI_DUP_FN.3 \
-MPI_Dims_create.3 \
-MPI_Errhandler_c2f.3 \
-MPI_Errhandler_create.3 \
-MPI_Errhandler_f2c.3 \
-MPI_Errhandler_free.3 \
-MPI_Errhandler_get.3 \
-MPI_Errhandler_set.3 \
-MPI_Error_class.3 \
-MPI_Error_string.3 \
-MPI_File_c2f.3 \
-MPI_File_close.3 \
-MPI_File_delete.3 \
-MPI_File_f2c.3 \
-MPI_File_get_amode.3 \
-MPI_File_get_atomicity.3 \
-MPI_File_get_byte_offset.3 \
-MPI_File_get_errhandler.3 \
-MPI_File_get_group.3 \
-MPI_File_get_info.3 \
-MPI_File_get_position.3 \
-MPI_File_get_position_shared.3 \
-MPI_File_get_size.3 \
-MPI_File_get_type_extent.3 \
-MPI_File_get_view.3 \
-MPI_File_iread.3 \
-MPI_File_iread_at.3 \
-MPI_File_iread_shared.3 \
-MPI_File_iwrite.3 \
-MPI_File_iwrite_at.3 \
-MPI_File_iwrite_shared.3 \
-MPI_File_open.3 \
-MPI_File_preallocate.3 \
-MPI_File_read.3 \
-MPI_File_read_all.3 \
-MPI_File_read_all_begin.3 \
-MPI_File_read_all_end.3 \
-MPI_File_read_at.3 \
-MPI_File_read_at_all.3 \
-MPI_File_read_at_all_begin.3 \
-MPI_File_read_at_all_end.3 \
-MPI_File_read_ordered.3 \
-MPI_File_read_ordered_begin.3 \
-MPI_File_read_ordered_end.3 \
-MPI_File_read_shared.3 \
-MPI_File_seek.3 \
-MPI_File_seek_shared.3 \
-MPI_File_set_atomicity.3 \
-MPI_File_set_errhandler.3 \
-MPI_File_set_info.3 \
-MPI_File_set_size.3 \
-MPI_File_set_view.3 \
-MPI_File_sync.3 \
-MPI_File_write.3 \
-MPI_File_write_all.3 \
-MPI_File_write_all_begin.3 \
-MPI_File_write_all_end.3 \
-MPI_File_write_at.3 \
-MPI_File_write_at_all.3 \
-MPI_File_write_at_all_begin.3 \
-MPI_File_write_at_all_end.3 \
-MPI_File_write_ordered.3 \
-MPI_File_write_ordered_begin.3 \
-MPI_File_write_ordered_end.3 \
-MPI_File_write_shared.3 \
-MPI_Finalize.3 \
-MPI_Finalized.3 \
-MPI_Free_mem.3 \
-MPI_Gather.3 \
-MPI_Gatherv.3 \
-MPI_Get.3 \
-MPI_Get_address.3 \
-MPI_Get_count.3 \
-MPI_Get_elements.3 \
-MPI_Get_processor_name.3 \
-MPI_Get_version.3 \
-MPI_Graph_create.3 \
-MPI_Graph_get.3 \
-MPI_Graph_map.3 \
-MPI_Graph_neighbors.3 \
-MPI_Graph_neighbors_count.3 \
-MPI_Graphdims_get.3 \
-MPI_Group_c2f.3 \
-MPI_Group_compare.3 \
-MPI_Group_difference.3 \
-MPI_Group_excl.3 \
-MPI_Group_f2c.3 \
-MPI_Group_free.3 \
-MPI_Group_incl.3 \
-MPI_Group_intersection.3 \
-MPI_Group_range_excl.3 \
-MPI_Group_range_incl.3 \
-MPI_Group_rank.3 \
-MPI_Group_size.3 \
-MPI_Group_translate_ranks.3 \
-MPI_Group_union.3 \
-MPI_Ibsend.3 \
-MPI_Info_c2f.3 \
-MPI_Info_create.3 \
-MPI_Info_delete.3 \
-MPI_Info_dup.3 \
-MPI_Info_f2c.3 \
-MPI_Info_free.3 \
-MPI_Info_get.3 \
-MPI_Info_get_nkeys.3 \
-MPI_Info_get_nthkey.3 \
-MPI_Info_get_valuelen.3 \
-MPI_Info_set.3 \
-MPI_Init.3 \
-MPI_Init_thread.3 \
-MPI_Initialized.3 \
-MPI_Intercomm_create.3 \
-MPI_Intercomm_merge.3 \
-MPI_Iprobe.3 \
-MPI_Irecv.3 \
-MPI_Irsend.3 \
-MPI_Is_thread_main.3 \
-MPI_Isend.3 \
-MPI_Issend.3 \
-MPI_Keyval_create.3 \
-MPI_Keyval_free.3 \
-MPI_Lookup_name.3 \
-MPI_Op_c2f.3 \
-MPI_Op_create.3 \
-MPI_Op_f2c.3 \
-MPI_Op_free.3 \
-MPI_Open_port.3 \
-MPI_Pack.3 \
-MPI_Pack_size.3 \
-MPI_Pcontrol.3 \
-MPI_Probe.3 \
-MPI_Publish_name.3 \
-MPI_Put.3 \
-MPI_Query_thread.3 \
-MPI_Recv.3 \
-MPI_Recv_init.3 \
-MPI_Reduce.3 \
-MPI_Reduce_scatter.3 \
-MPI_Request_c2f.3 \
-MPI_Request_f2c.3 \
-MPI_Request_free.3 \
-MPI_Rsend.3 \
-MPI_Rsend_init.3 \
-MPI_Scan.3 \
-MPI_Scatter.3 \
-MPI_Scatterv.3 \
-MPI_Send.3 \
-MPI_Send_init.3 \
-MPI_Sendrecv.3 \
-MPI_Sendrecv_replace.3 \
-MPI_Ssend.3 \
-MPI_Ssend_init.3 \
-MPI_Start.3 \
-MPI_Startall.3 \
-MPI_Status_c2f.3 \
-MPI_Status_f2c.3 \
-MPI_TYPE_DUP_FN.3 \
-MPI_Test.3 \
-MPI_Test_cancelled.3 \
-MPI_Testall.3 \
-MPI_Testany.3 \
-MPI_Testsome.3 \
-MPI_Topo_test.3 \
-MPI_Type_c2f.3 \
-MPI_Type_commit.3 \
-MPI_Type_contiguous.3 \
-MPI_Type_create_darray.3 \
-MPI_Type_create_extent.3 \
-MPI_Type_create_hindexed.3 \
-MPI_Type_create_hvector.3 \
-MPI_Type_create_keyval.3 \
-MPI_Type_create_struct.3 \
-MPI_Type_create_subarray.3 \
-MPI_Type_delete_attr.3 \
-MPI_Type_dup.3 \
-MPI_Type_extent.3 \
-MPI_Type_f2c.3 \
-MPI_Type_free.3 \
-MPI_Type_free_keyval.3 \
-MPI_Type_get_attr.3 \
-MPI_Type_get_contents.3 \
-MPI_Type_get_envelope.3 \
-MPI_Type_get_extent.3 \
-MPI_Type_get_name.3 \
-MPI_Type_get_true_extent.3 \
-MPI_Type_hindexed.3 \
-MPI_Type_hvector.3 \
-MPI_Type_indexed.3 \
-MPI_Type_lb.3 \
-MPI_Type_set_attr.3 \
-MPI_Type_set_name.3 \
-MPI_Type_size.3 \
-MPI_Type_struct.3 \
-MPI_Type_ub.3 \
-MPI_Type_vector.3 \
-MPI_Unpack.3 \
-MPI_WIN_DUP_FN.3 \
-MPI_Wait.3 \
-MPI_Waitall.3 \
-MPI_Waitany.3 \
-MPI_Waitsome.3 \
-MPI_Win_c2f.3 \
-MPI_Win_complete.3 \
-MPI_Win_create.3 \
-MPI_Win_create_errhandler.3 \
-MPI_Win_create_keyval.3 \
-MPI_Win_delete_attr.3 \
-MPI_Win_f2c.3 \
-MPI_Win_fence.3 \
-MPI_Win_free.3 \
-MPI_Win_free_keyval.3 \
-MPI_Win_get_attr.3 \
-MPI_Win_get_errhandler.3 \
-MPI_Win_get_group.3 \
-MPI_Win_get_name.3 \
-MPI_Win_post.3 \
-MPI_Win_set_attr.3 \
-MPI_Win_set_errhandler.3 \
-MPI_Win_set_name.3 \
-MPI_Win_start.3 \
-MPI_Win_wait.3 \
-MPI_Wtick.3 \
-MPI_Wtime.3 \
-XMPI_Buoy.3 \
-XMPI_Coloroff.3 \
-XMPI_Coloron.3 \
-libmpi.3
-
-MAN5= \
-CONSTANTS.5 \
-appschema.5 \
-bhost.5 \
-conf.5 \
-lam-helpfile.5 \
-procschema.5
-
-MAN7= \
-LAM.7 \
-MPI.7 \
-lam.7 \
-mpi.7
diff --git a/net/lam/files/patch-man-mans-Makefile.in b/net/lam/files/patch-man-mans-Makefile.in
index 9202a2aed5e8..de6a111db378 100644
--- a/net/lam/files/patch-man-mans-Makefile.in
+++ b/net/lam/files/patch-man-mans-Makefile.in
@@ -1,7 +1,11 @@
---- man/mans/Makefile.in Mon Jan 27 17:03:38 2003
-+++ man/mans/Makefile.in Wed Jun 18 12:18:05 2003
-@@ -193,3 +193,3 @@
-
+--- man/mans/Makefile.in.orig Fri Mar 10 22:31:27 2006
++++ man/mans/Makefile.in Sun Jul 16 16:43:58 2006
+@@ -134,7 +134,7 @@
+ CONFIG_CLEAN_FILES =
+ SOURCES =
+ DIST_SOURCES =
-mansdir = $(mandir)/mans
+mansdir = $(datadir)/lam
+ am__installdirs = "$(DESTDIR)$(mansdir)"
+ NROFF = nroff
MANS = $(man_MANS)
diff --git a/net/lam/files/patch-otb+lamcheckpoint+lamcheckpoint.c b/net/lam/files/patch-otb+lamcheckpoint+lamcheckpoint.c
new file mode 100644
index 000000000000..b2baecbc7045
--- /dev/null
+++ b/net/lam/files/patch-otb+lamcheckpoint+lamcheckpoint.c
@@ -0,0 +1,38 @@
+--- ./otb/lamcheckpoint/lamcheckpoint.c.orig Fri Feb 24 00:26:54 2006
++++ ./otb/lamcheckpoint/lamcheckpoint.c Sun Jul 16 12:31:41 2006
+@@ -36,7 +36,7 @@
+ OPT *ad;
+ int param_crlam;
+
+-static int strtonum(const char *, pid_t *);
++static int istrtonum(const char *, pid_t *);
+
+ /*
+ * main
+@@ -80,7 +80,7 @@
+
+ pid_arg = ao_param(ad, "pid", 0, 0);
+
+- if (strtonum(pid_arg, &pid) != 0) {
++ if (istrtonum(pid_arg, &pid) != 0) {
+ show_help("lamcheckpoint", "usage", NULL);
+ lam_ssi_base_close();
+ ao_free(ad);
+@@ -125,7 +125,7 @@
+
+
+ /*
+- * strtonum
++ * istrtonum
+ *
+ * Function: - convert string to number if possible
+ * - handles decimal/octal/hexadecimal
+@@ -135,7 +135,7 @@
+ * Returns: - 0 or LAMERROR
+ */
+ static int
+-strtonum(const char *str, pid_t *pnum)
++istrtonum(const char *str, pid_t *pnum)
+ {
+ char *endstr; /* end of parsed string */
+
diff --git a/net/lam/files/patch-share-args-all_opt.c b/net/lam/files/patch-share+args+all_opt.c
index ccf7d879a7a7..4c249dae4db9 100644
--- a/net/lam/files/patch-share-args-all_opt.c
+++ b/net/lam/files/patch-share+args+all_opt.c
@@ -1,6 +1,6 @@
---- share/args/all_opt.c.orig Wed May 17 17:31:19 2006
-+++ share/args/all_opt.c Wed May 17 17:43:55 2006
-@@ -21,6 +21,7 @@
+--- share/args/all_opt.c.orig Sun Sep 26 17:35:02 2004
++++ share/args/all_opt.c Sun Jul 16 12:07:07 2006
+@@ -19,6 +19,7 @@
*/
#include <stdlib.h>
@@ -8,16 +8,16 @@
#include <string.h>
#include <all_opt.h>
-@@ -34,7 +35,7 @@
+@@ -33,7 +34,7 @@
static int addinst(struct ao_opt *opt, int nparam, char **params);
static int countparam(OPT *aod, struct ao_opt *opt, char **argv);
static int mutexchk(struct ao_opt *opt);
--static int strtonum(char *str, int *pnum);
-+static int istrtonum(char *str, int *pnum);
- static struct ao_opt *findopt(OPT *desc, char *optstr);
+-static int strtonum(const char *str, int *pnum);
++static int istrtonum(const char *str, int *pnum);
+ static struct ao_opt *findopt(OPT *desc, const char *optstr);
-@@ -481,7 +482,7 @@
+@@ -652,7 +653,7 @@
/*
* If a number, assume '#' option.
*/
@@ -26,8 +26,8 @@
popt = findopt(aod, "#");
if ((popt == 0) || (mutexchk(popt))) {
-@@ -650,7 +651,7 @@
- }
+@@ -884,7 +885,7 @@
+
/*
- * strtonum
@@ -35,16 +35,16 @@
*
* Function: - convert string to number if possible
* - handles decimal/octal/hexadecimal
-@@ -660,7 +661,7 @@
+@@ -894,7 +895,7 @@
* Returns: - 0 or LAMERROR
*/
static int
--strtonum(char *str, int *pnum)
-+istrtonum(char *str, int *pnum)
+-strtonum(const char *str, int *pnum)
++istrtonum(const char *str, int *pnum)
{
char *endstr; /* end of parsed string */
-@@ -720,7 +721,7 @@
+@@ -956,7 +957,7 @@
if (strcmp(string, "--") == 0) break;
@@ -53,7 +53,7 @@
(findopt(aod, "#") != 0)) break;
if (findopt(aod, string + 1)) break;
-@@ -799,7 +800,7 @@
+@@ -1036,7 +1037,7 @@
for (; nparam > 0; --nparam, ++params, parmbuf += size) {
if (fl_int) {
diff --git a/net/lam/pkg-descr b/net/lam/pkg-descr
index fe1d0e1b5ab3..978b1611399d 100644
--- a/net/lam/pkg-descr
+++ b/net/lam/pkg-descr
@@ -1,10 +1,14 @@
LAM (Local Area Multicomputer) is an MPI programming environment and
development system for heterogeneous computers on a network. With LAM,
a dedicated cluster or an existing network computing infrastructure can act
-as one parallel computer solving one problem.
+as one parallel computer solving one problem.
LAM features extensive debugging support in the application development cycle
and peak performance for production applications. LAM features a full
implementation of the MPI communication standard.
+Note: LAM/MPI is now in a maintenance mode. This is a direct result of the
+LAM/MPI Team spending the vast majority of their time working on the
+next-generation MPI implementation -- Open MPI, i.e. the port net/openmpi.
+
WWW: http://www.lam-mpi.org/
diff --git a/net/lam/pkg-plist b/net/lam/pkg-plist
index 786858fbdbcf..7d84f0cba06b 100644
--- a/net/lam/pkg-plist
+++ b/net/lam/pkg-plist
@@ -1,82 +1,115 @@
+bin/hboot
+bin/hcc
+bin/hcp
+bin/hf77
+bin/lamboot
+bin/lamcheckpoint
bin/lamclean
+bin/lamd
bin/lamexec
bin/lamgrow
+bin/lamhalt
+bin/laminfo
+bin/lamnodes
+bin/lamrestart
bin/lamshrink
bin/lamtrace
+bin/lamwipe
+bin/mpiCC
+bin/mpic++
+bin/mpicc
+bin/mpiexec
+bin/mpif77
bin/mpimsg
bin/mpirun
bin/mpitask
-bin/lamd
-bin/tping
-bin/hboot
-bin/hcc
-bin/hcp
-bin/mpicc
-bin/mpic++
-bin/mpiCC
-bin/hf77
-bin/mpif77
-bin/lamboot
-bin/lamhalt
-bin/lamnodes
bin/recon
bin/tkill
+bin/tping
bin/wipe
-bin/balky
etc/lam-bhost.def
-etc/lam-bhost.lam
-etc/lam-conf.lam
-etc/lam-conf.otb
+etc/lam-conf.lamd
etc/lam-helpfile
+etc/lam-hostmap.txt
+etc/lam-ssi-boot-globus-helpfile
+etc/lam-ssi-boot-slurm-helpfile
+etc/lam-ssi-crmpi-self-helpfile
include/lam_config.h
+include/lam_config_bottom.h
include/mpi.h
+include/mpi2cxx/comm.h
+include/mpi2cxx/comm_inln.h
+include/mpi2cxx/constants.h
+include/mpi2cxx/datatype.h
+include/mpi2cxx/datatype_inln.h
+include/mpi2cxx/errhandler.h
+include/mpi2cxx/errhandler_inln.h
+include/mpi2cxx/exception.h
+include/mpi2cxx/functions.h
+include/mpi2cxx/functions_inln.h
+include/mpi2cxx/group.h
+include/mpi2cxx/group_inln.h
+include/mpi2cxx/info.h
+include/mpi2cxx/info_inln.h
+include/mpi2cxx/intercomm.h
+include/mpi2cxx/intercomm_inln.h
+include/mpi2cxx/intracomm.h
+include/mpi2cxx/intracomm_inln.h
+include/mpi2cxx/mpi2cxx_list.h
+include/mpi2cxx/mpi2cxx_map.h
+include/mpi2cxx/op.h
+include/mpi2cxx/op_inln.h
+include/mpi2cxx/pcomm.h
+include/mpi2cxx/pdatatype.h
+include/mpi2cxx/perrhandler.h
+include/mpi2cxx/pexception.h
+include/mpi2cxx/pgroup.h
+include/mpi2cxx/pgroup_inln.h
+include/mpi2cxx/pinfo.h
+include/mpi2cxx/pintercomm.h
+include/mpi2cxx/pintracomm.h
+include/mpi2cxx/pmpicxx.h
+include/mpi2cxx/pop.h
+include/mpi2cxx/pop_inln.h
+include/mpi2cxx/prequest.h
+include/mpi2cxx/prequest_inln.h
+include/mpi2cxx/pstatus.h
+include/mpi2cxx/pstatus_inln.h
+include/mpi2cxx/ptopology.h
+include/mpi2cxx/pwin.h
+include/mpi2cxx/request.h
+include/mpi2cxx/request_inln.h
+include/mpi2cxx/status.h
+include/mpi2cxx/status_inln.h
+include/mpi2cxx/topology.h
+include/mpi2cxx/topology_inln.h
+include/mpi2cxx/win.h
+include/mpi2cxx/win_inln.h
+include/mpicxx.h
include/mpif.h
-include/mpi2c++/mpi2c++_config.h
-include/mpi2c++/mpi++.h
-include/mpi2c++/mpi2c++_map.h
-include/mpi2c++/mpi2c++_list.h
-include/mpi2c++/constants.h
-include/mpi2c++/functions.h
-include/mpi2c++/datatype.h
-include/mpi2c++/exception.h
-include/mpi2c++/op.h
-include/mpi2c++/status.h
-include/mpi2c++/request.h
-include/mpi2c++/group.h
-include/mpi2c++/comm.h
-include/mpi2c++/errhandler.h
-include/mpi2c++/intracomm.h
-include/mpi2c++/topology.h
-include/mpi2c++/intercomm.h
-include/mpi2c++/datatype_inln.h
-include/mpi2c++/functions_inln.h
-include/mpi2c++/request_inln.h
-include/mpi2c++/comm_inln.h
-include/mpi2c++/intracomm_inln.h
-include/mpi2c++/op_inln.h
-include/mpi2c++/topology_inln.h
-include/mpi2c++/intercomm_inln.h
-include/mpi2c++/group_inln.h
-include/mpi2c++/errhandler_inln.h
-include/mpi2c++/status_inln.h
-include/mpi++.h
include/mpio.h
include/mpiof.h
-lib/liblamf77mpi.la
-lib/liblamf77mpi.a
-lib/libpmpi.la
-lib/libpmpi.a
-lib/liblam.la
+%%I386%%lib/lam/liblam_totalview.la
+%%I386%%lib/lam/liblam_totalview.so
+%%I386%%lib/lam/liblam_totalview.so.0
lib/liblam.a
-lib/libmpi.la
-lib/libmpi.a
+lib/liblam.la
+lib/liblamf77mpi.a
+lib/liblamf77mpi.la
lib/liblammpi++.a
+lib/liblammpi++.la
lib/liblammpio.a
+lib/libmpi.a
+lib/libmpi.la
+%%DATADIR%%/doc/APPLE_LICENSE
%%DATADIR%%/doc/ROMIO-COPYRIGHT
%%DATADIR%%/doc/ROMIO-README
%%DATADIR%%/doc/ROMIO-README_LAM
+%%DATADIR%%/doc/ptmalloc-COPYRIGHT
+%%DATADIR%%/doc/ptmalloc2-COPYRIGHT
%%DATADIR%%/doc/romio-users-guide.ps.gz
%%DATADIR%%/mpi.share
-@dirrm include/mpi2c++
+@dirrm include/mpi2cxx
+%%I386%%@dirrm lib/lam
@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%