aboutsummaryrefslogtreecommitdiff
path: root/net/latd
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-23 22:43:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-23 22:43:07 +0000
commitad38e05fb378336e10242c17ac02d036b716bab0 (patch)
treeb8d25d3d03a5ffaa9286df2cfb6d77107258fa4d /net/latd
parent24db010a8f9373e733cbe4ac8bf5fa92d3c5f03d (diff)
downloadports-ad38e05fb378336e10242c17ac02d036b716bab0.tar.gz
ports-ad38e05fb378336e10242c17ac02d036b716bab0.zip
Notes
Diffstat (limited to 'net/latd')
-rw-r--r--net/latd/Makefile28
-rw-r--r--net/latd/distinfo1
-rw-r--r--net/latd/files/patch-interfaces-bpf.cc10
-rw-r--r--net/latd/pkg-descr13
-rw-r--r--net/latd/pkg-plist5
5 files changed, 57 insertions, 0 deletions
diff --git a/net/latd/Makefile b/net/latd/Makefile
new file mode 100644
index 000000000000..f99e07b20dd5
--- /dev/null
+++ b/net/latd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: latd
+# Date created: 19 December 2003
+# Whom: Tillman Hodgson <tillman@seekingfire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latd
+PORTVERSION= 1.19
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= linux-decnet
+
+MAINTAINER= tillman@seekingfire.com
+COMMENT= The linux-decnet project LAT protocol suite
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= llogin.1
+MAN5= latd.conf.5
+MAN8= latd.8 latcp.8 moprc.8
+
+pre-configure:
+ @${CP} ${WRKSRC}/latd.conf ${WRKSRC}/latd.conf.sample
+ @${SED} -i .dist -e 's/sysconf_DATA = latd.conf/sysconf_DATA = latd.conf.sample/' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net/latd/distinfo b/net/latd/distinfo
new file mode 100644
index 000000000000..33c4408437fd
--- /dev/null
+++ b/net/latd/distinfo
@@ -0,0 +1 @@
+MD5 (latd-1.19.tar.gz) = 4ec5969354601d72550d1b4d00af01cd
diff --git a/net/latd/files/patch-interfaces-bpf.cc b/net/latd/files/patch-interfaces-bpf.cc
new file mode 100644
index 000000000000..7f0f9e34ee30
--- /dev/null
+++ b/net/latd/files/patch-interfaces-bpf.cc
@@ -0,0 +1,10 @@
+--- interfaces-bpf.cc.orig Tue Dec 23 23:40:11 2003
++++ interfaces-bpf.cc Tue Dec 23 23:40:32 2003
+@@ -25,6 +25,7 @@
+ #include <sys/time.h>
+ #include <sys/socket.h>
+ #include <sys/uio.h>
++#include <assert.h>
+
+ #include <net/if.h>
+ #include <net/bpf.h>
diff --git a/net/latd/pkg-descr b/net/latd/pkg-descr
new file mode 100644
index 000000000000..9a701d178e88
--- /dev/null
+++ b/net/latd/pkg-descr
@@ -0,0 +1,13 @@
+The linux-decnet project is an effort to bring full DECnet
+support to Linux; however, they also separately offer the latd
+package, a collection of programs that speak Digital's old Local
+Area Terminal (LAT) protocol. These programs enable network
+clients to reach serial devices connected to old LAT-only
+terminal servers, such as the DECserver 200/MC.
+
+This is a redistribution of the linux-decnet project's software,
+with FreeBSD compatability added. It is based very closely on the
+NetBSD port by Matt Fredette and has benefitted from the
+wonderful assistance of Patrick Caulfield (the original author).
+
+WWW: http://linux-decnet.sourceforge.net/
diff --git a/net/latd/pkg-plist b/net/latd/pkg-plist
new file mode 100644
index 000000000000..bbfd153f4901
--- /dev/null
+++ b/net/latd/pkg-plist
@@ -0,0 +1,5 @@
+sbin/latd
+sbin/latcp
+sbin/moprc
+bin/llogin
+etc/latd.conf.sample