aboutsummaryrefslogtreecommitdiff
path: root/net/ldapscripts
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-18 00:32:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-18 00:32:31 +0000
commita244cbd7c3c6265ad2cfd7c61c7e6c8e5002f7bc (patch)
tree19d3759331be2b6968961608fc501203aab7ea6b /net/ldapscripts
parentf5b8b10fecf46184cbfe7caa0b6e519261cc8335 (diff)
downloadports-a244cbd7c3c6265ad2cfd7c61c7e6c8e5002f7bc.tar.gz
ports-a244cbd7c3c6265ad2cfd7c61c7e6c8e5002f7bc.zip
Notes
Diffstat (limited to 'net/ldapscripts')
-rw-r--r--net/ldapscripts/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/ldapscripts/Makefile b/net/ldapscripts/Makefile
index c96a8fb19c20..2a20c772bb27 100644
--- a/net/ldapscripts/Makefile
+++ b/net/ldapscripts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ldapscripts
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://contribs.martymac.com/ldapscripts/
@@ -49,12 +50,15 @@ PORTDOCS= README CHANGELOG COPYING VERSION TODO
# and set paths to OpenLDAP binaries
post-patch:
${REINPLACE_CMD} "s|^all:.*|all:|g" ${WRKSRC}/Makefile
- ${REINPLACE_CMD} "s|^LDAPSEARCHBIN=.*|LDAPSEARCHBIN=\"${LOCALBASE}/bin/ldapsearch\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPADDBIN=.*|LDAPADDBIN=\"${LOCALBASE}/bin/ldapadd\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPDELETEBIN=.*|LDAPDELETEBIN=\"${LOCALBASE}/bin/ldapdelete\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPMODIFYBIN=.*|LDAPMODIFYBIN=\"${LOCALBASE}/bin/ldapmodify\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPMODRDNBIN=.*|LDAPMODRDNBIN=\"${LOCALBASE}/bin/ldapmodrdn\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPPASSWDBIN=.*|LDAPPASSWDBIN=\"${LOCALBASE}/bin/ldappasswd\"|g" ${WRKSRC}/etc/ldapscripts.conf
+ ${REINPLACE_CMD} \
+ -e "s|^LDAPSEARCHBIN=.*|LDAPSEARCHBIN=\"${LOCALBASE}/bin/ldapsearch\"|g" \
+ -e "s|^LDAPADDBIN=.*|LDAPADDBIN=\"${LOCALBASE}/bin/ldapadd\"|g" \
+ -e "s|^LDAPDELETEBIN=.*|LDAPDELETEBIN=\"${LOCALBASE}/bin/ldapdelete\"|g" \
+ -e "s|^LDAPMODIFYBIN=.*|LDAPMODIFYBIN=\"${LOCALBASE}/bin/ldapmodify\"|g" \
+ -e "s|^LDAPMODRDNBIN=.*|LDAPMODRDNBIN=\"${LOCALBASE}/bin/ldapmodrdn\"|g" \
+ -e "s|^LDAPPASSWDBIN=.*|LDAPPASSWDBIN=\"${LOCALBASE}/bin/ldappasswd\"|g" \
+ -e "s|^ICONVBIN=.*|ICONVBIN=\"${LOCALBASE}/bin/iconv\"|g" \
+ ${WRKSRC}/etc/ldapscripts.conf
# Install remaining stuff
post-install: