aboutsummaryrefslogtreecommitdiff
path: root/net/ldapsh
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-07-28 22:36:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-07-28 22:36:54 +0000
commit00be7677b5909fbb9bb8a9feb96bc7f229d30d0e (patch)
tree9f8fc4ae523134dfda9d1012030f50a7efd84626 /net/ldapsh
parentb855dea18d04000f17c2df6f88469faf24fcd54d (diff)
downloadports-00be7677b5909fbb9bb8a9feb96bc7f229d30d0e.tar.gz
ports-00be7677b5909fbb9bb8a9feb96bc7f229d30d0e.zip
Notes
Diffstat (limited to 'net/ldapsh')
-rw-r--r--net/ldapsh/Makefile41
-rw-r--r--net/ldapsh/distinfo2
-rw-r--r--net/ldapsh/pkg-descr12
-rw-r--r--net/ldapsh/pkg-plist17
4 files changed, 72 insertions, 0 deletions
diff --git a/net/ldapsh/Makefile b/net/ldapsh/Makefile
new file mode 100644
index 000000000000..6eb0ddbd16ec
--- /dev/null
+++ b/net/ldapsh/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ldapsh
+# Date created: Jul 28 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldapsh
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= http://madstop.com/ldapsh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Interactive shell used to administer ldap directories
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/ldapsh
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ldapsh ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/examples/LdapConfig.pl ${PREFIX}/etc/LdapConfig.pl.sample
+ ${CP} -r ${WRKSRC}/lib/Net ${SITE_PERL}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/usr/local/bin/perl,${PERL}," ${WRKSRC}/ldapsh
+
+.include <bsd.port.post.mk>
diff --git a/net/ldapsh/distinfo b/net/ldapsh/distinfo
new file mode 100644
index 000000000000..4f2b9ddc7380
--- /dev/null
+++ b/net/ldapsh/distinfo
@@ -0,0 +1,2 @@
+MD5 (ldapsh-1.2.tgz) = 0c4b8583594ddb5ddf6af960a77d1d30
+SIZE (ldapsh-1.2.tgz) = 27095
diff --git a/net/ldapsh/pkg-descr b/net/ldapsh/pkg-descr
new file mode 100644
index 000000000000..e04d6f53dfaa
--- /dev/null
+++ b/net/ldapsh/pkg-descr
@@ -0,0 +1,12 @@
+ldapsh is an interactive shell you can use to administer ldap directories. It
+provides an extensible command mechanism, with most of the necessary builtin
+commands (such as 'clone', 'edit', 'rm'), and it's relatively easy to add more
+commands.
+
+It supports configuring multiple LDAP sources, and storing your UID for each
+source so you don't have to type them each time.
+
+WWW: http://madstop.com/?node=ldapsh
+
+- Florent Thoumie
+flz@xbsd.org
diff --git a/net/ldapsh/pkg-plist b/net/ldapsh/pkg-plist
new file mode 100644
index 000000000000..195d2d900f4f
--- /dev/null
+++ b/net/ldapsh/pkg-plist
@@ -0,0 +1,17 @@
+bin/ldapsh
+etc/LdapConfig.pl.sample
+%%SITE_PERL%%/Net/LDAP/Config.pm
+%%SITE_PERL%%/Net/LDAP/Shell.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/cat.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/clone.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/edit.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/ls.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/new.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/rm.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Commands/stub.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Config.pm.example
+%%SITE_PERL%%/Net/LDAP/Shell/Desc.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Schema.pm
+%%SITE_PERL%%/Net/LDAP/Shell/Util.pm
+@dirrm %%SITE_PERL%%/Net/LDAP/Shell/Commands
+@dirrm %%SITE_PERL%%/Net/LDAP/Shell