aboutsummaryrefslogtreecommitdiff
path: root/net/libarms/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-30 17:53:09 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-30 17:53:09 +0000
commit6a0201f769cf5a5ab19d283b2844f3291599b0f5 (patch)
tree76bc9b834d5da9632432cd06617243132e7de2c1 /net/libarms/Makefile
parentfb8b507ceecd6e1e70f9181fa045b6f395f0d759 (diff)
downloadports-6a0201f769cf5a5ab19d283b2844f3291599b0f5.tar.gz
ports-6a0201f769cf5a5ab19d283b2844f3291599b0f5.zip
Notes
Diffstat (limited to 'net/libarms/Makefile')
-rw-r--r--net/libarms/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/libarms/Makefile b/net/libarms/Makefile
new file mode 100644
index 000000000000..1d23e0b5251d
--- /dev/null
+++ b/net/libarms/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libarms
+# Date created: 27 March 2012
+# Whom: shigeru@iij.ad.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= libarms
+PORTVERSION= 5.01
+CATEGORIES= net devel
+MASTER_SITES= https://dev.smf.jp/dl/ \
+ http://dev.smf.jp/dl/
+
+MAINTAINER= shigeru@iij.ad.jp
+COMMENT= SMFv2/ARMS client library for C
+
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+
+post-configure:
+ @${REINPLACE_CMD} 's|$${datarootdir}/doc/$${PACKAGE_TARNAME}|${DOCSDIR}|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>