aboutsummaryrefslogtreecommitdiff
path: root/net/libdmapsharing
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /net/libdmapsharing
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'net/libdmapsharing')
-rw-r--r--net/libdmapsharing/Makefile41
-rw-r--r--net/libdmapsharing/distinfo2
-rw-r--r--net/libdmapsharing/pkg-descr8
-rw-r--r--net/libdmapsharing/pkg-plist61
4 files changed, 112 insertions, 0 deletions
diff --git a/net/libdmapsharing/Makefile b/net/libdmapsharing/Makefile
new file mode 100644
index 000000000000..59aca72fc8d9
--- /dev/null
+++ b/net/libdmapsharing/Makefile
@@ -0,0 +1,41 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/net/libdmapsharing/Makefile 19962 2014-10-15 14:57:24Z gusi $
+
+PORTNAME= libdmapsharing
+PORTVERSION= 2.9.24
+PORTREVISION= 1
+CATEGORIES= net gnome
+MASTER_SITES= https://www.flyn.org/projects/libdmapsharing/
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME music playing application
+
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala
+
+USES= gettext gmake libtool pathfix pkgconfig
+USE_GNOME= gnomeprefix gtk20 introspection:build
+USE_GSTREAMER1= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-introspection \
+ --with-mdns=avahi
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags gtk+-3.0`
+LDFLAGS+= -L${LOCALBASE}/lib `pkg-config --libs gtk+-3.0`
+INSTALL_TARGET= install-strip
+
+OPTIONS_SUB= yes
+OPTIONS_DEFAULT= AVAHI
+OPTIONS_SINGLE= MDNS
+OPTIONS_SINGLE_MDNS= AVAHI MDNSRESPONDER
+AVAHI_LIB_DEPENDS= libavahi-core.so:${PORTSDIR}/net/avahi-app
+AVAHI_CONFIGURE_ON= --with-mdns=avahi
+MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:${PORTSDIR}/net/mDNSResponder \
+ libavahi-glib.so:${PORTSDIR}/net/avahi-app
+MDNSRESPONDER_CONFIGURE_ON= --with-mdns=mdns
+MDNSRESPONDER_DESC+= Zeroconf support via mDNSResponder (broken)
+
+.include <bsd.port.mk>
diff --git a/net/libdmapsharing/distinfo b/net/libdmapsharing/distinfo
new file mode 100644
index 000000000000..aa029cc45815
--- /dev/null
+++ b/net/libdmapsharing/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/libdmapsharing-2.9.24.tar.gz) = 8d323707a4e6baea9000b5886ba8ea717966ef11fd3e464b77e675a9c49fee36
+SIZE (gnome3/libdmapsharing-2.9.24.tar.gz) = 728305
diff --git a/net/libdmapsharing/pkg-descr b/net/libdmapsharing/pkg-descr
new file mode 100644
index 000000000000..d63a99b0d760
--- /dev/null
+++ b/net/libdmapsharing/pkg-descr
@@ -0,0 +1,8 @@
+Libdmapsharing is a library you may use to access, share and control the
+playback of media content using DMAP (DAAP, DPAP & DACP). Libdmapsharing
+also detects audio AirPlay services; coupled with the AirPlay support
+in PulseAudio or GStreamer, this can allow an application to stream audio
+to an AirPlay device. The library presently supports Linux and other
+POSIX-based systems.
+
+WWW: https://www.flyn.org/projects/libdmapsharing
diff --git a/net/libdmapsharing/pkg-plist b/net/libdmapsharing/pkg-plist
new file mode 100644
index 000000000000..bc5133a267e0
--- /dev/null
+++ b/net/libdmapsharing/pkg-plist
@@ -0,0 +1,61 @@
+include/libdmapsharing-3.0/libdmapsharing/daap-connection.h
+include/libdmapsharing-3.0/libdmapsharing/daap-record.h
+include/libdmapsharing-3.0/libdmapsharing/daap-share.h
+include/libdmapsharing-3.0/libdmapsharing/dacp-connection.h
+include/libdmapsharing-3.0/libdmapsharing/dacp-player.h
+include/libdmapsharing-3.0/libdmapsharing/dacp-share.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-connection.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-container-db.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-container-record.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-db.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-enums.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-gst-input-stream.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-md5.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-mdns-browser.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-mdns-publisher.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-record-factory.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-record.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-share.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-structure.h
+include/libdmapsharing-3.0/libdmapsharing/dmap-utils.h
+include/libdmapsharing-3.0/libdmapsharing/dmap.h
+include/libdmapsharing-3.0/libdmapsharing/dpap-connection.h
+include/libdmapsharing-3.0/libdmapsharing/dpap-record.h
+include/libdmapsharing-3.0/libdmapsharing/dpap-share.h
+lib/libdmapsharing-3.0.so
+lib/libdmapsharing-3.0.so.2
+lib/libdmapsharing-3.0.so.2.9.24
+libdata/pkgconfig/libdmapsharing-3.0.pc
+%%DOCSDIR%%-3.0/api-index-full.html
+%%DOCSDIR%%-3.0/ch01.html
+%%DOCSDIR%%-3.0/deprecated-api-index.html
+%%DOCSDIR%%-3.0/home.png
+%%DOCSDIR%%-3.0/index.html
+%%DOCSDIR%%-3.0/index.sgml
+%%DOCSDIR%%-3.0/left.png
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DAAPRecord.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DACPPlayer.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPContainerDb.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPContainerRecord.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPDb.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPMdnsBrowser.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPRecord.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DMAPRecordFactory.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-DPAPRecord.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-daap-connection.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-daap-share.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dacp-connection.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dacp-share.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-connection.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-enums.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-gst-input-stream.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-gst-mp3-input-stream.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-gst-wav-input-stream.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dmap-share.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dpap-connection.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0-dpap-share.html
+%%DOCSDIR%%-3.0/libdmapsharing-3.0.devhelp2
+%%DOCSDIR%%-3.0/object-tree.html
+%%DOCSDIR%%-3.0/right.png
+%%DOCSDIR%%-3.0/style.css
+%%DOCSDIR%%-3.0/up.png