aboutsummaryrefslogtreecommitdiff
path: root/net/libdnet
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-05 22:11:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-05 22:11:31 +0000
commit39ed019738f461d8f2fe661205be162659c10fb4 (patch)
treeec1b9f819371f03469087ee28c59ee2fb01d008f /net/libdnet
parent3691ea6bb49733a7344392ba822d0d04a1ab33c5 (diff)
downloadports-39ed019738f461d8f2fe661205be162659c10fb4.tar.gz
ports-39ed019738f461d8f2fe661205be162659c10fb4.zip
Notes
Diffstat (limited to 'net/libdnet')
-rw-r--r--net/libdnet/Makefile14
-rw-r--r--net/libdnet/distinfo6
-rw-r--r--net/libdnet/files/patch-configure30
-rw-r--r--net/libdnet/pkg-descr2
-rw-r--r--net/libdnet/pkg-plist1
5 files changed, 10 insertions, 43 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 1f738f239835..13486700f71b 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= libdnet
-PORTVERSION= 1.12
-PORTREVISION= 1
-DISTVERSIONPREFIX= ${PORTNAME}-
+PORTVERSION= 1.13
+DISTVERSIONPREFIX= v
CATEGORIES?= net
MAINTAINER?= onatan@gmail.com
@@ -13,19 +12,16 @@ COMMENT= Simple interface to low level networking routines
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES?= autoreconf libtool
+
USE_GITHUB= yes
-GH_ACCOUNT= dugsong
+GH_ACCOUNT= 5u623l20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_dnet_bsd_bpf=yes
-USES+= libtool
.if !defined(LIBDNET_SLAVE)
CONFIGURE_ARGS+= --without-python
USE_LDCONFIG= yes
.endif
-post-patch:
- @${REINPLACE_CMD} 's|shrext|shrext_cmds|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net/libdnet/distinfo b/net/libdnet/distinfo
index d847e70d1947..071340e8ba4c 100644
--- a/net/libdnet/distinfo
+++ b/net/libdnet/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473875381
-SHA256 (dugsong-libdnet-libdnet-1.12_GH0.tar.gz) = b6360659c93fa2e3cde9e0a1fc9c07bc4111f3448c5de856e095eb98315dd424
-SIZE (dugsong-libdnet-libdnet-1.12_GH0.tar.gz) = 959945
+TIMESTAMP = 1553018633
+SHA256 (5u623l20-libdnet-v1.13_GH0.tar.gz) = 04022817ff3309b09eb1ee1b478d41ac8b53bd14a951a118373701b89b997782
+SIZE (5u623l20-libdnet-v1.13_GH0.tar.gz) = 93336
diff --git a/net/libdnet/files/patch-configure b/net/libdnet/files/patch-configure
deleted file mode 100644
index caa232605ab1..000000000000
--- a/net/libdnet/files/patch-configure
+++ /dev/null
@@ -1,30 +0,0 @@
---- configure.orig 2007-01-20 19:30:22.000000000 +0700
-+++ configure 2018-04-16 18:23:18.054769000 +0700
-@@ -22247,27 +22247,6 @@
- *) LIBOBJS="$LIBOBJS fw-pf.$ac_objext" ;;
- esac
-
--elif test "$ac_cv_header_netinet_ip_fw_h" = yes ; then
-- case "$host_os" in
-- *freebsd5*)
-- case $LIBOBJS in
-- "fw-none.$ac_objext" | \
-- *" fw-none.$ac_objext" | \
-- "fw-none.$ac_objext "* | \
-- *" fw-none.$ac_objext "* ) ;;
-- *) LIBOBJS="$LIBOBJS fw-none.$ac_objext" ;;
--esac
-- ;;
-- *)
-- case $LIBOBJS in
-- "fw-ipfw.$ac_objext" | \
-- *" fw-ipfw.$ac_objext" | \
-- "fw-ipfw.$ac_objext "* | \
-- *" fw-ipfw.$ac_objext "* ) ;;
-- *) LIBOBJS="$LIBOBJS fw-ipfw.$ac_objext" ;;
--esac
-- ;;
-- esac
- elif test "$ac_cv_header_netinet_ip_fil_h" = yes ; then
- case $LIBOBJS in
- "fw-ipf.$ac_objext" | \
diff --git a/net/libdnet/pkg-descr b/net/libdnet/pkg-descr
index 7a1306aba6d8..ae21c970ef5c 100644
--- a/net/libdnet/pkg-descr
+++ b/net/libdnet/pkg-descr
@@ -5,4 +5,4 @@ firewalling, network interface lookup and manipulation, and raw IP
packet and Ethernet frame transmission. It is intended to complement
the functionality provided by pcap(3).
-WWW: https://code.google.com/p/libdnet/
+WWW: https://github.com/5u623l20/libdnet/
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index 8478859d4aa8..8c6c19b06840 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -17,6 +17,7 @@ include/dnet/ip6.h
include/dnet/os.h
include/dnet/rand.h
include/dnet/route.h
+include/dnet/sctp.h
include/dnet/tcp.h
include/dnet/tun.h
include/dnet/udp.h