aboutsummaryrefslogtreecommitdiff
path: root/net/libgnetwork
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-03 05:35:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-05-03 05:35:11 +0000
commit690839683e27b3610449902dc5069e77b29e2533 (patch)
tree6eba94d40cadbc346ec88818fff7902135b62098 /net/libgnetwork
parentfdc8eabdc20c24361fdf99d9d20e2a9d32a508c0 (diff)
downloadports-690839683e27b3610449902dc5069e77b29e2533.tar.gz
ports-690839683e27b3610449902dc5069e77b29e2533.zip
Notes
Diffstat (limited to 'net/libgnetwork')
-rw-r--r--net/libgnetwork/Makefile4
-rw-r--r--net/libgnetwork/files/patch-libgnetwork_gnetwork-tcp-connection.c20
2 files changed, 22 insertions, 2 deletions
diff --git a/net/libgnetwork/Makefile b/net/libgnetwork/Makefile
index d30fb741369c..6cd132c97347 100644
--- a/net/libgnetwork/Makefile
+++ b/net/libgnetwork/Makefile
@@ -22,8 +22,8 @@ USE_GNOME= gnomeprefix gnomehack intlhack gconf2
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=13
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
#.if !defined(WITHOUT_SSL)
#LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
diff --git a/net/libgnetwork/files/patch-libgnetwork_gnetwork-tcp-connection.c b/net/libgnetwork/files/patch-libgnetwork_gnetwork-tcp-connection.c
new file mode 100644
index 000000000000..a700f9f42fa1
--- /dev/null
+++ b/net/libgnetwork/files/patch-libgnetwork_gnetwork-tcp-connection.c
@@ -0,0 +1,20 @@
+--- libgnetwork/gnetwork-tcp-connection.c.orig Mon May 3 01:29:58 2004
++++ libgnetwork/gnetwork-tcp-connection.c Mon May 3 01:32:55 2004
+@@ -450,6 +450,7 @@
+ static void
+ open_ssl_connection (GNetworkTcpConnection * connection)
+ {
++#ifdef _USE_SSL
+ GIOChannel *channel;
+ GNetworkSslAuth *auth;
+ GError *error;
+@@ -517,6 +518,9 @@
+ g_object_notify (G_OBJECT (connection), "tcp-status");
+ g_object_notify (G_OBJECT (connection), "status");
+ g_object_thaw_notify (G_OBJECT (connection));
++#else
++ g_warning ("SSL support not enabled.");
++#endif
+ }
+
+