aboutsummaryrefslogtreecommitdiff
path: root/net/libgweather
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /net/libgweather
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'net/libgweather')
-rw-r--r--net/libgweather/Makefile28
-rw-r--r--net/libgweather/distinfo3
-rw-r--r--net/libgweather/pkg-descr9
-rw-r--r--net/libgweather/pkg-plist170
4 files changed, 210 insertions, 0 deletions
diff --git a/net/libgweather/Makefile b/net/libgweather/Makefile
new file mode 100644
index 000000000000..15fc44ccff56
--- /dev/null
+++ b/net/libgweather/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libgweather
+# Date created: 14th Jan 2008
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net/libgweather/Makefile,v 1.7 2008/03/11 11:45:48 ahze Exp $
+#
+
+PORTNAME= libgweather
+PORTVERSION= 2.22.0
+CATEGORIES= net gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library to accessing online weather informations
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gnomevfs2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gweather.schemas
+
+.include <bsd.port.mk>
diff --git a/net/libgweather/distinfo b/net/libgweather/distinfo
new file mode 100644
index 000000000000..62580528c851
--- /dev/null
+++ b/net/libgweather/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgweather-2.22.0.tar.bz2) = f25d3dada7416bf2d5edb5c7fd7ffce0
+SHA256 (libgweather-2.22.0.tar.bz2) = 4532c8f6938b8f878e20a5fd4069ac7ee9153da28561e74162fc112abfd0f411
+SIZE (libgweather-2.22.0.tar.bz2) = 2785765
diff --git a/net/libgweather/pkg-descr b/net/libgweather/pkg-descr
new file mode 100644
index 000000000000..99ea830ef287
--- /dev/null
+++ b/net/libgweather/pkg-descr
@@ -0,0 +1,9 @@
+libgweather is a library to access weather information from online
+services for numerous locations.
+
+libgweather isn't supported in the devel platform, which means OS vendors
+won't guarantee the API/ABI long-term, but authors of open source apps
+should feel free to use libgweather as users can always recompile against
+a new version.
+
+WWW: http://www.gnome.org/
diff --git a/net/libgweather/pkg-plist b/net/libgweather/pkg-plist
new file mode 100644
index 000000000000..5ffe9ae7e731
--- /dev/null
+++ b/net/libgweather/pkg-plist
@@ -0,0 +1,170 @@
+include/libgweather/gweather-gconf.h
+include/libgweather/gweather-prefs.h
+include/libgweather/weather.h
+lib/libgweather.a
+lib/libgweather.la
+lib/libgweather.so
+lib/libgweather.so.0
+libdata/pkgconfig/gweather.pc
+%%DATADIR%%/Locations.xml
+%%DATADIR%%/locations.dtd
+share/locale/am/LC_MESSAGES/libgweather.mo
+share/locale/ar/LC_MESSAGES/libgweather.mo
+share/locale/as/LC_MESSAGES/libgweather.mo
+share/locale/az/LC_MESSAGES/libgweather.mo
+share/locale/be/LC_MESSAGES/libgweather.mo
+share/locale/be@latin/LC_MESSAGES/libgweather.mo
+share/locale/bg/LC_MESSAGES/libgweather.mo
+share/locale/bn/LC_MESSAGES/libgweather.mo
+share/locale/bn_IN/LC_MESSAGES/libgweather.mo
+share/locale/bs/LC_MESSAGES/libgweather.mo
+share/locale/ca/LC_MESSAGES/libgweather.mo
+share/locale/cs/LC_MESSAGES/libgweather.mo
+share/locale/cy/LC_MESSAGES/libgweather.mo
+share/locale/da/LC_MESSAGES/libgweather.mo
+share/locale/de/LC_MESSAGES/libgweather.mo
+share/locale/dz/LC_MESSAGES/libgweather.mo
+share/locale/el/LC_MESSAGES/libgweather.mo
+share/locale/en_CA/LC_MESSAGES/libgweather.mo
+share/locale/en_GB/LC_MESSAGES/libgweather.mo
+share/locale/es/LC_MESSAGES/libgweather.mo
+share/locale/es_AR/LC_MESSAGES/libgweather.mo
+share/locale/es_CL/LC_MESSAGES/libgweather.mo
+share/locale/es_CO/LC_MESSAGES/libgweather.mo
+share/locale/es_CR/LC_MESSAGES/libgweather.mo
+share/locale/es_DO/LC_MESSAGES/libgweather.mo
+share/locale/es_EC/LC_MESSAGES/libgweather.mo
+share/locale/es_ES/LC_MESSAGES/libgweather.mo
+share/locale/es_GT/LC_MESSAGES/libgweather.mo
+share/locale/es_HN/LC_MESSAGES/libgweather.mo
+share/locale/es_MX/LC_MESSAGES/libgweather.mo
+share/locale/es_NI/LC_MESSAGES/libgweather.mo
+share/locale/es_PA/LC_MESSAGES/libgweather.mo
+share/locale/es_PE/LC_MESSAGES/libgweather.mo
+share/locale/es_PR/LC_MESSAGES/libgweather.mo
+share/locale/es_SV/LC_MESSAGES/libgweather.mo
+share/locale/es_UY/LC_MESSAGES/libgweather.mo
+share/locale/es_VE/LC_MESSAGES/libgweather.mo
+share/locale/et/LC_MESSAGES/libgweather.mo
+share/locale/eu/LC_MESSAGES/libgweather.mo
+share/locale/fa/LC_MESSAGES/libgweather.mo
+share/locale/fi/LC_MESSAGES/libgweather.mo
+share/locale/fr/LC_MESSAGES/libgweather.mo
+share/locale/ga/LC_MESSAGES/libgweather.mo
+share/locale/gl/LC_MESSAGES/libgweather.mo
+share/locale/gu/LC_MESSAGES/libgweather.mo
+share/locale/he/LC_MESSAGES/libgweather.mo
+share/locale/hi/LC_MESSAGES/libgweather.mo
+share/locale/hr/LC_MESSAGES/libgweather.mo
+share/locale/hu/LC_MESSAGES/libgweather.mo
+share/locale/hy/LC_MESSAGES/libgweather.mo
+share/locale/id/LC_MESSAGES/libgweather.mo
+share/locale/is/LC_MESSAGES/libgweather.mo
+share/locale/it/LC_MESSAGES/libgweather.mo
+share/locale/ja/LC_MESSAGES/libgweather.mo
+share/locale/ka/LC_MESSAGES/libgweather.mo
+share/locale/kn/LC_MESSAGES/libgweather.mo
+share/locale/ko/LC_MESSAGES/libgweather.mo
+share/locale/ku/LC_MESSAGES/libgweather.mo
+share/locale/ky/LC_MESSAGES/libgweather.mo
+share/locale/lt/LC_MESSAGES/libgweather.mo
+share/locale/lv/LC_MESSAGES/libgweather.mo
+share/locale/mg/LC_MESSAGES/libgweather.mo
+share/locale/mk/LC_MESSAGES/libgweather.mo
+share/locale/ml/LC_MESSAGES/libgweather.mo
+share/locale/mn/LC_MESSAGES/libgweather.mo
+share/locale/mr/LC_MESSAGES/libgweather.mo
+share/locale/ms/LC_MESSAGES/libgweather.mo
+share/locale/nb/LC_MESSAGES/libgweather.mo
+share/locale/ne/LC_MESSAGES/libgweather.mo
+share/locale/nl/LC_MESSAGES/libgweather.mo
+share/locale/nn/LC_MESSAGES/libgweather.mo
+share/locale/oc/LC_MESSAGES/libgweather.mo
+share/locale/or/LC_MESSAGES/libgweather.mo
+share/locale/pa/LC_MESSAGES/libgweather.mo
+share/locale/pl/LC_MESSAGES/libgweather.mo
+share/locale/pt/LC_MESSAGES/libgweather.mo
+share/locale/pt_BR/LC_MESSAGES/libgweather.mo
+share/locale/ro/LC_MESSAGES/libgweather.mo
+share/locale/ru/LC_MESSAGES/libgweather.mo
+share/locale/rw/LC_MESSAGES/libgweather.mo
+share/locale/si/LC_MESSAGES/libgweather.mo
+share/locale/sk/LC_MESSAGES/libgweather.mo
+share/locale/sl/LC_MESSAGES/libgweather.mo
+share/locale/sq/LC_MESSAGES/libgweather.mo
+share/locale/sr/LC_MESSAGES/libgweather.mo
+share/locale/sr@Latn/LC_MESSAGES/libgweather.mo
+share/locale/sv/LC_MESSAGES/libgweather.mo
+share/locale/ta/LC_MESSAGES/libgweather.mo
+share/locale/te/LC_MESSAGES/libgweather.mo
+share/locale/th/LC_MESSAGES/libgweather.mo
+share/locale/tr/LC_MESSAGES/libgweather.mo
+share/locale/uk/LC_MESSAGES/libgweather.mo
+share/locale/vi/LC_MESSAGES/libgweather.mo
+share/locale/wa/LC_MESSAGES/libgweather.mo
+share/locale/xh/LC_MESSAGES/libgweather.mo
+share/locale/zh_CN/LC_MESSAGES/libgweather.mo
+share/locale/zh_HK/LC_MESSAGES/libgweather.mo
+share/locale/zh_TW/LC_MESSAGES/libgweather.mo
+@dirrm %%DATADIR%%
+@dirrm include/libgweather
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/es_VE/LC_MESSAGES
+@dirrmtry share/locale/es_VE
+@dirrmtry share/locale/es_UY/LC_MESSAGES
+@dirrmtry share/locale/es_UY
+@dirrmtry share/locale/es_SV/LC_MESSAGES
+@dirrmtry share/locale/es_SV
+@dirrmtry share/locale/es_PR/LC_MESSAGES
+@dirrmtry share/locale/es_PR
+@dirrmtry share/locale/es_PE/LC_MESSAGES
+@dirrmtry share/locale/es_PE
+@dirrmtry share/locale/es_PA/LC_MESSAGES
+@dirrmtry share/locale/es_PA
+@dirrmtry share/locale/es_NI/LC_MESSAGES
+@dirrmtry share/locale/es_NI
+@dirrmtry share/locale/es_HN/LC_MESSAGES
+@dirrmtry share/locale/es_HN
+@dirrmtry share/locale/es_GT/LC_MESSAGES
+@dirrmtry share/locale/es_GT
+@dirrmtry share/locale/es_EC/LC_MESSAGES
+@dirrmtry share/locale/es_EC
+@dirrmtry share/locale/es_DO/LC_MESSAGES
+@dirrmtry share/locale/es_DO
+@dirrmtry share/locale/es_CR/LC_MESSAGES
+@dirrmtry share/locale/es_CR
+@dirrmtry share/locale/es_CO/LC_MESSAGES
+@dirrmtry share/locale/es_CO
+@dirrmtry share/locale/es_CL/LC_MESSAGES
+@dirrmtry share/locale/es_CL
+@dirrmtry share/locale/es_AR/LC_MESSAGES
+@dirrmtry share/locale/es_AR
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as