aboutsummaryrefslogtreecommitdiff
path: root/net/libicq2000
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-27 15:17:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-27 15:17:05 +0000
commitb4f05dfc2cda6f36178a66001e31640f200f4663 (patch)
treef1374837e3df358c65a18ea5d73ce3b04693a47c /net/libicq2000
parent7218868189ab088fb4e171c4efd1e6404e3815a4 (diff)
downloadports-b4f05dfc2cda6f36178a66001e31640f200f4663.tar.gz
ports-b4f05dfc2cda6f36178a66001e31640f200f4663.zip
Notes
Diffstat (limited to 'net/libicq2000')
-rw-r--r--net/libicq2000/Makefile41
-rw-r--r--net/libicq2000/distinfo1
-rw-r--r--net/libicq2000/pkg-comment1
-rw-r--r--net/libicq2000/pkg-descr8
-rw-r--r--net/libicq2000/pkg-plist55
5 files changed, 106 insertions, 0 deletions
diff --git a/net/libicq2000/Makefile b/net/libicq2000/Makefile
new file mode 100644
index 000000000000..008205d556e5
--- /dev/null
+++ b/net/libicq2000/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libicq2000
+# Date created: Sat Apr 27 10:36:05 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libicq2000
+PORTVERSION= 0.3.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++
+
+USE_LIBTOOL= yes
+
+MAN1= libicq2000-config.1
+
+DOC_FILES= AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS \
+ TODO
+
+post-patch:
+ @${PERL} -pi -e \
+ 's|^(headersincludedir =).+|\1\$$(includedir)/libicq2000|' \
+ ${WRKSRC}/libicq2000/Makefile.in
+
+post-configure:
+ @${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
+ @${PERL} -pi -e 's|^(install_ltlibs=).*|\1no|' ${WRKSRC}/libtool
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+.include <bsd.port.mk>
diff --git a/net/libicq2000/distinfo b/net/libicq2000/distinfo
new file mode 100644
index 000000000000..7a0ddf51827e
--- /dev/null
+++ b/net/libicq2000/distinfo
@@ -0,0 +1 @@
+MD5 (libicq2000-0.3.1.tar.gz) = 62cca3234d1575af90ab96dc60f73ba6
diff --git a/net/libicq2000/pkg-comment b/net/libicq2000/pkg-comment
new file mode 100644
index 000000000000..240dd4278b20
--- /dev/null
+++ b/net/libicq2000/pkg-comment
@@ -0,0 +1 @@
+An opensource C++ library to support icq2000/2001 protocol
diff --git a/net/libicq2000/pkg-descr b/net/libicq2000/pkg-descr
new file mode 100644
index 000000000000..fb5c05e33f8f
--- /dev/null
+++ b/net/libicq2000/pkg-descr
@@ -0,0 +1,8 @@
+[ from developer's site ]
+libicq2000 is an opensource C++ library being developed to support
+the icq2000/2001 protocol. It is easy for developers to use as the
+backbone for their clients' connection to the ICQ network - all the
+protocol work is abstracted away in one nice object-orientated
+interface.
+
+WWW: http://libicq2000.sourceforge.net/
diff --git a/net/libicq2000/pkg-plist b/net/libicq2000/pkg-plist
new file mode 100644
index 000000000000..75539a324a17
--- /dev/null
+++ b/net/libicq2000/pkg-plist
@@ -0,0 +1,55 @@
+bin/libicq2000-config
+include/libicq2000/Client.h
+include/libicq2000/buffer.h
+include/libicq2000/socket.h
+include/libicq2000/TLV.h
+include/libicq2000/constants.h
+include/libicq2000/SNAC.h
+include/libicq2000/SNAC-base.h
+include/libicq2000/SNAC-BUD.h
+include/libicq2000/SNAC-LOC.h
+include/libicq2000/SNAC-GEN.h
+include/libicq2000/SNAC-UIN.h
+include/libicq2000/SNAC-MSG.h
+include/libicq2000/SNAC-SRV.h
+include/libicq2000/SNAC-SBL.h
+include/libicq2000/SNAC-BOS.h
+include/libicq2000/events.h
+include/libicq2000/Xml.h
+include/libicq2000/Contact.h
+include/libicq2000/ContactList.h
+include/libicq2000/exceptions.h
+include/libicq2000/custom_marshal.h
+include/libicq2000/DirectClient.h
+include/libicq2000/ICQ.h
+include/libicq2000/UserInfoBlock.h
+include/libicq2000/ICBMCookie.h
+include/libicq2000/userinfoconstants.h
+include/libicq2000/Translator.h
+include/libicq2000/Cache.h
+include/libicq2000/RequestIDCache.h
+include/libicq2000/ICBMCookieCache.h
+include/libicq2000/SeqNumCache.h
+include/libicq2000/DCCache.h
+include/libicq2000/version.h
+include/libicq2000/userinfohelpers.h
+include/libicq2000/SocketClient.h
+include/libicq2000/SMTPClient.h
+include/libicq2000/time_extra.h
+include/libicq2000/MessageHandler.h
+include/libicq2000/ref_ptr.h
+include/libicq2000/Capabilities.h
+lib/libicq2000.so.4
+lib/libicq2000.so
+lib/libicq2000.a
+share/aclocal/libicq2000.m4
+%%PORTDOCS%%share/doc/libicq2000/AUTHORS
+%%PORTDOCS%%share/doc/libicq2000/COPYING
+%%PORTDOCS%%share/doc/libicq2000/ChangeLog
+%%PORTDOCS%%share/doc/libicq2000/INSTALL
+%%PORTDOCS%%share/doc/libicq2000/NEWS
+%%PORTDOCS%%share/doc/libicq2000/README
+%%PORTDOCS%%share/doc/libicq2000/THANKS
+%%PORTDOCS%%share/doc/libicq2000/TODO
+%%PORTDOCS%%@dirrm share/doc/libicq2000
+@dirrm include/libicq2000