aboutsummaryrefslogtreecommitdiff
path: root/net/libmateweather
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-04 11:44:30 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-04 11:44:30 +0000
commit0a7668c1332918aa06ca27664ae8c447a553c5fd (patch)
tree37169f4d6a1ec15a3f96493c65cb713e58dc7aee /net/libmateweather
parent1702ea4d9050cc64965b5766671c067e06c781e2 (diff)
Notes
Diffstat (limited to 'net/libmateweather')
-rw-r--r--net/libmateweather/Makefile13
-rw-r--r--net/libmateweather/distinfo5
-rw-r--r--net/libmateweather/files/patch-libmateweather_weather-iwin.c11
-rw-r--r--net/libmateweather/files/patch-libmateweather_weather-metar.c39
-rw-r--r--net/libmateweather/pkg-plist56
5 files changed, 33 insertions, 91 deletions
diff --git a/net/libmateweather/Makefile b/net/libmateweather/Makefile
index 1f95f651c5ba..9058571523fc 100644
--- a/net/libmateweather/Makefile
+++ b/net/libmateweather/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libmateweather
-PORTVERSION= 1.12.1
-PORTREVISION= 1
+PORTVERSION= 1.18.1
CATEGORIES= net mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -14,20 +13,14 @@ COMMENT= Library to accessing online weather informations
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= itstool:textproc/itstool
-LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup
PORTSCOUT= limitw:1,even
USES= gettext gmake libtool localbase pathfix pkgconfig tar:xz
-USE_GNOME= cairo gtk20 libxml2 intlhack
+USE_GNOME= cairo gnomeprefix gtk30 intltool libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-gtk-doc \
- --with-gtk=2.0 \
- --with-html-dir=${PREFIX}/share/doc
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
diff --git a/net/libmateweather/distinfo b/net/libmateweather/distinfo
index 316763465f64..9b3567be14dc 100644
--- a/net/libmateweather/distinfo
+++ b/net/libmateweather/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/libmateweather-1.12.1.tar.xz) = 74aaeb844059ecf7f7aa4314676348750c50212a7c6e5dbbed71793bcd373863
-SIZE (mate/libmateweather-1.12.1.tar.xz) = 3526540
+TIMESTAMP = 1497518746
+SHA256 (mate/libmateweather-1.18.1.tar.xz) = 6af4ca73df3d0589481e74f8be843130359ba071d76195b3c4396d270874db7c
+SIZE (mate/libmateweather-1.18.1.tar.xz) = 3454820
diff --git a/net/libmateweather/files/patch-libmateweather_weather-iwin.c b/net/libmateweather/files/patch-libmateweather_weather-iwin.c
deleted file mode 100644
index ca02969da082..000000000000
--- a/net/libmateweather/files/patch-libmateweather_weather-iwin.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libmateweather/weather-iwin.c.orig 2016-09-29 14:03:12.143111000 +0200
-+++ libmateweather/weather-iwin.c 2016-09-29 14:03:35.883636000 +0200
-@@ -462,7 +462,7 @@ iwin_start_open (WeatherInfo *info)
- zone = g_ascii_strdown (loc->zone, -1);
- state = g_strndup (zone, 2);
-
-- url = g_strdup_printf ("http://weather.noaa.gov/pub/data/forecasts/zone/%s/%s.txt", state, zone);
-+ url = g_strdup_printf ("http://tgftp.nws.noaa.gov/data/forecasts/zone/%s/%s.txt", state, zone);
-
- g_free (zone);
- g_free (state);
diff --git a/net/libmateweather/files/patch-libmateweather_weather-metar.c b/net/libmateweather/files/patch-libmateweather_weather-metar.c
deleted file mode 100644
index aa992cae6df4..000000000000
--- a/net/libmateweather/files/patch-libmateweather_weather-metar.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- libmateweather/weather-metar.c.orig 2016-09-29 14:03:25.503926000 +0200
-+++ libmateweather/weather-metar.c 2016-09-29 14:03:40.232655000 +0200
-@@ -510,7 +510,7 @@ metar_finish (SoupSession *session, Soup
-
- loc = info->location;
-
-- searchkey = g_strdup_printf ("\n%s", loc->code);
-+ searchkey = g_strdup_printf ("<raw_text>%s", loc->code);
- p = strstr (msg->response_body->data, searchkey);
- g_free (searchkey);
- if (p) {
-@@ -522,8 +522,8 @@ metar_finish (SoupSession *session, Soup
- metar = g_strdup (p);
- success = metar_parse (metar, info);
- g_free (metar);
-- } else if (!strstr (msg->response_body->data, "National Weather Service")) {
-- /* The response doesn't even seem to have come from NWS...
-+ } else if (!strstr (msg->response_body->data, "aviationweather.gov")) {
-+ /* The response doesn't even seem to have come from NOAA...
- * most likely it is a wifi hotspot login page. Call that a
- * network error.
- */
-@@ -550,8 +550,14 @@ metar_start_open (WeatherInfo *info)
- }
-
- msg = soup_form_request_new (
-- "GET", "http://weather.noaa.gov/mgetmetar.php",
-- "cccc", loc->code,
-+ "GET", "https://www.aviationweather.gov/adds/dataserver_current/httpparam",
-+ "dataSource", "metars",
-+ "requestType", "retrieve",
-+ "format", "xml",
-+ "hoursBeforeNow", "3",
-+ "mostRecent", "true",
-+ "fields", "raw_text",
-+ "stationString", loc->code,
- NULL);
- soup_session_queue_message (info->session, msg, metar_finish, info);
-
diff --git a/net/libmateweather/pkg-plist b/net/libmateweather/pkg-plist
index 902284915390..ac1f5e010cc9 100644
--- a/net/libmateweather/pkg-plist
+++ b/net/libmateweather/pkg-plist
@@ -10,30 +10,28 @@ lib/libmateweather.so
lib/libmateweather.so.1
lib/libmateweather.so.1.6.9
libdata/pkgconfig/mateweather.pc
-%%DOCSDIR%%/MateWeatherLocation.html
-%%DOCSDIR%%/MateWeatherLocationEntry.html
-%%DOCSDIR%%/MateWeatherTimezone.html
-%%DOCSDIR%%/MateWeatherTimezoneMenu.html
-%%DOCSDIR%%/annotation-glossary.html
-%%DOCSDIR%%/api-index-deprecated.html
-%%DOCSDIR%%/api-index-full.html
-%%DOCSDIR%%/ch01.html
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left-insensitive.png
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/libmateweather-mateweather-mateconf.html
-%%DOCSDIR%%/libmateweather-mateweather-prefs.html
-%%DOCSDIR%%/libmateweather-mateweather-xml.html
-%%DOCSDIR%%/libmateweather-weather.html
-%%DOCSDIR%%/libmateweather.devhelp2
-%%DOCSDIR%%/object-tree.html
-%%DOCSDIR%%/right-insensitive.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up-insensitive.png
-%%DOCSDIR%%/up.png
+%%PORTDOCS%%%%DOCSDIR%%/MateWeatherLocation.html
+%%PORTDOCS%%%%DOCSDIR%%/MateWeatherLocationEntry.html
+%%PORTDOCS%%%%DOCSDIR%%/MateWeatherTimezone.html
+%%PORTDOCS%%%%DOCSDIR%%/MateWeatherTimezoneMenu.html
+%%PORTDOCS%%%%DOCSDIR%%/annotation-glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/api-index-full.html
+%%PORTDOCS%%%%DOCSDIR%%/ch01.html
+%%PORTDOCS%%%%DOCSDIR%%/home.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/left-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%/left.png
+%%PORTDOCS%%%%DOCSDIR%%/libmateweather-mateweather-mateconf.html
+%%PORTDOCS%%%%DOCSDIR%%/libmateweather-mateweather-prefs.html
+%%PORTDOCS%%%%DOCSDIR%%/libmateweather-mateweather-xml.html
+%%PORTDOCS%%%%DOCSDIR%%/libmateweather-weather.html
+%%PORTDOCS%%%%DOCSDIR%%/libmateweather.devhelp2
+%%PORTDOCS%%%%DOCSDIR%%/object-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/right-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%/right.png
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/up-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%/up.png
share/icons/mate/16x16/status/weather-clear-night-000.png
share/icons/mate/16x16/status/weather-clear-night-010.png
share/icons/mate/16x16/status/weather-clear-night-020.png
@@ -478,7 +476,6 @@ share/locale/as/LC_MESSAGES/libmateweather.mo
share/locale/ast/LC_MESSAGES/libmateweather.mo
share/locale/az/LC_MESSAGES/libmateweather.mo
share/locale/be/LC_MESSAGES/libmateweather.mo
-share/locale/be@latin/LC_MESSAGES/libmateweather.mo
share/locale/bg/LC_MESSAGES/libmateweather.mo
share/locale/bn/LC_MESSAGES/libmateweather.mo
share/locale/bn_IN/LC_MESSAGES/libmateweather.mo
@@ -494,7 +491,6 @@ share/locale/da/LC_MESSAGES/libmateweather.mo
share/locale/de/LC_MESSAGES/libmateweather.mo
share/locale/dz/LC_MESSAGES/libmateweather.mo
share/locale/el/LC_MESSAGES/libmateweather.mo
-share/locale/en@shaw/LC_MESSAGES/libmateweather.mo
share/locale/en_AU/LC_MESSAGES/libmateweather.mo
share/locale/en_CA/LC_MESSAGES/libmateweather.mo
share/locale/en_GB/LC_MESSAGES/libmateweather.mo
@@ -507,8 +503,6 @@ share/locale/es_CR/LC_MESSAGES/libmateweather.mo
share/locale/es_DO/LC_MESSAGES/libmateweather.mo
share/locale/es_EC/LC_MESSAGES/libmateweather.mo
share/locale/es_ES/LC_MESSAGES/libmateweather.mo
-share/locale/es_GT/LC_MESSAGES/libmateweather.mo
-share/locale/es_HN/LC_MESSAGES/libmateweather.mo
share/locale/es_MX/LC_MESSAGES/libmateweather.mo
share/locale/es_NI/LC_MESSAGES/libmateweather.mo
share/locale/es_PA/LC_MESSAGES/libmateweather.mo
@@ -522,6 +516,8 @@ share/locale/eu/LC_MESSAGES/libmateweather.mo
share/locale/fa/LC_MESSAGES/libmateweather.mo
share/locale/fi/LC_MESSAGES/libmateweather.mo
share/locale/fr/LC_MESSAGES/libmateweather.mo
+share/locale/fr_CA/LC_MESSAGES/libmateweather.mo
+share/locale/frp/LC_MESSAGES/libmateweather.mo
share/locale/ga/LC_MESSAGES/libmateweather.mo
share/locale/gl/LC_MESSAGES/libmateweather.mo
share/locale/gu/LC_MESSAGES/libmateweather.mo
@@ -534,11 +530,13 @@ share/locale/id/LC_MESSAGES/libmateweather.mo
share/locale/is/LC_MESSAGES/libmateweather.mo
share/locale/it/LC_MESSAGES/libmateweather.mo
share/locale/ja/LC_MESSAGES/libmateweather.mo
+share/locale/jv/LC_MESSAGES/libmateweather.mo
share/locale/ka/LC_MESSAGES/libmateweather.mo
share/locale/kk/LC_MESSAGES/libmateweather.mo
share/locale/kn/LC_MESSAGES/libmateweather.mo
share/locale/ko/LC_MESSAGES/libmateweather.mo
share/locale/ku/LC_MESSAGES/libmateweather.mo
+share/locale/ku_IQ/LC_MESSAGES/libmateweather.mo
share/locale/ky/LC_MESSAGES/libmateweather.mo
share/locale/lt/LC_MESSAGES/libmateweather.mo
share/locale/lv/LC_MESSAGES/libmateweather.mo
@@ -550,7 +548,6 @@ share/locale/mn/LC_MESSAGES/libmateweather.mo
share/locale/mr/LC_MESSAGES/libmateweather.mo
share/locale/ms/LC_MESSAGES/libmateweather.mo
share/locale/nb/LC_MESSAGES/libmateweather.mo
-share/locale/nds/LC_MESSAGES/libmateweather.mo
share/locale/ne/LC_MESSAGES/libmateweather.mo
share/locale/nl/LC_MESSAGES/libmateweather.mo
share/locale/nn/LC_MESSAGES/libmateweather.mo
@@ -575,6 +572,7 @@ share/locale/te/LC_MESSAGES/libmateweather.mo
share/locale/th/LC_MESSAGES/libmateweather.mo
share/locale/tr/LC_MESSAGES/libmateweather.mo
share/locale/uk/LC_MESSAGES/libmateweather.mo
+share/locale/uz/LC_MESSAGES/libmateweather.mo
share/locale/vi/LC_MESSAGES/libmateweather.mo
share/locale/wa/LC_MESSAGES/libmateweather.mo
share/locale/xh/LC_MESSAGES/libmateweather.mo