aboutsummaryrefslogtreecommitdiff
path: root/net/libmms/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-01-09 17:40:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-01-09 17:40:59 +0000
commit75a15e84b74ef331579645fc0bd1ac6b733f83b6 (patch)
treed1b973a370e21eae09810452445da5e2ec5f1af1 /net/libmms/Makefile
parent92542e174327ca6247b2d1d0fff6e5d740a55e33 (diff)
downloadports-75a15e84b74ef331579645fc0bd1ac6b733f83b6.tar.gz
ports-75a15e84b74ef331579645fc0bd1ac6b733f83b6.zip
Notes
Diffstat (limited to 'net/libmms/Makefile')
-rw-r--r--net/libmms/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/libmms/Makefile b/net/libmms/Makefile
new file mode 100644
index 000000000000..e478a74fc098
--- /dev/null
+++ b/net/libmms/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libmms
+# Date created: 25 Dec 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmms
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library for parsing mms:// and mmsh:// type network streams
+
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib.h|' \
+ ${WRKSRC}/src/uri.c
+
+.include <bsd.port.mk>