aboutsummaryrefslogtreecommitdiff
path: root/net/libnet-devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/libnet-devel
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Notes
Notes: svn path=/head/; revision=183770
Diffstat (limited to 'net/libnet-devel')
-rw-r--r--net/libnet-devel/Makefile23
-rw-r--r--net/libnet-devel/files/patch-Makefile.in10
-rw-r--r--net/libnet-devel/files/patch-include__Makefile.in11
-rw-r--r--net/libnet-devel/files/patch-include__libnet__Makefile.in11
-rw-r--r--net/libnet-devel/files/patch-libnet-config.in13
-rw-r--r--net/libnet-devel/files/patch-src__Makefile.in20
-rw-r--r--net/libnet-devel/pkg-plist30
7 files changed, 96 insertions, 22 deletions
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
index 4ef7cabdbe0e..dd445dff8fb3 100644
--- a/net/libnet-devel/Makefile
+++ b/net/libnet-devel/Makefile
@@ -7,43 +7,48 @@
PORTNAME= libnet
PORTVERSION= 1.1.3.r1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.packetfactory.net/libnet/dist/
-PKGNAMESUFFIX= -devel
+PKGNAMESUFFIX= ${SHORT_VER}-devel
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r1$//}-RC-01
MAINTAINER= ports@FreeBSD.org
COMMENT= A C library for creating IP packets (development version)
-CONFLICTS= libnet*-1.*
-
-DEPRECATED= distfile and homepage disappeared
-EXPIRATION_DATE= 2007-01-04
-
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${SHORT_VER}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${SHORT_VER}
DOCS= README doc/BUGS doc/CHANGELOG doc/CONTRIB doc/COPYING \
doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
EXAMPLES= sample/*.c
+SHORT_VER= 113
+
.include <bsd.port.pre.mk>
post-patch:
.if ${OSVERSION} < 500000
- ${REINPLACE_CMD} -e "s|stdint.h|inttypes.h|g" \
+ ${REINPLACE_CMD} -e "s|stdint\.h|inttypes.h|g" \
${WRKSRC}/include/libnet/libnet-types.h
.else
${DO_NADA}
.endif
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config \
+ ${PREFIX}/bin/libnet${SHORT_VER}-config
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ @cd ${PREFIX}/lib && \
+ ${LN} -sf libnet${SHORT_VER}/libnet.so libnet-1.1.3.so.1 && \
+ ${LN} -sf libnet-1.1.3.so.1 libnet-1.1.3.so
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/net/libnet-devel/files/patch-Makefile.in b/net/libnet-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..59863e03e93c
--- /dev/null
+++ b/net/libnet-devel/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- ./Makefile.in.orig Thu Dec 2 21:27:39 2004
++++ ./Makefile.in Sat Jan 20 14:10:35 2007
+@@ -208,7 +208,6 @@
+ DISTCLEANFILES = *~
+ SUBDIRS = include src sample
+ EXTRA_DIST = Makefile.am.common
+-bin_SCRIPTS = libnet-config
+ all: all-recursive
+
+ .SUFFIXES:
diff --git a/net/libnet-devel/files/patch-include__Makefile.in b/net/libnet-devel/files/patch-include__Makefile.in
new file mode 100644
index 000000000000..e427c836bb55
--- /dev/null
+++ b/net/libnet-devel/files/patch-include__Makefile.in
@@ -0,0 +1,11 @@
+--- ./include/Makefile.in.orig Thu Dec 2 21:27:37 2004
++++ ./include/Makefile.in Sat Sep 30 21:22:18 2006
+@@ -171,7 +171,7 @@
+ host_cpu = @host_cpu@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+-includedir = @includedir@
++includedir = @includedir@/libnet113
+ infodir = @infodir@
+ install_sh = @install_sh@
+ libdir = @libdir@
diff --git a/net/libnet-devel/files/patch-include__libnet__Makefile.in b/net/libnet-devel/files/patch-include__libnet__Makefile.in
new file mode 100644
index 000000000000..aa25fbe63ea8
--- /dev/null
+++ b/net/libnet-devel/files/patch-include__libnet__Makefile.in
@@ -0,0 +1,11 @@
+--- ./include/libnet/Makefile.in.orig Thu Dec 2 21:27:37 2004
++++ ./include/libnet/Makefile.in Sat Sep 30 21:23:15 2006
+@@ -163,7 +163,7 @@
+ host_cpu = @host_cpu@
+ host_os = @host_os@
+ host_vendor = @host_vendor@
+-includedir = @includedir@
++includedir = @includedir@/libnet113
+ infodir = @infodir@
+ install_sh = @install_sh@
+ libdir = @libdir@
diff --git a/net/libnet-devel/files/patch-libnet-config.in b/net/libnet-devel/files/patch-libnet-config.in
new file mode 100644
index 000000000000..5e99ee54fa5a
--- /dev/null
+++ b/net/libnet-devel/files/patch-libnet-config.in
@@ -0,0 +1,13 @@
+--- ./libnet-config.in.orig Sat Jan 3 17:31:00 2004
++++ ./libnet-config.in Sat Sep 30 21:20:02 2006
+@@ -8,8 +8,8 @@
+ # @configure_input@
+
+ libnet_defines="@LIBNET_CONFIG_DEFINES@"
+-libnet_cflags="@LIBNET_CONFIG_CFLAGS@"
+-libnet_libs="@LIBNET_CONFIG_LIBS@ -lnet"
++libnet_cflags="@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include/libnet113"
++libnet_libs="@LIBNET_CONFIG_LIBS@ -L@prefix@/lib/libnet113 -lnet"
+
+ usage()
+ {
diff --git a/net/libnet-devel/files/patch-src__Makefile.in b/net/libnet-devel/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..e7032b79c724
--- /dev/null
+++ b/net/libnet-devel/files/patch-src__Makefile.in
@@ -0,0 +1,20 @@
+--- ./src/Makefile.in.orig Thu Dec 2 21:27:39 2004
++++ ./src/Makefile.in Sat Sep 30 22:47:10 2006
+@@ -205,7 +205,7 @@
+ includedir = @includedir@
+ infodir = @infodir@
+ install_sh = @install_sh@
+-libdir = @libdir@
++libdir = @libdir@/libnet113
+ libexecdir = @libexecdir@
+ localstatedir = @localstatedir@
+ mandir = @mandir@
+@@ -273,7 +273,7 @@
+ libnet_write.c
+
+ libnet_la_LIBADD = @LTLIBOBJS@
+-libnet_la_LDFLAGS = -version-info 1:3:1 -Wl
++libnet_la_LDFLAGS = -version-info 1:3:1 -Wl -soname=libnet-1.1.3.so.1
+ all: all-am
+
+ .SUFFIXES:
diff --git a/net/libnet-devel/pkg-plist b/net/libnet-devel/pkg-plist
index 6fb0e60ec242..4fae456a596a 100644
--- a/net/libnet-devel/pkg-plist
+++ b/net/libnet-devel/pkg-plist
@@ -1,15 +1,17 @@
-bin/libnet-config
-include/libnet.h
-include/libnet/libnet-asn1.h
-include/libnet/libnet-functions.h
-include/libnet/libnet-headers.h
-include/libnet/libnet-macros.h
-include/libnet/libnet-structures.h
-include/libnet/libnet-types.h
-lib/libnet.a
-lib/libnet.la
-lib/libnet.so
-lib/libnet.so.1
+bin/libnet113-config
+include/libnet113/libnet.h
+include/libnet113/libnet/libnet-asn1.h
+include/libnet113/libnet/libnet-functions.h
+include/libnet113/libnet/libnet-headers.h
+include/libnet113/libnet/libnet-macros.h
+include/libnet113/libnet/libnet-structures.h
+include/libnet113/libnet/libnet-types.h
+lib/libnet113/libnet.a
+lib/libnet113/libnet.la
+lib/libnet113/libnet.so
+lib/libnet113/libnet.so.1
+lib/libnet-1.1.3.so
+lib/libnet-1.1.3.so.1
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
@@ -67,4 +69,6 @@ lib/libnet.so.1
%%EXAMPLESDIR%%/udp2.c
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/libnet
+@dirrm lib/libnet113
+@dirrm include/libnet113/libnet
+@dirrm include/libnet113