aboutsummaryrefslogtreecommitdiff
path: root/net/libnids
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-06-11 15:05:41 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-06-11 15:05:41 +0000
commitd1a82685009fde804c133cb6e90c090c9579ab73 (patch)
tree345f569ffc7715b277099a9913afed917ec9b4f0 /net/libnids
parentffe1ecf7bbe907f1d3d16909a10f8f1297bcefc6 (diff)
downloadports-d1a82685009fde804c133cb6e90c090c9579ab73.tar.gz
ports-d1a82685009fde804c133cb6e90c090c9579ab73.zip
Notes
Diffstat (limited to 'net/libnids')
-rw-r--r--net/libnids/Makefile4
-rw-r--r--net/libnids/distinfo6
-rw-r--r--net/libnids/files/patch-src::libnids.c16
3 files changed, 22 insertions, 4 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 467af6b9e008..7c556280adff 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= libnids
-PORTVERSION= 1.23
+PORTVERSION= 1.24
CATEGORIES= net security
MASTER_SITES= SF
MAINTAINER= roam@FreeBSD.org
COMMENT= Network monitoring library with TCP/IP reassembly
+LICENSE= GPLv2
+
OPTIONS= LIBNET "Include code requiring libnet" ON \
LIBNET10 "Use the old libnet-1.0.x version" ON \
GLIB2 "Use GLIB2 for multiprocessing support" ON
diff --git a/net/libnids/distinfo b/net/libnids/distinfo
index f6eaac0ef49d..7ebaf25b278d 100644
--- a/net/libnids/distinfo
+++ b/net/libnids/distinfo
@@ -1,3 +1,3 @@
-MD5 (libnids-1.23.tar.gz) = af35e8ef403a0ca95df2da94db856428
-SHA256 (libnids-1.23.tar.gz) = 755cd72483c2cdccbc6634c00de9e2d8666419fd80da36a2bdb3f81657130643
-SIZE (libnids-1.23.tar.gz) = 140975
+MD5 (libnids-1.24.tar.gz) = 72d37c79c85615ffe158aa524d649610
+SHA256 (libnids-1.24.tar.gz) = 314b4793e0902fbf1fdb7fb659af37a3c1306ed1aad5d1c84de6c931b351d359
+SIZE (libnids-1.24.tar.gz) = 151021
diff --git a/net/libnids/files/patch-src::libnids.c b/net/libnids/files/patch-src::libnids.c
new file mode 100644
index 000000000000..e514cf2fdf25
--- /dev/null
+++ b/net/libnids/files/patch-src::libnids.c
@@ -0,0 +1,16 @@
+Description: Do not include the non-existent alloca.h header.
+ I'll forward this patch next week after I write a configure test for it.
+Forwarded: no
+Author: Peter Pentchev <roam@FreeBSD.org>
+Last-Update: 2010-06-011
+
+--- src/libnids.c.orig
++++ src/libnids.c
+@@ -14,7 +14,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <syslog.h>
+-#include <alloca.h>
+ #include <pcap.h>
+ #include <errno.h>
+ #include <config.h>