aboutsummaryrefslogtreecommitdiff
path: root/net/libnids
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-10-29 14:13:08 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-10-29 14:13:08 +0000
commit0021dc6c0c07daa50dd776e13cb69f216757a45f (patch)
tree289119b191ad3bfb5d2658c07cf715a58ce8dc40 /net/libnids
parent186cf0ca05f620ed782fa61fbde5f6a4e5313fb4 (diff)
downloadports-0021dc6c0c07daa50dd776e13cb69f216757a45f.tar.gz
ports-0021dc6c0c07daa50dd776e13cb69f216757a45f.zip
Notes
Diffstat (limited to 'net/libnids')
-rw-r--r--net/libnids/Makefile31
-rw-r--r--net/libnids/distinfo2
-rw-r--r--net/libnids/files/patch-src::libnids.c12
-rw-r--r--net/libnids/pkg-plist10
4 files changed, 30 insertions, 25 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index e134ff12c723..c967466e1698 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -6,29 +6,36 @@
#
PORTNAME= libnids
-PORTVERSION= 1.16
-PORTREVISION= 1
+PORTVERSION= 1.18
CATEGORIES= net security
-MASTER_SITES= http://www.packetfactory.net/projects/libnids/dist/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roam@FreeBSD.org
-COMMENT= "Network monitoring library with TCP/IP reassembly"
+COMMENT= Network monitoring library with TCP/IP reassembly
+.if defined(WITH_LIBNET_DEVEL)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+.else
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+.endif
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
MAN3= libnids.3
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-install:
${INSTALL_DATA} ${WRKSRC}/src/nids.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/src/libnids.a ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README doc/*
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}/
+.endfor
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libnids/distinfo b/net/libnids/distinfo
index a10e765a4f55..c12210953927 100644
--- a/net/libnids/distinfo
+++ b/net/libnids/distinfo
@@ -1 +1 @@
-MD5 (libnids-1.16.tar.gz) = 95497093d0de330be12ddc658ad7decc
+MD5 (libnids-1.18.tar.gz) = 9ee6dcdfac97bae6fe611aa27d2594a5
diff --git a/net/libnids/files/patch-src::libnids.c b/net/libnids/files/patch-src::libnids.c
deleted file mode 100644
index 780e77d973c0..000000000000
--- a/net/libnids/files/patch-src::libnids.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/libnids.c.orig Tue Oct 9 21:13:12 2001
-+++ src/libnids.c Tue Oct 9 21:13:38 2001
-@@ -369,6 +369,9 @@
- return 0;
- }
- switch ((linktype = pcap_datalink(desc))) {
-+ case DLT_NULL:
-+ linkoffset = 4;
-+ break;
- case DLT_EN10MB:
- linkoffset = 14;
- break;
diff --git a/net/libnids/pkg-plist b/net/libnids/pkg-plist
index 529223a735f4..4aba9c55228b 100644
--- a/net/libnids/pkg-plist
+++ b/net/libnids/pkg-plist
@@ -1,2 +1,12 @@
include/nids.h
lib/libnids.a
+%%PORTDOCS%%%%DOCSDIR%%/API.html
+%%PORTDOCS%%%%DOCSDIR%%/API.txt
+%%PORTDOCS%%%%DOCSDIR%%/LINUX
+%%PORTDOCS%%%%DOCSDIR%%/NEW_LIBPCAP
+%%PORTDOCS%%%%DOCSDIR%%/PATCH
+%%PORTDOCS%%%%DOCSDIR%%/PERFORMANCE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TESTS
+%%PORTDOCS%%%%DOCSDIR%%/bugtraq_post
+%%PORTDOCS%%@dirrm %%DOCSDIR%%