aboutsummaryrefslogtreecommitdiff
path: root/net/libpcap/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2004-01-13 18:04:51 +0000
committerBruce M Simpson <bms@FreeBSD.org>2004-01-13 18:04:51 +0000
commitbed768a8999075a9c2b6eb4607db175124f71ed1 (patch)
tree2494fb44b04757031f3b347760658f029a8d0e39 /net/libpcap/Makefile
parentb04e1f2dc86da909896e63689908edaac36df3d1 (diff)
downloadports-bed768a8999075a9c2b6eb4607db175124f71ed1.tar.gz
ports-bed768a8999075a9c2b6eb4607db175124f71ed1.zip
Notes
Diffstat (limited to 'net/libpcap/Makefile')
-rw-r--r--net/libpcap/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 8b2895edeb13..2a9094f7c94e 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -7,9 +7,10 @@
PORTNAME= libpcap
PORTVERSION= 0.8.1
+PORTREVISION= 351
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/beta/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-316
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTREVISION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Ubiquitous network traffic capture library
@@ -22,6 +23,20 @@ MAN3= pcap.3
GNU_CONFIGURE= yes
+.if defined(LIBPCAP_OVERWRITE_BASE)
+PREFIX= /usr
+PKGNAMESUFFIX= -overwrite-base
+MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man
+PLIST_SUB+= NOTBASE="@comment "
+PLIST_SUB+= BASE=""
+EXTRA_PATCHES+= ${FILESDIR}/patchbase-Makefile.in
+PKGMESSAGE= ${FILESDIR}/pkg-message-base
+.else
+PLIST_SUB+= BASE="@comment "
+PLIST_SUB+= NOTBASE=""
+.endif
+
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -30,4 +45,9 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --without-dag
.endif
+.if defined(LIBPCAP_OVERWRITE_BASE)
+post-install:
+ ${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.mk>