aboutsummaryrefslogtreecommitdiff
path: root/net/libpcap
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2004-01-13 18:04:51 +0000
committerBruce M Simpson <bms@FreeBSD.org>2004-01-13 18:04:51 +0000
commitbed768a8999075a9c2b6eb4607db175124f71ed1 (patch)
tree2494fb44b04757031f3b347760658f029a8d0e39 /net/libpcap
parentb04e1f2dc86da909896e63689908edaac36df3d1 (diff)
downloadports-bed768a8999075a9c2b6eb4607db175124f71ed1.tar.gz
ports-bed768a8999075a9c2b6eb4607db175124f71ed1.zip
Notes
Diffstat (limited to 'net/libpcap')
-rw-r--r--net/libpcap/Makefile22
-rw-r--r--net/libpcap/distinfo2
-rw-r--r--net/libpcap/files/patchbase-Makefile.in30
-rw-r--r--net/libpcap/files/pkg-message-base13
-rw-r--r--net/libpcap/pkg-plist2
5 files changed, 67 insertions, 2 deletions
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 8b2895edeb13..2a9094f7c94e 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -7,9 +7,10 @@
PORTNAME= libpcap
PORTVERSION= 0.8.1
+PORTREVISION= 351
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/beta/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-316
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTREVISION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Ubiquitous network traffic capture library
@@ -22,6 +23,20 @@ MAN3= pcap.3
GNU_CONFIGURE= yes
+.if defined(LIBPCAP_OVERWRITE_BASE)
+PREFIX= /usr
+PKGNAMESUFFIX= -overwrite-base
+MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man
+PLIST_SUB+= NOTBASE="@comment "
+PLIST_SUB+= BASE=""
+EXTRA_PATCHES+= ${FILESDIR}/patchbase-Makefile.in
+PKGMESSAGE= ${FILESDIR}/pkg-message-base
+.else
+PLIST_SUB+= BASE="@comment "
+PLIST_SUB+= NOTBASE=""
+.endif
+
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -30,4 +45,9 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --without-dag
.endif
+.if defined(LIBPCAP_OVERWRITE_BASE)
+post-install:
+ ${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.mk>
diff --git a/net/libpcap/distinfo b/net/libpcap/distinfo
index 419564f4b861..1c7c63c8d2b1 100644
--- a/net/libpcap/distinfo
+++ b/net/libpcap/distinfo
@@ -1 +1 @@
-MD5 (libpcap-0.8.1-316.tar.gz) = ab8f17ca785b9e0272f98010dc16e13b
+MD5 (libpcap-0.8.1-351.tar.gz) = 7e40804221dfa9d10a41f129b9edf3b4
diff --git a/net/libpcap/files/patchbase-Makefile.in b/net/libpcap/files/patchbase-Makefile.in
new file mode 100644
index 000000000000..6f234ab0d9d7
--- /dev/null
+++ b/net/libpcap/files/patchbase-Makefile.in
@@ -0,0 +1,30 @@
+--- Makefile.in.orig Thu Jan 8 16:38:30 2004
++++ Makefile.in Thu Jan 8 16:41:40 2004
+@@ -96,13 +96,17 @@
+
+ CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c
+
+-all: libpcap.a
++all: libpcap.a libpcap.so.2
+
+ libpcap.a: $(OBJ)
+ @rm -f $@
+ ar rc $@ $(OBJ) $(LIBS)
+ $(RANLIB) $@
+
++libpcap.so.2: $(OBJ)
++ @rm -f $@
++ $(CC) -shared -Wl,-x -o libpcap.so.2 -Wl,-soname,libpcap.so.2 `lorder *.o | tsort -q`
++
+ scanner.c: $(srcdir)/scanner.l
+ @rm -f $@
+ $(LEX) -t $< > $$$$.$@; mv $$$$.$@ $@
+@@ -154,6 +158,8 @@
+ install:
+ [ -d $(DESTDIR)$(libdir) ] || \
+ (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
++ $(INSTALL_DATA) libpcap.so.2 $(DESTDIR)$(libdir)/libpcap.so.2
++ ln -fs $(DESTDIR)$(libdir)/libpcap.so.2 $(DESTDIR)$(libdir)/libpcap.so
+ $(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a
+ $(RANLIB) $(DESTDIR)$(libdir)/libpcap.a
+ [ -d $(DESTDIR)$(includedir) ] || \
diff --git a/net/libpcap/files/pkg-message-base b/net/libpcap/files/pkg-message-base
new file mode 100644
index 000000000000..9cb9a773b0d3
--- /dev/null
+++ b/net/libpcap/files/pkg-message-base
@@ -0,0 +1,13 @@
+***************************************
+* You might run into troubles running *
+* tcpdump, you should recompile it if *
+* it segfaults: *
+* $ cd /usr/src/usr.sbin/tcpdump *
+* $ make && make install *
+***************************************
+* You can always reinstall the older *
+* libraries via the source directory *
+* of the base system: *
+* $ cd /usr/src/lib/libpcap *
+* $ make && make install *
+***************************************
diff --git a/net/libpcap/pkg-plist b/net/libpcap/pkg-plist
index 209925c86e06..a76804c9577a 100644
--- a/net/libpcap/pkg-plist
+++ b/net/libpcap/pkg-plist
@@ -1,4 +1,6 @@
lib/libpcap.a
+%%BASE%%lib/libpcap.so.2
+%%BASE%%lib/libpcap.so
include/pcap.h
include/pcap-namedb.h
include/pcap-bpf.h