aboutsummaryrefslogtreecommitdiff
path: root/net/libpcapnav/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-04 07:30:37 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-04 07:30:37 +0000
commit0849723e380f04e6f5b783d00a7e636a418c2033 (patch)
treed607a76cd3bed23601a9da267512dab41a6349a2 /net/libpcapnav/Makefile
parent94b7383a089b13291edab8f3e396ea7238302df9 (diff)
downloadports-0849723e380f04e6f5b783d00a7e636a418c2033.tar.gz
ports-0849723e380f04e6f5b783d00a7e636a418c2033.zip
Notes
Diffstat (limited to 'net/libpcapnav/Makefile')
-rw-r--r--net/libpcapnav/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/libpcapnav/Makefile b/net/libpcapnav/Makefile
new file mode 100644
index 000000000000..13e2b019e614
--- /dev/null
+++ b/net/libpcapnav/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libpcapnav
+# Date created: 2004-04-23
+# Whom: Yann Berthier <yb@sainte-barbe.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpcapnav
+PORTVERSION= 0.5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= netdude
+
+MAINTAINER= yb@sainte-barbe.org
+COMMENT= A libpcap wrapper library
+
+CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
+USE_LIBTOOL_VER= 13
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|DOC_MODULE = pcapnav|DOC_MODULE =|' \
+ ${WRKSRC}/docs/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|docs||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>