aboutsummaryrefslogtreecommitdiff
path: root/net/libproxy
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-07-13 11:38:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-07-13 11:38:19 +0000
commit4214583699ccace87efa0dc121ecfcaa63f5ea6d (patch)
tree02cf1b66297546fbb80393f5722227f57f1e3707 /net/libproxy
parent7be00ab876c6ab9a27553dc5165c733a1a3260bd (diff)
downloadports-4214583699ccace87efa0dc121ecfcaa63f5ea6d.tar.gz
ports-4214583699ccace87efa0dc121ecfcaa63f5ea6d.zip
Notes
Diffstat (limited to 'net/libproxy')
-rw-r--r--net/libproxy/files/patch-libproxy_url.cpp10
-rw-r--r--net/libproxy/files/patch-utils-CMakeLists.txt8
2 files changed, 18 insertions, 0 deletions
diff --git a/net/libproxy/files/patch-libproxy_url.cpp b/net/libproxy/files/patch-libproxy_url.cpp
new file mode 100644
index 000000000000..b185b2bd5c21
--- /dev/null
+++ b/net/libproxy/files/patch-libproxy_url.cpp
@@ -0,0 +1,10 @@
+--- libproxy/url.cpp~
++++ libproxy/url.cpp
+@@ -27,6 +27,7 @@
+ #define close _close
+ #endif
+ #include <fcntl.h> // For ::open()
++#include <unistd.h> // For close()
+ #include <cstring> // For memcpy()
+ #include <sstream> // For int/string conversion (using stringstream)
+ #include <cstdio> // For sscanf()
diff --git a/net/libproxy/files/patch-utils-CMakeLists.txt b/net/libproxy/files/patch-utils-CMakeLists.txt
new file mode 100644
index 000000000000..014f04d42c18
--- /dev/null
+++ b/net/libproxy/files/patch-utils-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- utils/CMakeLists.txt~
++++ utils/CMakeLists.txt
+@@ -3,4 +3,5 @@ link_directories(${LIBPROXY_LIBRARY_DIRS
+
+ add_executable(proxy proxy.c)
+ target_link_libraries(proxy libproxy)
++set(CMAKE_C_COMPILER ${CMAKE_CXX_COMPILER})
+ install(TARGETS proxy RUNTIME DESTINATION ${BIN_INSTALL_DIR}) \ No newline at end of file