aboutsummaryrefslogtreecommitdiff
path: root/net/libproxy
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-22 19:59:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-22 19:59:41 +0000
commitca21823b65ea22aea7534e28a607f7b7d2fdcff6 (patch)
tree17c54ee81284568526278b3357e355cf65710ca2 /net/libproxy
parentc5b42d52a34d81c5b85fb406b0ba22ab9d696bc3 (diff)
downloadports-ca21823b65ea22aea7534e28a607f7b7d2fdcff6.tar.gz
ports-ca21823b65ea22aea7534e28a607f7b7d2fdcff6.zip
Update net/libproxy to 0.4.15
* this release switched the build system to cmake * move libproxy-gnome to libproxy-gnome2 for consistency * add new slave libproxy-webkit3 * try to simplify the whole thing * bump revisions in the dependencies Reviewed by: gnome (kwm), mat Differential Revision: https://reviews.freebsd.org/D15655
Notes
Notes: svn path=/head/; revision=473062
Diffstat (limited to 'net/libproxy')
-rw-r--r--net/libproxy/Makefile100
-rw-r--r--net/libproxy/distinfo5
-rw-r--r--net/libproxy/files/patch-CMakeLists.txt31
-rw-r--r--net/libproxy/files/patch-bindings_CMakeLists.txt18
-rw-r--r--net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt35
-rw-r--r--net/libproxy/files/patch-bindings_perl_t_CMakeLists.txt5
-rw-r--r--net/libproxy/files/patch-libproxy_CMakeLists.txt21
-rw-r--r--net/libproxy/files/patch-libproxy_cmake_modules.cmk15
-rw-r--r--net/libproxy/files/patch-libproxy_cmake_modules_config__kde.cmk32
-rw-r--r--net/libproxy/files/patch-libproxy_cmake_pxmodule.cmk20
-rw-r--r--net/libproxy/files/patch-libproxy_test_get-pac-test.cpp18
-rw-r--r--net/libproxy/files/patch-utils_CMakeLists.txt17
12 files changed, 188 insertions, 129 deletions
diff --git a/net/libproxy/Makefile b/net/libproxy/Makefile
index 325de4ed3e6c..4aab937c72fb 100644
--- a/net/libproxy/Makefile
+++ b/net/libproxy/Makefile
@@ -1,9 +1,8 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/libproxy/Makefile,v 1.1 2011/01/12 13:10:52 kwm Exp $
PORTNAME= libproxy
-PORTVERSION= 0.4.12
+PORTVERSION= 0.4.15
PORTREVISION?= 0
CATEGORIES?= net devel
@@ -13,71 +12,54 @@ COMMENT?= Library that provides automatic proxy configuration management
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-CPE_VENDOR= libproxy_project
+USES+= cmake:outsource cpe pathfix pkgconfig
+CPE_VENDOR= libproxy_project
PATHFIX_CMAKELISTSTXT= devfiles.cmk
-USE_GITHUB= yes
-USES+= cmake:outsource cpe pathfix
+USE_GITHUB= yes
-PLIST_SUB+= VERSION=${PORTVERSION}
-
-CMAKE_ARGS= -DBIPR:BOOL=OFF -DWITH_DOTNET:BOOL=OFF \
- -DWITH_NATUS:BOOL=OFF -DWITH_NM:BOOL=OFF \
- -DWITH_VALA:BOOL=ON
-
-.if !defined(LIBPROXY_SLAVE)
-USE_LDCONFIG= yes
-CMAKE_ARGS+= -DWITH_PYTHON:BOOL=OFF -DWITH_PERL:BOOL=OFF \
- -DWITH_GNOME2:BOOL=OFF -DWITH_GNOME3:BOOL=OFF \
- -DWITH_KDE:BOOL=OFF -DWITH_MOZJS:BOOL=OFF \
- -DWITH_WEBKIT:BOOL=OFF -DWITH_WEBKIT3:BOOL=OFF
-.else
-PORTSCOUT= ignore:1
-
-# Libproxy is build for the slave ports, since I haven't been able to find
-# out how to only build optional code with cmake.
-# Patches for this problem are welcome.
+CMAKE_ON+= WITH_VALA
+CMAKE_OFF+= BIPR WITH_DOTNET WITH_NATUS WITH_NM WITH_NMold
-. if ${LIBPROXY_SLAVE}=="python"
-CMAKE_ARGS+= -DWITH_PYTHON:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_PYTHON:BOOL=OFF
-. endif
+# Slave ports.
+LIBPROXY_SLAVES= library gnome2 gnome3 kde mozjs python perl webkit webkit3
-. if ${LIBPROXY_SLAVE}=="perl"
-CMAKE_ARGS+= -DWITH_PERL:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_PERL:BOOL=OFF
-. endif
+# If nothing is set, we're building the library, i.e. this port.
+LIBPROXY_SLAVE?= library
-. if ${LIBPROXY_SLAVE}=="gnome"
-CMAKE_ARGS+= -DWITH_GNOME2:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_GNOME2:BOOL=OFF
-. endif
+PLIST_SUB+= VERSION=${PORTVERSION}
-. if ${LIBPROXY_SLAVE}=="gnome3"
-CMAKE_ARGS+= -DWITH_GNOME3:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_GNOME3:BOOL=OFF
-. endif
+# Activate the wanted module, and deactivate the others
+CMAKE_ON+= WITH_${LIBPROXY_SLAVE:tu}
+CMAKE_OFF+= ${LIBPROXY_SLAVES:N${LIBPROXY_SLAVE}:tu:S/^/WITH_/}
-. if ${LIBPROXY_SLAVE}=="kde"
-CMAKE_ARGS+= -DWITH_KDE:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_KDE:BOOL=OFF
-. endif
+# Setup slave ports.
+.if ${LIBPROXY_SLAVE:Nlibrary}
+USES+= localbase
+LIB_DEPENDS+= libproxy.so:net/libproxy
+DESCR= ${.CURDIR:H}/${PORTNAME}-${LIBPROXY_SLAVE}/pkg-descr
+PLIST= ${.CURDIR:H}/${PORTNAME}-${LIBPROXY_SLAVE}/pkg-plist
+.endif
-. if ${LIBPROXY_SLAVE}=="webkit"
-CMAKE_ARGS+= -DWITH_WEBKIT3:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_WEBKIT3:BOOL=OFF -DWITH_WEBKIT:BOOL=OFF
-. endif
+.if ${LIBPROXY_SLAVE:Mwebkit3}
+# Additionally to WITH_WEBKIT3 also WITH_WEBKIT is required.
+CMAKE_ON+= WITH_WEBKIT
+CMAKE_OFF:= ${CMAKE_OFF:C/WITH_WEBKIT//}
+.endif
-. if ${LIBPROXY_SLAVE}=="mozjs"
-CMAKE_ARGS+= -DWITH_MOZJS:BOOL=ON
-. else
-CMAKE_ARGS+= -DWITH_MOZJS:BOOL=OFF
-. endif
+.include <bsd.port.pre.mk>
+
+# Hackery for the to python backends.
+.if ${LIBPROXY_SLAVE:Mpython}
+. if ${PYTHON_MAJOR_VER} == 2
+CMAKE_ON+= WITH_PYTHON2
+CMAKE_OFF+= WITH_PYTHON3
+CMAKE_ARGS+= -DPYTHON2_EXECUTABLE:FILEPATH=${PYTHON_CMD}
+. else
+CMAKE_ON+= WITH_PYTHON3
+CMAKE_OFF+= WITH_PYTHON2
+. endif
+.else
+CMAKE_OFF+= WITH_PYTHON2 WITH_PYTHON3
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/libproxy/distinfo b/net/libproxy/distinfo
index 660635201224..b0890e89a5a0 100644
--- a/net/libproxy/distinfo
+++ b/net/libproxy/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libproxy-libproxy-0.4.12_GH0.tar.gz) = add9c5e30767c17b00f842f6280d818ece1eb23ab92e1fc68661204c95d7e22b
-SIZE (libproxy-libproxy-0.4.12_GH0.tar.gz) = 87765
+TIMESTAMP = 1499371033
+SHA256 (libproxy-libproxy-0.4.15_GH0.tar.gz) = 18f58b0a0043b6881774187427ead158d310127fc46a1c668ad6d207fb28b4e0
+SIZE (libproxy-libproxy-0.4.15_GH0.tar.gz) = 93084
diff --git a/net/libproxy/files/patch-CMakeLists.txt b/net/libproxy/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f9b7708ac3c3
--- /dev/null
+++ b/net/libproxy/files/patch-CMakeLists.txt
@@ -0,0 +1,31 @@
+As the library is only built in the master port, and therfore missing in the
+build directory for the slave ports, find it via pkg-config and link against it,
+when building a slave.
+
+--- CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
++++ CMakeLists.txt
+@@ -23,6 +23,15 @@ else()
+ set(CMAKE_INSTALL_CONFIG_NAME ${CMAKE_BUILD_TYPE})
+ endif()
+
++# Make building the library optional.
++option(WITH_LIBRARY "Build libproxy.so" ON)
++
++if (NOT WITH_LIBRARY)
++ # For the other ports provide an easy way to link against libproxy.so via PkgConfig::LIBPROXY.
++ find_package(PkgConfig)
++ pkg_check_modules(LIBPROXY libproxy-1.0 REQUIRED IMPORTED_TARGET)
++endif ()
++
+ include(cmake/cpack.cmk)
+ include(cmake/ctest.cmk)
+ include(cmake/paths.cmk)
+@@ -56,5 +65,7 @@ endif()
+
+ # Always build these
+ add_subdirectory(libproxy)
+-add_subdirectory(utils)
++if (WITH_LIBRARY)
++ add_subdirectory(utils)
++endif()
+
diff --git a/net/libproxy/files/patch-bindings_CMakeLists.txt b/net/libproxy/files/patch-bindings_CMakeLists.txt
new file mode 100644
index 000000000000..9fd4fc8862c1
--- /dev/null
+++ b/net/libproxy/files/patch-bindings_CMakeLists.txt
@@ -0,0 +1,18 @@
+Only build the library in the master port.
+
+--- bindings/CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
++++ bindings/CMakeLists.txt
+@@ -20,6 +20,7 @@ if (WITH_PERL)
+ endif()
+
+ # Install Vala bindings / Install only when -DWITH_VALA is passed to cmake.
++if (WITH_LIBRARY)
+ option(WITH_VALA "Enables Vala bindings" OFF)
+ if(WITH_VALA)
+ if (NOT VAPI_DIR)
+@@ -27,4 +28,5 @@ if(WITH_VALA)
+ endif()
+ install(FILES vala/libproxy-1.0.vapi DESTINATION ${VAPI_DIR})
+ set(VAPI_DIR ${VAPI_DIR} CACHE PATH "Vala API directory")
++endif()
+ endif()
diff --git a/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt b/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt
index a6147d01e0ae..b35c965d6e74 100644
--- a/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt
+++ b/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt
@@ -1,21 +1,24 @@
-* Explicitly against libperl.so.x.y.
- This is being discussed in https://github.com/libproxy/libproxy/pull/7.
- We need this for `make stage-qa' to pass, as the Libproxy.so binding uses
- libperl symbols and thus should link against it.
+As the library is only built in the master port, and therfore missing in the
+build directory for the slave ports, find it via pkg-config and link against it,
+when building a slave.
-* Set RPATH in Libproxy.so.
- We do not install libperl.so into ${LOCALBASE}/lib, so the Libproxy.so ELF
- binary must be told the non-default location where it should look for
- libperl.so.x.y.
---- bindings/perl/src/CMakeLists.txt.orig 2016-01-12 16:41:07 UTC
+--- bindings/perl/src/CMakeLists.txt.orig 2018-06-03 17:39:41 UTC
+++ bindings/perl/src/CMakeLists.txt
-@@ -12,7 +12,8 @@ set(Libproxy_LIB_SRCS Libproxy.c)
+@@ -4,7 +4,7 @@ include_directories( ${PERL_INCLUDE_PATH} ${CMAKE_SOUR
+ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/Libproxy.c
+ COMMAND ${PERL_EXECUTABLE} ARGS ${CMAKE_CURRENT_SOURCE_DIR}/doxsubpp.pl
+ ${PERL_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/Libproxy.xs ${CMAKE_CURRENT_BINARY_DIR}/Libproxy.c
+- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Libproxy.xs libproxy
++ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Libproxy.xs
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
+
+ set(Libproxy_LIB_SRCS Libproxy.c)
+@@ -12,7 +12,7 @@ set(Libproxy_LIB_SRCS Libproxy.c)
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/perl/blib/arch/auto/Net)
add_library(PLlibproxy SHARED ${Libproxy_LIB_SRCS})
--target_link_libraries(PLlibproxy libproxy pthread)
-+target_link_libraries(PLlibproxy ${PERL_LIBRARY} libproxy pthread)
-+set_target_properties(PLlibproxy PROPERTIES INSTALL_RPATH "${PERL_INCLUDE_DIR}")
- set_target_properties(PLlibproxy PROPERTIES OUTPUT_NAME "Libproxy")
- set_target_properties(PLlibproxy PROPERTIES PREFIX "")
-
+-set(PLlibproxy_LIB_DEPENDENCIES libproxy pthread)
++set(PLlibproxy_LIB_DEPENDENCIES PkgConfig::LIBPROXY pthread)
+ if(PERL_LINK_LIBPERL)
+ set(PLlibproxy_LIB_DEPENDENCIES ${PERL_LIBRARY} ${PLlibproxy_LIB_DEPENDENCIES})
+ endif()
diff --git a/net/libproxy/files/patch-bindings_perl_t_CMakeLists.txt b/net/libproxy/files/patch-bindings_perl_t_CMakeLists.txt
new file mode 100644
index 000000000000..e95a4e0b4339
--- /dev/null
+++ b/net/libproxy/files/patch-bindings_perl_t_CMakeLists.txt
@@ -0,0 +1,5 @@
+--- bindings/perl/t/CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
++++ bindings/perl/t/CMakeLists.txt
+@@ -1 +1 @@
+-add_custom_target(test prove -b ${CMAKE_CURRENT_SOURCE_DIR})
++add_custom_target(test_perl prove -b ${CMAKE_CURRENT_SOURCE_DIR})
diff --git a/net/libproxy/files/patch-libproxy_CMakeLists.txt b/net/libproxy/files/patch-libproxy_CMakeLists.txt
index ade8a7d19e33..2272e5db4bd2 100644
--- a/net/libproxy/files/patch-libproxy_CMakeLists.txt
+++ b/net/libproxy/files/patch-libproxy_CMakeLists.txt
@@ -16,9 +16,9 @@ In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:569:19: error: use of undeclared identifier 'isascii'
if (!(isascii(*__low) && (__tab_[static_cast<int>(*__low)] & __m)))
^
---- libproxy/CMakeLists.txt.orig 2016-01-12 16:41:07 UTC
+--- libproxy/CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
+++ libproxy/CMakeLists.txt
-@@ -6,7 +6,6 @@ set_project_version(0 4 12)
+@@ -6,18 +6,19 @@ set_project_version(0 4 15)
if (WIN32)
add_definitions(-D_CRT_SECURE_NO_WARNINGS=1)
else(WIN32)
@@ -26,3 +26,20 @@ In file included from /usr/include/c++/v1/ios:216:
set(CMAKE_CXX_FLAGS "-fvisibility=hidden ${CMAKE_CXX_FLAGS}")
endif(WIN32)
+ ### Modules
+ include(cmake/modules.cmk)
+
+-### Dev files
+-include(cmake/devfiles.cmk)
++if(WITH_LIBRARY)
++ ### Dev files
++ include(cmake/devfiles.cmk)
+
+-### Main library
+-include(cmake/libproxy.cmk)
++ ### Main library
++ include(cmake/libproxy.cmk)
++endif()
+
+ ### Tests
+ add_testdirectory(test)
diff --git a/net/libproxy/files/patch-libproxy_cmake_modules.cmk b/net/libproxy/files/patch-libproxy_cmake_modules.cmk
deleted file mode 100644
index a18651fd1f1a..000000000000
--- a/net/libproxy/files/patch-libproxy_cmake_modules.cmk
+++ /dev/null
@@ -1,15 +0,0 @@
-Use only the value of WITH_KDE to determine whether to build config_kde.
-
-See the changes in patch-libproxy_cmake_modules_config__kde.cmk for more
-information.
---- libproxy/cmake/modules.cmk.orig 2016-01-18 19:41:03 UTC
-+++ libproxy/cmake/modules.cmk
-@@ -32,7 +32,7 @@ px_module(config_envvar "${EN
- px_module(config_sysconfig "${SYSCONFIG_FOUND}" 1)
- px_module(config_gnome "${GNOME2_FOUND}" 0)
- px_module(config_gnome3 "${GNOME3_FOUND}" 0)
--px_module(config_kde "${KDE_FOUND}" 0)
-+px_module(config_kde "${WITH_KDE}" 0)
- px_module(config_macosx "${SC_FOUND}" 1 ${SC_LIBRARIES} ${CF_LIBRARIES})
- px_module(config_w32reg "${WIN32}" 1)
- px_module(ignore_domain 1 1)
diff --git a/net/libproxy/files/patch-libproxy_cmake_modules_config__kde.cmk b/net/libproxy/files/patch-libproxy_cmake_modules_config__kde.cmk
deleted file mode 100644
index d0e51fa10cae..000000000000
--- a/net/libproxy/files/patch-libproxy_cmake_modules_config__kde.cmk
+++ /dev/null
@@ -1,32 +0,0 @@
-commit f30191930114cc334e02bb471f2c547198cad91c
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Jan 18 20:19:09 2016 +0100
-
- config_kde: Decide whether to build the module based only on WITH_KDE.
-
- kreadconfig/kreadconfig5 are runtime dependencies only. As such, there
- should not be a build-time dependency on those in CMake at all. In other
- words, building without those binaries works perfectly fine, and they
- are only required when running libproxy.
-
-commit 8ca0db36983e9154c808288fea4cbdfc9a7ea4c5
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Jan 18 16:59:28 2016 +0100
-
- Make the KDE config module optional again.
-
- This is a follow-up to bd9bf72 ("Add generic KDE config module"): make
- it possible for distributions to not build the KDE config module at all,
- even if it does not have any dependencies on Qt/KDE/KF5.
---- libproxy/cmake/modules/config_kde.cmk.orig 2016-01-12 16:41:07 UTC
-+++ libproxy/cmake/modules/config_kde.cmk
-@@ -1,6 +1,4 @@
--find_program(KDE4_CONF kreadconfig)
--find_program(KF5_CONF kreadconfig5)
-+option(WITH_KDE "Build module to read proxy settings from KDE4/KF5" ON)
-
--if (KDE4_CONF OR KF5_CONF)
-- set(KDE_FOUND 1)
--endif()
-+# There are no additional detections; kreadconfig (from KDE4) and kreadconfig5
-+# (from KF5) are only needed at runtime.
diff --git a/net/libproxy/files/patch-libproxy_cmake_pxmodule.cmk b/net/libproxy/files/patch-libproxy_cmake_pxmodule.cmk
new file mode 100644
index 000000000000..044fbd66b830
--- /dev/null
+++ b/net/libproxy/files/patch-libproxy_cmake_pxmodule.cmk
@@ -0,0 +1,20 @@
+As the library is only built in the master port, and therfore missing in the
+build directory for the slave ports, find it via pkg-config and link against it,
+when building a slave.
+
+--- libproxy/cmake/pxmodule.cmk.orig 2017-05-11 09:33:33 UTC
++++ libproxy/cmake/pxmodule.cmk
+@@ -18,7 +18,12 @@ function(px_module name build builtin)
+ set(built "m")
+ set_property(SOURCE modules/${name}.cpp PROPERTY COMPILE_DEFINITIONS LIBEXECDIR="${LIBEXECDIR}")
+ add_library(${name} MODULE modules/${name}.cpp)
+- target_link_libraries(${name} libproxy)
++ link_directories(${CMAKE_INSTALL_PREFIX}/lib)
++ if (WITH_LIBRARY)
++ target_link_libraries(${name} proxy)
++ else ()
++ target_link_libraries(${name} PkgConfig::LIBPROXY)
++ endif ()
+ set_target_properties(${name} PROPERTIES PREFIX "")
+ install(TARGETS ${name} LIBRARY DESTINATION ${MODULE_INSTALL_DIR})
+ if(${ARGC} GREATER 3)
diff --git a/net/libproxy/files/patch-libproxy_test_get-pac-test.cpp b/net/libproxy/files/patch-libproxy_test_get-pac-test.cpp
index 963f8f56b6f8..8baef77dae6d 100644
--- a/net/libproxy/files/patch-libproxy_test_get-pac-test.cpp
+++ b/net/libproxy/files/patch-libproxy_test_get-pac-test.cpp
@@ -1,12 +1,15 @@
+First hunk:
libc++ doesn't like "using namespace std" in C++11
libproxy/test/get-pac-test.cpp:48:10: error: assigning to 'int' from incompatible type '__bind<int &, sockaddr *, unsigned long>'
ret = bind(m_sock, (sockaddr*)&addr, sizeof (struct sockaddr_in));
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+Second hunk:
+Fix typo.
---- libproxy/test/get-pac-test.cpp.orig 2016-01-12 16:41:07 UTC
-+++ libproxy/test/get-pac-test.cpp
-@@ -45,7 +45,7 @@ class TestServer {
+--- libproxy/test/get-pac-test.cpp.orig 2017-05-11 11:33:33.000000000 +0200
++++ libproxy/test/get-pac-test.cpp 2018-06-02 14:32:22.796000000 +0200
+@@ -52,7 +52,7 @@
setsockopt(m_sock, SOL_SOCKET, SO_REUSEADDR, &i, sizeof(i));
@@ -15,3 +18,12 @@ libproxy/test/get-pac-test.cpp:48:10: error: assigning to 'int' from incompatibl
assert(!ret);
ret = listen(m_sock, 1);
+@@ -130,7 +130,7 @@
+
+ #ifdef SO_NOSIGPIPE
+ int i = 1;
+- setsockopt(c_sock, SOL_SOCKET, SO_NOSIGPIPE, &i, sizeof(i));
++ setsockopt(csock, SOL_SOCKET, SO_NOSIGPIPE, &i, sizeof(i));
+ #endif
+
+ // Read request
diff --git a/net/libproxy/files/patch-utils_CMakeLists.txt b/net/libproxy/files/patch-utils_CMakeLists.txt
new file mode 100644
index 000000000000..0e92372a0191
--- /dev/null
+++ b/net/libproxy/files/patch-utils_CMakeLists.txt
@@ -0,0 +1,17 @@
+As the library is only built in the master port, and therfore missing in the
+build directory for the slave ports, find it via pkg-config and link against it,
+when building a slave.
+
+--- utils/CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
++++ utils/CMakeLists.txt
+@@ -1,5 +1,9 @@
+ include_directories("../libproxy")
+
+ add_executable(proxy proxy.c)
+-target_link_libraries(proxy libproxy)
++if (WITH_LIBRARY)
++ target_link_libraries(proxy libproxy)
++else ()
++ target_link_libraries(proxy PkgConfig::LIBPROXY)
++endif ()
+ install(TARGETS proxy RUNTIME DESTINATION ${BIN_INSTALL_DIR})