aboutsummaryrefslogtreecommitdiff
path: root/net/librdkafka
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-07-24 11:14:40 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-07-24 11:14:40 +0000
commitaa1e9823f197f0bc3811299279a23480aeffd2c4 (patch)
tree9c27ff61397965f93dfd39222d8287a5ae0eff3e /net/librdkafka
parentd888d61cc06e652164d1c26d3cf09c9f72b583fe (diff)
Notes
Diffstat (limited to 'net/librdkafka')
-rw-r--r--net/librdkafka/Makefile32
-rw-r--r--net/librdkafka/distinfo2
-rw-r--r--net/librdkafka/pkg-descr8
-rw-r--r--net/librdkafka/pkg-plist9
4 files changed, 51 insertions, 0 deletions
diff --git a/net/librdkafka/Makefile b/net/librdkafka/Makefile
new file mode 100644
index 000000000000..a1697ef9188d
--- /dev/null
+++ b/net/librdkafka/Makefile
@@ -0,0 +1,32 @@
+# Created by: Victor Yagofarov <xnasx@yandex.ru>
+# $FreeBSD$
+
+PORTNAME= librdkafka
+PORTVERSION= 0.8.6
+CATEGORIES= net
+DISTNAME= ${GH_ACCOUNT}-${PORTNAME}-${PORTVERSION}-${GH_TAGNAME}
+
+MAINTAINER= xnasx@yandex.ru
+COMMENT= Apache Kafka C/C++ library
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GITHUB= yes
+GH_ACCOUNT= edenhill
+GH_TAGNAME= e3d984849a
+
+USE_LDCONFIG= yes
+
+USES= gmake perl5
+GNU_CONFIGURE= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/rdkafka.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/librdkafka.pc
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librdkafka.so.1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librdkafka++.so.1
+
+.include <bsd.port.mk>
diff --git a/net/librdkafka/distinfo b/net/librdkafka/distinfo
new file mode 100644
index 000000000000..300b69b73588
--- /dev/null
+++ b/net/librdkafka/distinfo
@@ -0,0 +1,2 @@
+SHA256 (edenhill-librdkafka-0.8.6-e3d984849a_GH0.tar.gz) = 8a0383ad377f9067ed76e5198fce1729d6e08b2603bd1e1e9064cb57f0c8be4d
+SIZE (edenhill-librdkafka-0.8.6-e3d984849a_GH0.tar.gz) = 202170
diff --git a/net/librdkafka/pkg-descr b/net/librdkafka/pkg-descr
new file mode 100644
index 000000000000..a11f9afb1e9d
--- /dev/null
+++ b/net/librdkafka/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of librdkafka, a C library implementation
+of the Apache Kafka protocol, containing both Producer and
+Consumer support. It was designed with message delivery
+reliability and high performance in mind, current figures
+exceed 800000 msgs/second for the producer and 3 million
+msgs/second for the consumer.
+
+WWW: https://github.com/edenhill/librdkafka/
diff --git a/net/librdkafka/pkg-plist b/net/librdkafka/pkg-plist
new file mode 100644
index 000000000000..3937c10a44b9
--- /dev/null
+++ b/net/librdkafka/pkg-plist
@@ -0,0 +1,9 @@
+include/librdkafka/rdkafka.h
+include/librdkafka/rdkafkacpp.h
+lib/librdkafka++.a
+lib/librdkafka++.so
+lib/librdkafka++.so.1
+lib/librdkafka.a
+lib/librdkafka.so
+lib/librdkafka.so.1
+libdata/pkgconfig/librdkafka.pc